summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-office')
-rw-r--r--app-office/koffice/Manifest4
-rw-r--r--app-office/koffice/koffice-1.3_beta3.ebuild36
2 files changed, 38 insertions, 2 deletions
diff --git a/app-office/koffice/Manifest b/app-office/koffice/Manifest
index 9beb6ac8831b..e87ccf6c8dda 100644
--- a/app-office/koffice/Manifest
+++ b/app-office/koffice/Manifest
@@ -8,8 +8,8 @@ MD5 9a620860de6fc04a27efe67c76f8c71d koffice-1.2-r2.ebuild 963
MD5 d043a27656d6972c3eff302c3278642d koffice-1.3_beta1.ebuild 1241
MD5 8d25144bc3f609caab76c82bc069a66b koffice-1.2_rc1.ebuild 847
MD5 a0e94b795d07efc85539ea4ea091a5ba koffice-1.1.1.ebuild 1141
-MD5 0723379dd69598c7d141785fd1a38e7d ChangeLog 4537
-MD5 fb6a5e03de157439070e31a0fc4ab2eb koffice-1.3_beta3.ebuild 1023
+MD5 4e4fab387f62640da72b98e9e56233c2 ChangeLog 4538
+MD5 2c635c379088841ed105511faa1d4ce7 koffice-1.3_beta3.ebuild 1023
MD5 9ac6e869b89945991aa610d979745f09 metadata.xml 225
MD5 7eb5f8e0051bdfa9d39ddc41d0f2b11e files/digest-koffice-1.2_beta2 71
MD5 362c1081c562d8405d25be71122ca125 files/koffice-1.2-connectortool.diff 493
diff --git a/app-office/koffice/koffice-1.3_beta3.ebuild b/app-office/koffice/koffice-1.3_beta3.ebuild
new file mode 100644
index 000000000000..8e7a5a65b3f8
--- /dev/null
+++ b/app-office/koffice/koffice-1.3_beta3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/koffice/koffice-1.3_beta3.ebuild,v 1.1 2003/08/26 15:07:27 caleb Exp $
+inherit kde-base flag-o-matic
+
+# TODO : mysql support
+# other refs from configure: jasper, qt-docs, doxygen, libxml2, libxslt, freetype, fontconfig, qt being built with sql support (???)
+
+filter-flags "-fomit-frame-pointer"
+
+need-kde 3
+
+MY_P=${PN}-1.2.92
+
+DESCRIPTION="A free, integrated office suite for KDE, the K Desktop Environment."
+HOMEPAGE="http://www.koffice.org/"
+LICENSE="GPL-2 LGPL-2"
+SRC_URI="mirror://kde/unstable/${MY_P}/src/${MY_P}.tar.bz2"
+
+S="$WORKDIR/${MY_P}"
+
+KEYWORDS="~x86"
+
+DEPEND="$DEPEND
+ >=dev-lang/python-2.2.1
+ >=media-libs/libart_lgpl-2.3.9
+ >=media-gfx/imagemagick-5.4.5
+ >=app-text/wv2-0.0.9
+ dev-util/pkgconfig"
+
+export LIBPYTHON="`python-config --libs`"
+export LIBPYTHON="${LIBPYTHON//-L \/usr\/lib\/python2.2\/config}"
+
+need-automake 1.5
+need-autoconf 2.5
+