summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-office/khacc/khacc-1.7.9.ebuild')
-rw-r--r--app-office/khacc/khacc-1.7.9.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-office/khacc/khacc-1.7.9.ebuild b/app-office/khacc/khacc-1.7.9.ebuild
new file mode 100644
index 000000000000..3b7fb95bf10a
--- /dev/null
+++ b/app-office/khacc/khacc-1.7.9.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/khacc/khacc-1.7.9.ebuild,v 1.1 2004/05/01 17:22:44 centic Exp $
+
+inherit kde
+need-kde 3
+
+newdepend "=app-office/qhacc-2.9.9"
+
+DESCRIPTION="KDE personal accounting system based on QHacc."
+HOMEPAGE="http://qhacc.sourceforge.net"
+SRC_URI="mirror://sourceforge/qhacc/${P}.tar.gz"
+
+KEYWORDS="~x86 ~sparc"
+LICENSE="GPL-2"
+
+IUSE=""
+SLOT="0"
+
+src_compile() {
+ myconf="$myconf --with-qhacc-includes=/usr/include --with-qhacc-libs=/usr/lib --with-qhacc-config=/usr/bin"
+ kde_src_compile
+}
+
+pkg_postinst() {
+ einfo "Copy the files in /etc/qhacc to ~/.qhacc,
+ You have to run this program with the command:
+ khacc -f ~/.qhacc/
+ I prefer to put this in my .bashrc
+ alias khacc=\"khacc -f ~/.qhacc\""
+}
+