summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/uptimed/uptimed-0.3.16.ebuild')
-rw-r--r--app-misc/uptimed/uptimed-0.3.16.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-misc/uptimed/uptimed-0.3.16.ebuild b/app-misc/uptimed/uptimed-0.3.16.ebuild
new file mode 100644
index 000000000000..bd00302095de
--- /dev/null
+++ b/app-misc/uptimed/uptimed-0.3.16.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/uptimed/uptimed-0.3.16.ebuild,v 1.1 2009/01/02 12:05:01 armin76 Exp $
+
+inherit autotools
+
+DESCRIPTION="System uptime record daemon that keeps track of your highest uptimes"
+HOMEPAGE="http://podgorny.cz/uptimed"
+SRC_URI="http://podgorny.cz/uptimed/releases/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # respect DESTDIR
+ sed -i -e 's|-d \(/var/spool.*\)$|-d $(DESTDIR)\1|' Makefile.am || \
+ die "sed failed."
+
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ keepdir /var/spool/uptimed
+ dodoc ChangeLog README TODO AUTHORS CREDITS INSTALL.cgi sample-cgi/*
+ doinitd "${FILESDIR}"/uptimed
+}
+
+pkg_postinst() {
+ echo
+ elog "Start uptimed with '/etc/init.d/uptimed start'"
+ elog "To view your uptime records, use the command 'uprecords'."
+ echo
+}