summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/regex-markup/regex-markup-0.10.0.ebuild')
-rw-r--r--app-misc/regex-markup/regex-markup-0.10.0.ebuild26
1 files changed, 18 insertions, 8 deletions
diff --git a/app-misc/regex-markup/regex-markup-0.10.0.ebuild b/app-misc/regex-markup/regex-markup-0.10.0.ebuild
index 7d187578ad6b..0c6f5bdf4df2 100644
--- a/app-misc/regex-markup/regex-markup-0.10.0.ebuild
+++ b/app-misc/regex-markup/regex-markup-0.10.0.ebuild
@@ -1,6 +1,10 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/regex-markup/regex-markup-0.10.0.ebuild,v 1.3 2008/05/11 14:00:00 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/regex-markup/regex-markup-0.10.0.ebuild,v 1.4 2012/06/20 12:23:18 jlec Exp $
+
+EAPI=4
+
+inherit eutils
DESCRIPTION="A tool to color syslog files as well"
HOMEPAGE="http://www.nongnu.org/regex-markup/"
@@ -9,16 +13,22 @@ SRC_URI="http://savannah.nongnu.org/download/regex-markup/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ppc x86"
-IUSE="examples"
+IUSE="examples nls"
-DEPEND=""
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-locale.patch
+}
+
+src_configure() {
+ econf \
+ --enable-largefile \
+ $(use_enable nls)
+}
src_install() {
- make DESTDIR="${D}" install || die "make install failed"
+ default
if use examples; then
cd examples
- make -f Makefile
- cd ..
+ emake -f Makefile
fi
- dodoc AUTHORS ChangeLog NEWS README TODO
}