summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/gtypist/gtypist-2.7.ebuild')
-rw-r--r--app-misc/gtypist/gtypist-2.7.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-misc/gtypist/gtypist-2.7.ebuild b/app-misc/gtypist/gtypist-2.7.ebuild
new file mode 100644
index 000000000000..eb084f5294d4
--- /dev/null
+++ b/app-misc/gtypist/gtypist-2.7.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/gtypist/gtypist-2.7.ebuild,v 1.1 2003/11/04 21:51:27 usata Exp $
+
+DESCRIPTION="universal typing tutor"
+SRC_URI="mirror://gnu/gtypist/${P}.tar.gz"
+HOMEPAGE="http://www.gnu.org/software/gtypist/gtypist.html"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+IUSE="nls"
+
+DEPEND=">=sys-libs/ncurses-5.2"
+
+src_compile() {
+ # gtypist also produces some Emacs/XEmacs editing modes if
+ # emacs/xemacs is present. if emacs/xemacs is not present then
+ # these emacs modes are not compiled or installed.
+ econf `use_enable nls` || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc ABOUT-NLS AUTHORS COPYING ChangeLog INSTALL NEWS README TODO THANKS
+}