summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-laptop/tpctl/tpctl-4.4.ebuild')
-rw-r--r--app-laptop/tpctl/tpctl-4.4.ebuild25
1 files changed, 13 insertions, 12 deletions
diff --git a/app-laptop/tpctl/tpctl-4.4.ebuild b/app-laptop/tpctl/tpctl-4.4.ebuild
index 39998f63f043..c5c9cf2a7a63 100644
--- a/app-laptop/tpctl/tpctl-4.4.ebuild
+++ b/app-laptop/tpctl/tpctl-4.4.ebuild
@@ -1,27 +1,29 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-laptop/tpctl/tpctl-4.4.ebuild,v 1.2 2004/06/24 22:00:48 agriffis Exp $
-
-IUSE="ncurses tpctlir perl"
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/tpctl/tpctl-4.4.ebuild,v 1.3 2004/06/28 02:37:53 vapier Exp $
#transform P to match tarball versioning
MYPV=${PV/_beta/beta}
MYP="${PN}_${MYPV}"
DESCRIPTION="Thinkpad system control user space programs"
-SRC_URI="mirror://sourceforge/tpctl/${MYP}.tar.gz"
HOMEPAGE="http://tpctl.sourceforge.net/tpctlhome.htm"
-KEYWORDS="-* x86"
-SLOT="0"
+SRC_URI="mirror://sourceforge/tpctl/${MYP}.tar.gz"
+
LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* x86"
+IUSE="ncurses tpctlir perl"
-DEPEND="$DEPEND >=app-laptop/thinkpad-4.3 ncurses? ( sys-libs/ncurses )"
-RDEPEND="$RDEPEND >=app-laptop/thinkpad-4.3 ncurses? ( sys-libs/ncurses ) perl? ( dev-lang/perl )"
+DEPEND=">=app-laptop/thinkpad-4.3
+ ncurses? ( sys-libs/ncurses )"
+RDEPEND="${DEPEND}
+ perl? ( dev-lang/perl )"
src_compile() {
emake -C lib || die "lib make failed"
emake -C tpctl || die "tpctl make failed"
- if use ncurses > /dev/null; then
+ if use ncurses ; then
emake -C ntpctl || die "ntpctl make failed"
fi
@@ -34,8 +36,7 @@ src_compile() {
}
src_install() {
- dodoc AUTHORS COPYING ChangeLog README SUPPORTED-MODELS TROUBLESHOOTING \
- VGA-MODES
+ dodoc AUTHORS ChangeLog README SUPPORTED-MODELS TROUBLESHOOTING VGA-MODES
dolib lib/libsmapidev.so.2.0
dobin tpctl/tpctl
[ -e ntpctl/ntpctl ] && dobin ntpctl/ntpctl
@@ -44,7 +45,7 @@ src_install() {
dodoc README.tpctlir
dobin tpctlir/tpctlir
fi
- if use perl > /dev/null; then
+ if use perl ; then
mv apmiser/README README.apmiser
dodoc README.apmiser
dosbin apmiser/apmiser