summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-laptop/pommed/files/pommed-1.11.patch')
-rw-r--r--app-laptop/pommed/files/pommed-1.11.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/app-laptop/pommed/files/pommed-1.11.patch b/app-laptop/pommed/files/pommed-1.11.patch
new file mode 100644
index 000000000000..0dcb368bb5de
--- /dev/null
+++ b/app-laptop/pommed/files/pommed-1.11.patch
@@ -0,0 +1,21 @@
+diff -ru pommed-1.11~/pommed/Makefile pommed-1.11/pommed/Makefile
+--- pommed-1.11~/pommed/Makefile 2007-11-18 22:41:53.000000000 +0100
++++ pommed-1.11/pommed/Makefile 2007-11-18 22:44:05.000000000 +0100
+@@ -16,7 +16,7 @@
+
+ INOTIFY_CFLAGS = $(shell test -e /usr/include/sys/inotify.h || echo -DNO_SYS_INOTIFY_H)
+
+-CFLAGS = -g -O2 -Wall $(DBUS_CFLAGS) $(ALSA_CFLAGS) $(AUDIOFILE_CFLAGS) $(CONFUSE_CFLAGS) $(INOTIFY_CFLAGS)
++CFLAGS += -g -Wall $(DBUS_CFLAGS) $(ALSA_CFLAGS) $(AUDIOFILE_CFLAGS) $(CONFUSE_CFLAGS) $(INOTIFY_CFLAGS)
+
+ ifeq ($(ARCH), ppc)
+ OFLIB ?=
+@@ -41,7 +41,7 @@
+
+ else
+
+-LDFLAGS = -lz -lsmbios $(DBUS_LIBS) $(ALSA_LIBS) $(AUDIOFILE_LIBS) $(CONFUSE_LIBS)
++LDFLAGS = -lz -lsmbios -lstdc++ $(DBUS_LIBS) $(ALSA_LIBS) $(AUDIOFILE_LIBS) $(CONFUSE_LIBS)
+
+ SOURCES = pommed.c cd_eject.c evdev.c conffile.c audio.c dbus.c power.c beep.c \
+ mactel/x1600_backlight.c mactel/gma950_backlight.c \