summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-laptop/hdaps-gl/hdaps-gl-0.0.5.ebuild')
-rw-r--r--app-laptop/hdaps-gl/hdaps-gl-0.0.5.ebuild16
1 files changed, 9 insertions, 7 deletions
diff --git a/app-laptop/hdaps-gl/hdaps-gl-0.0.5.ebuild b/app-laptop/hdaps-gl/hdaps-gl-0.0.5.ebuild
index cbb00de3b22e..6074616abbf9 100644
--- a/app-laptop/hdaps-gl/hdaps-gl-0.0.5.ebuild
+++ b/app-laptop/hdaps-gl/hdaps-gl-0.0.5.ebuild
@@ -1,8 +1,10 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-laptop/hdaps-gl/hdaps-gl-0.0.5.ebuild,v 1.3 2011/10/02 20:44:52 hanno Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/hdaps-gl/hdaps-gl-0.0.5.ebuild,v 1.4 2011/10/07 20:52:12 hanno Exp $
-inherit eutils
+EAPI=4
+
+inherit eutils toolchain-funcs
DESCRIPTION="OpenGL visualization for HDAPS data"
HOMEPAGE="http://hdaps.sourceforge.net"
@@ -17,14 +19,14 @@ DEPEND="virtual/opengl
media-libs/freeglut"
RDEPEND="${DEPEND}"
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}/${P}-as-needed.diff" || die
+src_prepare() {
+ epatch "${FILESDIR}/${P}-as-needed.diff"
}
src_compile() {
- emake CFLAGS="${CFLAGS} ${LDFLAGS}" || die "make failed"
+ emake CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS} ${LDFLAGS}" \
+ || die "emake failed"
}
src_install() {