summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/ibus-skk/ChangeLog9
-rw-r--r--app-i18n/ibus-skk/ibus-skk-0.0.4.ebuild47
-rw-r--r--app-i18n/ibus-table/ChangeLog11
-rw-r--r--app-i18n/ibus-table/ibus-table-1.2.0.20090804.ebuild47
-rw-r--r--app-i18n/ibus-table/ibus-table-1.2.0.20100111.ebuild (renamed from app-i18n/ibus-table/ibus-table-1.2.0.20090625.ebuild)16
-rw-r--r--app-i18n/ibus/ChangeLog10
-rw-r--r--app-i18n/ibus/ibus-1.2.0.20100111.ebuild103
7 files changed, 181 insertions, 62 deletions
diff --git a/app-i18n/ibus-skk/ChangeLog b/app-i18n/ibus-skk/ChangeLog
index 751a5a2f0ab2..4d6bbc2c7c77 100644
--- a/app-i18n/ibus-skk/ChangeLog
+++ b/app-i18n/ibus-skk/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-i18n/ibus-skk
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-skk/ChangeLog,v 1.3 2009/12/31 06:20:58 matsuu Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-skk/ChangeLog,v 1.4 2010/01/13 13:33:28 matsuu Exp $
+
+*ibus-skk-0.0.4 (13 Jan 2010)
+
+ 13 Jan 2010; MATSUU Takuto <matsuu@gentoo.org> +ibus-skk-0.0.4.ebuild:
+ Version bumped.
*ibus-skk-0.0.3 (31 Dec 2009)
diff --git a/app-i18n/ibus-skk/ibus-skk-0.0.4.ebuild b/app-i18n/ibus-skk/ibus-skk-0.0.4.ebuild
new file mode 100644
index 000000000000..372ab4982cc4
--- /dev/null
+++ b/app-i18n/ibus-skk/ibus-skk-0.0.4.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-skk/ibus-skk-0.0.4.ebuild,v 1.1 2010/01/13 13:33:28 matsuu Exp $
+
+EAPI="2"
+
+inherit python
+
+DESCRIPTION="Japanese input method Anthy IMEngine for IBus Framework"
+HOMEPAGE="http://github.com/ueno/ibus-skk"
+SRC_URI="http://cloud.github.com/downloads/ueno/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+
+RDEPEND="app-i18n/ibus
+ >=dev-lang/python-2.5
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ nls? ( >=sys-devel/gettext-0.16.1 )"
+RDEPEND="${RDEPEND}
+ app-i18n/skk-jisyo"
+
+src_prepare() {
+ mv py-compile py-compile.orig || die
+ ln -s "$(type -P true)" py-compile || die
+}
+
+src_configure() {
+ econf $(use_enable nls) || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc AUTHORS ChangeLog NEWS README THANKS TODO || die
+}
+
+pkg_postinst() {
+ python_mod_optimize /usr/share/${PN}
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/share/${PN}
+}
diff --git a/app-i18n/ibus-table/ChangeLog b/app-i18n/ibus-table/ChangeLog
index 5f0ddf78d302..5c4a01f6ae9b 100644
--- a/app-i18n/ibus-table/ChangeLog
+++ b/app-i18n/ibus-table/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-i18n/ibus-table
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-table/ChangeLog,v 1.18 2009/09/07 23:19:51 matsuu Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-table/ChangeLog,v 1.19 2010/01/13 13:29:00 matsuu Exp $
+
+*ibus-table-1.2.0.20100111 (13 Jan 2010)
+
+ 13 Jan 2010; MATSUU Takuto <matsuu@gentoo.org>
+ -ibus-table-1.2.0.20090625.ebuild, -ibus-table-1.2.0.20090804.ebuild,
+ +ibus-table-1.2.0.20100111.ebuild:
+ Version bumped. Removed old versions.
*ibus-table-1.2.0.20090904 (07 Sep 2009)
diff --git a/app-i18n/ibus-table/ibus-table-1.2.0.20090804.ebuild b/app-i18n/ibus-table/ibus-table-1.2.0.20090804.ebuild
deleted file mode 100644
index ad60d6d75e99..000000000000
--- a/app-i18n/ibus-table/ibus-table-1.2.0.20090804.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-table/ibus-table-1.2.0.20090804.ebuild,v 1.1 2009/08/04 14:24:33 matsuu Exp $
-
-EAPI="2"
-inherit eutils python
-
-DESCRIPTION="The Table Engine for IBus Framework"
-HOMEPAGE="http://code.google.com/p/ibus/"
-SRC_URI="http://ibus.googlecode.com/files/${P}.tar.gz"
-
-LICENSE="GPL-2 LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="minimal nls"
-
-RDEPEND=">=app-i18n/ibus-1.1
- >=dev-lang/python-2.5[sqlite]
- nls? ( virtual/libintl )"
-DEPEND="${RDEPEND}
- nls? ( >=sys-devel/gettext-0.16.1 )
- dev-util/pkgconfig"
-
-src_prepare() {
- mv py-compile py-compile.orig || die
- ln -s "$(type -P true)" py-compile || die
-}
-
-src_configure() {
- econf \
- $(use_enable !minimal additional) \
- $(use_enable nls) || die
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
-
- dodoc AUTHORS ChangeLog NEWS README
-}
-
-pkg_postinst() {
- python_mod_optimize /usr/share/${PN}/engine
-}
-
-pkg_postrm() {
- python_mod_cleanup /usr/share/${PN}/engine
-}
diff --git a/app-i18n/ibus-table/ibus-table-1.2.0.20090625.ebuild b/app-i18n/ibus-table/ibus-table-1.2.0.20100111.ebuild
index b26d205a0d05..080a6654a581 100644
--- a/app-i18n/ibus-table/ibus-table-1.2.0.20090625.ebuild
+++ b/app-i18n/ibus-table/ibus-table-1.2.0.20100111.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-table/ibus-table-1.2.0.20090625.ebuild,v 1.1 2009/07/04 00:16:06 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-table/ibus-table-1.2.0.20100111.ebuild,v 1.1 2010/01/13 13:29:00 matsuu Exp $
EAPI="2"
-inherit eutils python
+inherit python
DESCRIPTION="The Table Engine for IBus Framework"
HOMEPAGE="http://code.google.com/p/ibus/"
@@ -12,10 +12,10 @@ SRC_URI="http://ibus.googlecode.com/files/${P}.tar.gz"
LICENSE="GPL-2 LGPL-2.1"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="minimal nls"
+IUSE="nls"
-RDEPEND=">=app-i18n/ibus-1.1
- >=dev-lang/python-2.5[sqlite]
+RDEPEND=">=app-i18n/ibus-1.2
+ =dev-lang/python-2*[sqlite]
nls? ( virtual/libintl )"
DEPEND="${RDEPEND}
nls? ( >=sys-devel/gettext-0.16.1 )
@@ -27,9 +27,7 @@ src_prepare() {
}
src_configure() {
- econf \
- $(use_enable !minimal additional) \
- $(use_enable nls) || die
+ econf $(use_enable nls) --disable-additional || die
}
src_install() {
diff --git a/app-i18n/ibus/ChangeLog b/app-i18n/ibus/ChangeLog
index ad28d62368ae..8dada01241ad 100644
--- a/app-i18n/ibus/ChangeLog
+++ b/app-i18n/ibus/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-i18n/ibus
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus/ChangeLog,v 1.49 2009/12/31 09:59:23 matsuu Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus/ChangeLog,v 1.50 2010/01/13 13:27:51 matsuu Exp $
+
+*ibus-1.2.0.20100111 (13 Jan 2010)
+
+ 13 Jan 2010; MATSUU Takuto <matsuu@gentoo.org>
+ +ibus-1.2.0.20100111.ebuild:
+ Version bumped.
*ibus-1.2.0.20091225-r1 (31 Dec 2009)
diff --git a/app-i18n/ibus/ibus-1.2.0.20100111.ebuild b/app-i18n/ibus/ibus-1.2.0.20100111.ebuild
new file mode 100644
index 000000000000..b7c583520813
--- /dev/null
+++ b/app-i18n/ibus/ibus-1.2.0.20100111.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus/ibus-1.2.0.20100111.ebuild,v 1.1 2010/01/13 13:27:51 matsuu Exp $
+
+EAPI="1"
+inherit eutils gnome2-utils multilib python
+
+DESCRIPTION="Intelligent Input Bus for Linux / Unix OS"
+HOMEPAGE="http://code.google.com/p/ibus/"
+SRC_URI="http://ibus.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc nls"
+
+RDEPEND=">=dev-libs/glib-2.18
+ >=x11-libs/gtk+-2
+ >=gnome-base/gconf-2.12
+ >=gnome-base/librsvg-2
+ sys-apps/dbus
+ app-text/iso-codes
+ x11-libs/libX11
+ >=dev-lang/python-2.5
+ >=dev-python/pygobject-2.14
+ dev-python/notify-python
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ >=dev-lang/perl-5.8.1
+ dev-perl/XML-Parser
+ dev-util/pkgconfig
+ doc? ( >=dev-util/gtk-doc-1.9 )
+ nls? ( >=sys-devel/gettext-0.16.1 )"
+RDEPEND="${RDEPEND}
+ dev-python/pygtk
+ >=dev-python/dbus-python-0.83
+ dev-python/pyxdg"
+
+RESTRICT="test"
+
+pkg_setup() {
+ # An arch specific config directory is used on multilib systems
+ has_multilib_profile && GTK2_CONFDIR="/etc/gtk-2.0/${CHOST}"
+ GTK2_CONFDIR=${GTK2_CONFDIR:=/etc/gtk-2.0/}
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ mv py-compile py-compile.orig || die
+ ln -s "$(type -P true)" py-compile || die
+ echo "ibus/_config.py" >> po/POTFILES.skip || die
+}
+
+src_compile() {
+ econf \
+ $(use_enable doc gtk-doc) \
+ $(use_enable nls) || die
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ # bug 289547
+ keepdir /usr/share/ibus/{engine,icons}
+
+ dodoc AUTHORS ChangeLog NEWS README
+}
+
+pkg_postinst() {
+
+ elog "To use ibus, you should:"
+ elog "1. Get input engines from sunrise overlay."
+ elog " Run \"emerge -s ibus-\" in your favorite terminal"
+ elog " for a list of packages we already have."
+ elog
+ elog "2. Setup ibus:"
+ elog
+ elog " $ ibus-setup"
+ elog
+ elog "3. Set the following in your user startup scripts"
+ elog " such as .xinitrc, .xsession or .xprofile:"
+ elog
+ elog " export XMODIFIERS=\"@im=ibus\""
+ elog " export GTK_IM_MODULE=\"ibus\""
+ elog " export QT_IM_MODULE=\"xim\""
+ elog " ibus-daemon -d -x"
+
+ [ "${ROOT}" = "/" -a -x /usr/bin/gtk-query-immodules-2.0 ] && \
+ gtk-query-immodules-2.0 > "${ROOT}/${GTK2_CONFDIR}/gtk.immodules"
+
+ python_mod_optimize /usr/share/${PN}
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ [ "${ROOT}" = "/" -a -x /usr/bin/gtk-query-immodules-2.0 ] && \
+ gtk-query-immodules-2.0 > "${ROOT}/${GTK2_CONFDIR}/gtk.immodules"
+
+ python_mod_cleanup /usr/share/${PN}
+ gnome2_icon_cache_update
+}