summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-i18n/scim-anthy/scim-anthy-1.2.1.ebuild')
-rw-r--r--app-i18n/scim-anthy/scim-anthy-1.2.1.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/app-i18n/scim-anthy/scim-anthy-1.2.1.ebuild b/app-i18n/scim-anthy/scim-anthy-1.2.1.ebuild
new file mode 100644
index 000000000000..874adb7c6b13
--- /dev/null
+++ b/app-i18n/scim-anthy/scim-anthy-1.2.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim-anthy/scim-anthy-1.2.1.ebuild,v 1.1 2006/10/15 16:03:27 matsuu Exp $
+
+inherit libtool
+
+DESCRIPTION="Japanese input method Anthy IMEngine for SCIM"
+HOMEPAGE="http://scim-imengine.sourceforge.jp/index.cgi?cmd=view;name=SCIMAnthy"
+SRC_URI="mirror://sourceforge.jp/scim-imengine/21967/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="nls"
+
+DEPEND="|| ( >=app-i18n/scim-1.2 >=app-i18n/scim-cvs-1.2 )
+ || ( >=app-i18n/anthy-5900 >=app-i18n/anthy-ss-5911 )
+ nls? ( virtual/libintl )"
+RDEPEND="${DEPEND}
+ app-dicts/kasumi"
+DEPEND="${DEPEND}
+ nls? ( sys-devel/gettext )
+ dev-util/pkgconfig"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ elibtoolize
+}
+
+src_compile() {
+ econf \
+ $(use_enable nls) \
+ --disable-static \
+ --disable-dependency-tracking || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc AUTHORS THANKS README
+}
+
+pkg_postinst() {
+ einfo
+ einfo "To use SCIM, you should use the following in your user startup scripts"
+ einfo "such as .gnomerc or .xinitrc:"
+ einfo
+ einfo "LANG='your_language' scim -d"
+ einfo "export XMODIFIERS=@im=SCIM"
+ einfo "export GTK_IM_MODULE=scim"
+ einfo "export QT_IM_MODULE=scim"
+ einfo
+}