summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-i18n/prime/prime-0.9.2-r1.ebuild')
-rw-r--r--app-i18n/prime/prime-0.9.2-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-i18n/prime/prime-0.9.2-r1.ebuild b/app-i18n/prime/prime-0.9.2-r1.ebuild
new file mode 100644
index 000000000000..96eefa32934a
--- /dev/null
+++ b/app-i18n/prime/prime-0.9.2-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/prime/prime-0.9.2-r1.ebuild,v 1.1 2004/11/30 06:46:16 usata Exp $
+
+inherit ruby eutils
+
+DESCRIPTION="Japanese PRedictive Input Method Editor"
+HOMEPAGE="http://taiyaki.org/prime/"
+SRC_URI="http://prime.sourceforge.jp/src/${P/_/-}.tar.gz"
+
+LICENSE="GPL-2"
+# 0.8.X -> stable, 0.9.Y -> development; dictionary format may change
+# between releases in development branch, so please use it with care
+SLOT="0"
+KEYWORDS="~alpha ~ppc ~x86"
+IUSE="emacs"
+
+DEPEND="virtual/ruby
+ app-dicts/prime-dict
+ >=dev-libs/suikyo-1.3.0
+ dev-ruby/ruby-progressbar"
+PDEPEND="emacs? ( app-emacs/prime-el )"
+
+PATCHES="${FILESDIR}/${P}-pkgconfig.patch"
+
+S="${WORKDIR}/${P/_/-}"
+
+RUBY_ECONF="--with-prime-docdir=/usr/share/doc/${PF}/html
+ --with-rubydir=/usr/lib/ruby/site_ruby"
+
+src_compile() {
+ ruby_src_compile -j1
+}
+
+src_install() {
+ make DESTDIR=${D} install install-etc || die
+
+ erubydoc
+}