summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/simh')
-rw-r--r--app-emulation/simh/ChangeLog7
-rw-r--r--app-emulation/simh/Manifest5
-rw-r--r--app-emulation/simh/files/digest-simh-3.3.01
-rw-r--r--app-emulation/simh/files/makefile.patch11
-rw-r--r--app-emulation/simh/metadata.xml9
-rw-r--r--app-emulation/simh/simh-3.3.0.ebuild47
6 files changed, 80 insertions, 0 deletions
diff --git a/app-emulation/simh/ChangeLog b/app-emulation/simh/ChangeLog
new file mode 100644
index 000000000000..34bbfcb4bfc0
--- /dev/null
+++ b/app-emulation/simh/ChangeLog
@@ -0,0 +1,7 @@
+# ChangeLog for app-emulation/simh
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/simh/ChangeLog,v 1.1 2005/08/27 20:59:39 rphillips Exp $
+
+ 27 Aug 2005; <rphillips@gentoo.org> :
+ New ebuild. Thanks to Emil Skoldberg. Fixes #73996
+
diff --git a/app-emulation/simh/Manifest b/app-emulation/simh/Manifest
new file mode 100644
index 000000000000..af5e9895e8dc
--- /dev/null
+++ b/app-emulation/simh/Manifest
@@ -0,0 +1,5 @@
+MD5 24ce35f1d11838c35c482ea4fb750a19 simh-3.3.0.ebuild 950
+MD5 8d29123aba71179ef9974e37c84c16a2 ChangeLog 306
+MD5 1652522405f5936eb29776ef8d5ffa5b metadata.xml 310
+MD5 1dc0c3f3a27cb7fb307f8d027cb65f85 files/makefile.patch 383
+MD5 ff5b80de0c6ccbeb7007cd208b3882d1 files/digest-simh-3.3.0 59
diff --git a/app-emulation/simh/files/digest-simh-3.3.0 b/app-emulation/simh/files/digest-simh-3.3.0
new file mode 100644
index 000000000000..d378ff063629
--- /dev/null
+++ b/app-emulation/simh/files/digest-simh-3.3.0
@@ -0,0 +1 @@
+MD5 a8262f17ddd24e63bfdf04e3e9fc442b simhv33-0.zip 2153444
diff --git a/app-emulation/simh/files/makefile.patch b/app-emulation/simh/files/makefile.patch
new file mode 100644
index 000000000000..15cd4406a17e
--- /dev/null
+++ b/app-emulation/simh/files/makefile.patch
@@ -0,0 +1,11 @@
+--- simh/makefile 2004-12-09 15:37:34.823634965 +0000
++++ simh.new/makefile 2004-12-09 15:38:34.401562833 +0000
+@@ -13,7 +13,7 @@
+ CC = gcc -std=c99 -O2 -g -lm $(OS_CCDEFS) -I .
+ ifeq ($(USE_NETWORK),)
+ else
+-NETWORK_OPT = -DUSE_NETWORK -isystem /usr/local/include /usr/local/lib/libpcap.a
++NETWORK_OPT = -DUSE_NETWORK -DNEED_PCAP_SENDPACKET -lpcap
+ endif
+ else
+ #Win32 Environments
diff --git a/app-emulation/simh/metadata.xml b/app-emulation/simh/metadata.xml
new file mode 100644
index 000000000000..d8b96be3c5cd
--- /dev/null
+++ b/app-emulation/simh/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <maintainer>
+ <email>bug-wranglers@gentoo.org</email>
+ <description>This package lacks a primary herd or maintainer.</description>
+ </maintainer>
+</pkgmetadata>
diff --git a/app-emulation/simh/simh-3.3.0.ebuild b/app-emulation/simh/simh-3.3.0.ebuild
new file mode 100644
index 000000000000..2cb2328b7e4b
--- /dev/null
+++ b/app-emulation/simh/simh-3.3.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/simh/simh-3.3.0.ebuild,v 1.1 2005/08/27 20:59:39 rphillips Exp $
+
+inherit eutils
+
+DESCRIPTION="a simulator for historical computers such as Vax, PDP-11 etc.)"
+HOMEPAGE="http://simh.trailing-edge.com/"
+SRC_URI="http://simh.trailing-edge.com/sources/simhv33-0.zip"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND="net-libs/libpcap"
+
+S=${WORKDIR}
+
+MAKEOPTS="USE_NETWORK=1 ${MAKEOPTS}"
+
+
+src_unpack() {
+ mkdir ${WORKDIR}/BIN
+ unpack ${A}
+
+ # convert makefile from dos format to unix format
+ sed -i 's/.$//' makefile
+
+ epatch ${FILESDIR}/makefile.patch
+}
+
+src_compile() {
+ emake || die "make failed"
+}
+
+src_install() {
+ cd "${S}/BIN"
+ for BINFILE in *; do
+ newbin ${BINFILE} "simh-${BINFILE}"
+ done
+
+ cd ${S}
+ dodir /usr/share/simh
+ insinto /usr/share/simh
+ doins VAX/*.bin
+ dodoc *.txt */*.txt
+}