summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/gpa/gpa-0.4.3.ebuild')
-rw-r--r--app-crypt/gpa/gpa-0.4.3.ebuild33
1 files changed, 9 insertions, 24 deletions
diff --git a/app-crypt/gpa/gpa-0.4.3.ebuild b/app-crypt/gpa/gpa-0.4.3.ebuild
index d7871d6b58dd..a94a771bcce1 100644
--- a/app-crypt/gpa/gpa-0.4.3.ebuild
+++ b/app-crypt/gpa/gpa-0.4.3.ebuild
@@ -1,45 +1,30 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/gpa/gpa-0.4.3.ebuild,v 1.3 2002/07/11 06:30:11 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/gpa/gpa-0.4.3.ebuild,v 1.4 2002/07/25 15:31:24 seemant Exp $
S=${WORKDIR}/${P}
DESCRIPTION="Standard GUI for GnuPG"
SRC_URI="ftp://ftp.gnupg.org/gcrypt/alpha/${PN}/${P}.tar.gz"
HOMEPAGE="http://www.gnupg.org/gpa.html"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86"
+
DEPEND="=x11-libs/gtk+-1.2*
app-crypt/gnupg
nls? ( sys-devel/gettext )"
-
src_compile() {
local myconf
- if [ -z "`use nls`" ] ; then
- myconf="--disable-nls"
- fi
-
- ./configure --host=${CHOST} \
- --prefix=/usr \
- --mandir=/usr/share/man \
- --infodir=/usr/share/info \
- --sysconfdir=/etc \
- $myconf || die
+ use nls || myconf="--disable-nls"
+ econf ${myconf} || die
emake || die
}
src_install () {
- make prefix=${D}/usr \
- mandir=${D}/usr/share/man \
- infodir=${D}/usr/share/info \
- sysconfdir=${D}/etc \
- install || die
-
+ einstall || die
dodoc AUTHORS COPYING ChangeLog README NEWS TODO
}
-
-
-
-
-