summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-wireless/hostap-driver/ChangeLog8
-rw-r--r--net-wireless/hostap-driver/Manifest5
-rw-r--r--net-wireless/hostap-driver/files/digest-hostap-driver-0.4.91
-rw-r--r--net-wireless/hostap-driver/files/hostap-driver-0.4.9-firmware.patch12
-rw-r--r--net-wireless/hostap-driver/hostap-driver-0.4.9.ebuild109
-rw-r--r--net-wireless/hostapd/Manifest6
6 files changed, 138 insertions, 3 deletions
diff --git a/net-wireless/hostap-driver/ChangeLog b/net-wireless/hostap-driver/ChangeLog
index 71276b39afcf..b78a7339a02f 100644
--- a/net-wireless/hostap-driver/ChangeLog
+++ b/net-wireless/hostap-driver/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-wireless/hostap-driver
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/hostap-driver/ChangeLog,v 1.53 2006/03/26 16:06:24 brix Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/hostap-driver/ChangeLog,v 1.54 2006/05/27 19:55:00 brix Exp $
+
+*hostap-driver-0.4.9 (27 May 2006)
+
+ 27 May 2006; Henrik Brix Andersen <brix@gentoo.org>
+ +files/hostap-driver-0.4.9-firmware.patch, +hostap-driver-0.4.9.ebuild:
+ Version bump, but only for people using kernels older than linux-2.6.14.
26 Mar 2006; Henrik Brix Andersen <brix@gentoo.org>
hostap-driver-0.4.7.ebuild:
diff --git a/net-wireless/hostap-driver/Manifest b/net-wireless/hostap-driver/Manifest
index cf1bf9cff090..7af3e297f1cb 100644
--- a/net-wireless/hostap-driver/Manifest
+++ b/net-wireless/hostap-driver/Manifest
@@ -1,5 +1,8 @@
-MD5 2f11ef44cc240fef00ccf388afcb3b42 ChangeLog 9816
+MD5 cede5168d736cab76951391fe969b78b ChangeLog 10056
MD5 c5800b90593d3826c5cef81cca46526a files/digest-hostap-driver-0.4.7 71
+MD5 b7a0ab3af34f51bdaa93f5a8d9b2ec66 files/digest-hostap-driver-0.4.9 71
MD5 3b2078eb6aa3c5754d282f6537ecd771 files/hostap-driver-0.4.7-firmware.patch 739
+MD5 3b2078eb6aa3c5754d282f6537ecd771 files/hostap-driver-0.4.9-firmware.patch 739
MD5 934bdf885e6f3a37723bf711c61cdb7a hostap-driver-0.4.7.ebuild 3186
+MD5 87ab0a606f82aa729e84155c514f3c50 hostap-driver-0.4.9.ebuild 2994
MD5 5f6ec5c50fa3a91a429fec8670cf241b metadata.xml 722
diff --git a/net-wireless/hostap-driver/files/digest-hostap-driver-0.4.9 b/net-wireless/hostap-driver/files/digest-hostap-driver-0.4.9
new file mode 100644
index 000000000000..397918c176be
--- /dev/null
+++ b/net-wireless/hostap-driver/files/digest-hostap-driver-0.4.9
@@ -0,0 +1 @@
+MD5 c7534dc040ab90218257a78488ecd378 hostap-driver-0.4.9.tar.gz 202959
diff --git a/net-wireless/hostap-driver/files/hostap-driver-0.4.9-firmware.patch b/net-wireless/hostap-driver/files/hostap-driver-0.4.9-firmware.patch
new file mode 100644
index 000000000000..c7d5741e8fae
--- /dev/null
+++ b/net-wireless/hostap-driver/files/hostap-driver-0.4.9-firmware.patch
@@ -0,0 +1,12 @@
+diff -urp hostap-driver-0.4.7/driver/modules/hostap_config.h hostap-driver-0.4.7-firmware/driver/modules/hostap_config.h
+--- hostap-driver-0.4.7/driver/modules/hostap_config.h 2005-11-21 02:42:12.000000000 +0100
++++ hostap-driver-0.4.7-firmware/driver/modules/hostap_config.h 2005-11-21 10:27:54.000000000 +0100
+@@ -59,7 +59,7 @@
+ * In addition, please note that it is possible to kill your card with
+ * non-volatile download if you are using incorrect image. This feature has not
+ * been fully tested, so please be careful with it. */
+-/* #define PRISM2_NON_VOLATILE_DOWNLOAD */
++#define PRISM2_NON_VOLATILE_DOWNLOAD
+ #endif /* PRISM2_DOWNLOAD_SUPPORT */
+
+ /* Include wireless extensions sub-ioctl support even if wireless extensions
diff --git a/net-wireless/hostap-driver/hostap-driver-0.4.9.ebuild b/net-wireless/hostap-driver/hostap-driver-0.4.9.ebuild
new file mode 100644
index 000000000000..657b8d75dfac
--- /dev/null
+++ b/net-wireless/hostap-driver/hostap-driver-0.4.9.ebuild
@@ -0,0 +1,109 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/hostap-driver/hostap-driver-0.4.9.ebuild,v 1.1 2006/05/27 19:55:00 brix Exp $
+
+inherit toolchain-funcs eutils linux-mod
+
+DESCRIPTION="Driver for Intersil Prism2/2.5/3 based IEEE 802.11b wireless LAN products"
+HOMEPAGE="http://hostap.epitest.fi"
+SRC_URI="http://hostap.epitest.fi/releases/${P}.tar.gz"
+LICENSE="GPL-2"
+
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="pcmcia"
+SLOT="0"
+
+RDEPEND=">=net-wireless/wireless-tools-25"
+
+BUILD_TARGETS="all"
+MODULESD_HOSTAP_DOCS="README"
+MODULESD_HOSTAP_CRYPT_WEP_ENABLED="no"
+MODULESD_HOSTAP_CRYPT_TKIP_ENABLED="no"
+MODULESD_HOSTAP_CRYPT_CCMP_ENABLED="no"
+
+CONFIG_CHECK="!HOSTAP NET_RADIO"
+ERROR_HOSTAP="${P} requires the in-kernel version of the hostap driver to be disabled (CONFIG_HOSTAP)"
+ERROR_NET_RADIO="${P} requires support for Wireless LAN drivers (non-hamradio) & Wireless Extensions (CONFIG_NET_RADIO)."
+
+pkg_setup() {
+ linux-mod_pkg_setup
+
+ if kernel_is ge 2 6 14; then
+ eerror
+ eerror "This version of hostap-driver is incompatible with linux-2.6.14 and above."
+ eerror "Please use the more recent in-kernel version of the hostap module when using"
+ eerror "linux-2.6.14 or above."
+ eerror
+ die "Incompatible kernel version"
+ fi
+
+ MODULE_NAMES="hostap(net::${S}/driver/modules)
+ hostap_pci(net::${S}/driver/modules)
+ hostap_plx(net::${S}/driver/modules)
+ hostap_crypt_wep(net::${S}/driver/modules)
+ hostap_crypt_ccmp(net::${S}/driver/modules)
+ hostap_crypt_tkip(net::${S}/driver/modules)"
+
+ if use pcmcia; then
+ MODULE_NAMES="${MODULE_NAMES} hostap_cs(net::${S}/driver/modules)"
+ fi
+
+ BUILD_PARAMS="KERNEL_PATH=${KV_DIR}"
+}
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ epatch ${FILESDIR}/${P}-firmware.patch
+
+ sed -i \
+ -e "s:gcc:$(tc-getCC):" \
+ -e "s:tail -1:tail -n 1:" \
+ ${S}/Makefile
+
+ if use pcmcia; then
+ # unpack the pcmcia-cs sources if needed
+ pcmcia_src_unpack
+
+ # set correct pcmcia path (PCMCIA_VERSION gets set from pcmcia_src_unpack)
+ if [ -n "${PCMCIA_VERSION}" ]; then
+ sed -i "s:^\(PCMCIA_PATH\)=:\1=${PCMCIA_SOURCE_DIR}:" ${S}/Makefile
+ fi
+ fi
+
+ convert_to_m ${S}/Makefile
+}
+
+src_install() {
+ if use pcmcia; then
+ insinto /etc/pcmcia
+ doins driver/etc/hostap_cs.conf
+ fi
+
+ dodoc ChangeLog
+
+ linux-mod_src_install
+}
+
+pkg_postinst() {
+ if [ -e /etc/pcmcia/prism2.conf ]
+ then
+ einfo ""
+ einfo "You may need to edit or remove /etc/pcmcia/prism2.conf"
+ einfo "This is usually a result of conflicts with the"
+ einfo "net-wireless/linux-wlan-ng drivers."
+ einfo ""
+ fi
+
+ ewarn ""
+ ewarn "Please note that this installation of HostAP contains support"
+ ewarn "for downloading binary firmware images into the non-volatile"
+ ewarn "(permanent) flash memory of wireless LAN cards."
+ ewarn ""
+ ewarn "Albeit being a great feature, this can lead to A DEAD CARD"
+ ewarn "when inappropriately used (e.g. wrong firmware)."
+ ewarn ""
+
+ linux-mod_pkg_postinst
+}
diff --git a/net-wireless/hostapd/Manifest b/net-wireless/hostapd/Manifest
index c44e25e2a7b9..23d135d3cfb4 100644
--- a/net-wireless/hostapd/Manifest
+++ b/net-wireless/hostapd/Manifest
@@ -1,12 +1,15 @@
-MD5 1214672945819c1d8dae182792614e90 ChangeLog 10779
+MD5 e003a39ab292a56b34e471ed3fbedc10 ChangeLog 10965
MD5 b0b607a1e367c39a3b14a50fd66d89b1 files/digest-hostapd-0.4.7-r2 65
MD5 b889b17ff10dbe3193353f453f04be64 files/digest-hostapd-0.4.8 65
+MD5 b6e6c055b71a94affe9d7c4386f12b2f files/digest-hostapd-0.4.9 65
MD5 371819cdecb937819dcca6c56f322ff3 files/digest-hostapd-0.5.2 65
MD5 1577a4ad5b96a07a2da9d15e0c4ea2de files/digest-hostapd-0.5.3 65
MD5 d5a08b266b9a031229e8910fe8cd18b3 files/hostapd-0.4.7-conf.d 425
MD5 4995955a0f26765b587f160d89e83910 files/hostapd-0.4.7-init.d 967
MD5 b0f2b07b294b771e1ffc4505970cb73d files/hostapd-0.4.8-conf.d 425
MD5 4150a7586faf504196a8f4f4e46c4b7a files/hostapd-0.4.8-init.d 967
+MD5 44e1d599bbbbabcb53ce925ee037e42b files/hostapd-0.4.9-conf.d 245
+MD5 1d73c64378ff1612794ba839ebc32567 files/hostapd-0.4.9-init.d 954
MD5 44e1d599bbbbabcb53ce925ee037e42b files/hostapd-0.5.2-conf.d 245
MD5 124087c0589db2ab55758b3316d43edf files/hostapd-0.5.2-init.d 954
MD5 b4a52e58c5b08e2f69f837d0a811b8d4 files/hostapd-0.5.2-ssl.patch 371
@@ -15,6 +18,7 @@ MD5 b917ccb2d6e1cc062ee9411083e189ef files/hostapd-0.5.3-init.d 954
MD5 8795d6fca0a69f83b03c5179fc578579 files/hostapd-0.5.3-os_get_random.patch 1496
MD5 98674360a16af6d2ee36838a0e186c05 hostapd-0.4.7-r2.ebuild 2738
MD5 0f134eb61a5ae09f24a2fa598756de71 hostapd-0.4.8.ebuild 3069
+MD5 e691e1ea6ab71ffbd03cc7f78c380d52 hostapd-0.4.9.ebuild 3070
MD5 776150e37fd4c98bed965730424ac02e hostapd-0.5.2.ebuild 3288
MD5 1451d03aa444a518096135e04be35f51 hostapd-0.5.3.ebuild 3567
MD5 52a4b928b36a98e530ae455b73f868f5 metadata.xml 462