summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-apps/portage/Manifest14
-rw-r--r--sys-apps/portage/portage-2.0.51_rc1.ebuild30
2 files changed, 16 insertions, 28 deletions
diff --git a/sys-apps/portage/Manifest b/sys-apps/portage/Manifest
index aaedd5df0141..6fcbb6ee42a2 100644
--- a/sys-apps/portage/Manifest
+++ b/sys-apps/portage/Manifest
@@ -1,17 +1,7 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
-MD5 bfb7050b7f4317ddfbbf3de8f78ab8d0 portage-2.0.51_rc1.ebuild 11659
-MD5 0ea980904ecc333daf7f702ceddc1349 portage-2.0.50-r11.ebuild 11697
MD5 ba4ae80e5e6cf58aac9c5aa1cc5f777e ChangeLog 411
MD5 4ec0f0ae9676b9d2d227d737d508306b metadata.xml 165
+MD5 0ea980904ecc333daf7f702ceddc1349 portage-2.0.50-r11.ebuild 11697
+MD5 cf4cd87a2ee1940be7c5c9f3e97f8567 portage-2.0.51_rc1.ebuild 11696
MD5 5375f0805d4d56dc961ad81162854790 files/digest-portage-2.0.50-r11 71
MD5 ed8dbb706c68468d6fa4c91a237e8b6f files/digest-portage-2.0.51_rc1 71
MD5 a754ca9e2eea9f8484bf5f93d339043a files/README.RESCUE 1911
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.2.6 (GNU/Linux)
-
-iD8DBQFBUMZlBDOEqLMd+jQRAje0AJ9ZWMkjRK3JBjU5CtEje/mc6jm9jwCgk5Nt
-zpw56TcHigqY4KEIckAssuE=
-=6X10
------END PGP SIGNATURE-----
diff --git a/sys-apps/portage/portage-2.0.51_rc1.ebuild b/sys-apps/portage/portage-2.0.51_rc1.ebuild
index 68954b61f8f1..7d624be4f663 100644
--- a/sys-apps/portage/portage-2.0.51_rc1.ebuild
+++ b/sys-apps/portage/portage-2.0.51_rc1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/portage-2.0.51_rc1.ebuild,v 1.5 2004/09/22 00:24:49 carpaski Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/portage-2.0.51_rc1.ebuild,v 1.6 2004/09/22 05:09:59 usata Exp $
IUSE="build multilib selinux"
@@ -65,11 +65,12 @@ src_compile() {
check_multilib
make CFLAGS="-O2 -pipe" HAVE_64BIT_ARCH="${MULTILIB}" || die
;;
- "macos")
- ewarn "NOT BUILDING SANDBOX ON $ARCH"
- ;;
*)
- make || die
+ if use macos || use ppc-macos ; then
+ ewarn "NOT BUILDING SANDBOX ON Mac OS X"
+ else
+ make || die
+ fi
;;
esac
cd ${S}/bin
@@ -119,17 +120,14 @@ src_install() {
dosym emake /usr/lib/portage/bin/pmake
doexe ${S}/src/tbz2tool
- case "$ARCH" in
- macos)
- ewarn "Not installing sandbox on $ARCH"
- ;;
- *)
- #install sandbox
- cd ${S}/src/sandbox-1.1
- make DESTDIR=${D} HAVE_64BIT_ARCH="${MULTILIB}" \
- install || die "Failed to compile sandbox"
- ;;
- esac
+ if use macos || use ppc-macos ; then
+ ewarn "Not installing sandbox on Mac OS X"
+ else
+ #install sandbox
+ cd ${S}/src/sandbox-1.1
+ make DESTDIR=${D} HAVE_64BIT_ARCH="${MULTILIB}" \
+ install || die "Failed to compile sandbox"
+ fi
#symlinks
dodir /usr/bin /usr/sbin