summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-misc/ssh/ChangeLog8
-rw-r--r--net-misc/ssh/files/digest-ssh-3.2.51
-rw-r--r--net-misc/ssh/files/pamd.sshd211
-rw-r--r--net-misc/ssh/files/sshd234
-rw-r--r--net-misc/ssh/ssh-3.2.5.ebuild46
5 files changed, 100 insertions, 0 deletions
diff --git a/net-misc/ssh/ChangeLog b/net-misc/ssh/ChangeLog
new file mode 100644
index 000000000000..ee903888952a
--- /dev/null
+++ b/net-misc/ssh/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for net-misc/ssh
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/ssh/ChangeLog,v 1.1 2003/09/26 06:26:07 vapier Exp $
+
+*ssh-3.2.5 (26 Sep 2003)
+
+ 26 Sep 2003; Mike Frysinger <vapier@gentoo.org> :
+ Initial import. Ebuild submitted by Gustavo Felisberto <gustavo@felisberto.net> #29472.
diff --git a/net-misc/ssh/files/digest-ssh-3.2.5 b/net-misc/ssh/files/digest-ssh-3.2.5
new file mode 100644
index 000000000000..41a15fedba16
--- /dev/null
+++ b/net-misc/ssh/files/digest-ssh-3.2.5
@@ -0,0 +1 @@
+MD5 0d9da1d79e4ce9cff44daf93e5b66a11 ssh-3.2.5.tar.gz 2258425
diff --git a/net-misc/ssh/files/pamd.sshd2 b/net-misc/ssh/files/pamd.sshd2
new file mode 100644
index 000000000000..7517975dcd59
--- /dev/null
+++ b/net-misc/ssh/files/pamd.sshd2
@@ -0,0 +1,11 @@
+#%PAM-1.0
+# Sample /etc/pam.d file. If you use /etc/pam.conf style, prepend
+# "sshd2 " to every line.
+# Sami Lehtinen <sjl@ssh.com>
+
+auth required /lib/security/pam_pwdb.so shadow
+auth required /lib/security/pam_nologin.so
+#auth required pam_permit.so
+account required /lib/security/pam_pwdb.so
+password required /lib/security/pam_pwdb.so shadow use_authtok
+session required /lib/security/pam_pwdb.so
diff --git a/net-misc/ssh/files/sshd2 b/net-misc/ssh/files/sshd2
new file mode 100644
index 000000000000..28306e94e14b
--- /dev/null
+++ b/net-misc/ssh/files/sshd2
@@ -0,0 +1,34 @@
+#!/sbin/runscript
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+
+
+depend() {
+ use logger dns
+ need net
+}
+
+checkconfig() {
+ if [ ! -e /etc/ssh2/sshd2_config ] ; then
+ eerror "You need an /etc/ssh/sshd2_config file to run sshd"
+ eerror "There is a sample file in /etc/ssh2/"
+ return 1
+ fi
+
+}
+
+
+start() {
+ checkconfig || return 1
+ ebegin "Starting sshd2"
+ start-stop-daemon --start --quiet --pidfile /var/run/sshd2.pid \
+ --startas /usr/sbin/sshd2
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping sshd2"
+ start-stop-daemon --stop --quiet --pidfile /var/run/sshd2_22.pid
+ eend $?
+}
+
diff --git a/net-misc/ssh/ssh-3.2.5.ebuild b/net-misc/ssh/ssh-3.2.5.ebuild
new file mode 100644
index 000000000000..aca5958bb60c
--- /dev/null
+++ b/net-misc/ssh/ssh-3.2.5.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/ssh/ssh-3.2.5.ebuild,v 1.1 2003/09/26 06:26:07 vapier Exp $
+
+DESCRIPTION="Ssh.com Non-Comercial Use ssh version"
+HOMEPAGE="http://www.ssh.com/"
+SRC_URI="ftp://ftp.ssh.com/pub/ssh/${P}.tar.gz"
+
+LICENSE="SSH"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="X ipv6 gpg openssh"
+
+DEPEND="X? ( virtual/x11 )
+ !openssh? ( !virtual/ssh )"
+PROVIDE="virtual/ssh"
+
+src_compile() {
+ econf \
+ `use_with ipv6 ipv6` \
+ `use_with X` \
+ `use_with gpg` \
+ || die "configure failed"
+ emake -j1 || die "make failed"
+}
+
+src_install() {
+ if [ -e ${ROOT}/etc/ssh2/hostkey ] ; then
+ # this keeps the install from generating these keys again
+ insinto /etc/ssh2
+ doins ${ROOT}/etc/ssh2/hostkey{,.pub}
+ fperms go-rwx /etc/ssh2/hostkey
+ fi
+
+ make install DESTDIR=${D} || die "install failed"
+ chmod 600 ${D}/etc/ssh2/sshd2_config
+ dodoc CHANGES FAQ HOWTO.anonymous.sftp README* SSH2.QUICKSTART
+
+ insinto /etc/pam.d
+ newins ${FILESDIR}/pamd.sshd2 sshd2
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/sshd2 sshd2
+
+ cd ${D}/usr
+ [ `use openssh` ] && find bin sbin share/man -type l -exec rm '{}' \;
+}