summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-games/KXL/metadata.xml19
-rw-r--r--dev-games/cardpics/cardpics-0.4.ebuild8
-rw-r--r--dev-games/cardpics/metadata.xml12
-rw-r--r--dev-games/hawknl/metadata.xml20
-rw-r--r--dev-games/hlsdk/hlsdk-2.3.ebuild4
-rw-r--r--dev-games/hlsdk/metadata.xml21
-rw-r--r--dev-games/libnw/libnw-1.30.01.ebuild6
-rw-r--r--dev-games/libnw/metadata.xml16
-rw-r--r--dev-games/ode/metadata.xml11
-rw-r--r--dev-games/ogre/metadata.xml80
-rw-r--r--dev-games/physfs/metadata.xml22
-rw-r--r--dev-games/simgear/metadata.xml13
12 files changed, 219 insertions, 13 deletions
diff --git a/dev-games/KXL/metadata.xml b/dev-games/KXL/metadata.xml
new file mode 100644
index 000000000000..d5af03e3e537
--- /dev/null
+++ b/dev-games/KXL/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+<longdescription>
+KXL is the library developed for the purpose of the ability to develop a
+game easily on X Window System of Linux.
+
+KXL is the composition of the window of one sheet, and the frame buffer
+of one sheet.
+
+KXL corresponds to reading of a bitmap picture, and offers a still
+simple drawing function and a wave sound function.
+
+KXL is written only using xlib.
+
+KXL is written by the C language.
+</longdescription>
+</pkgmetadata>
diff --git a/dev-games/cardpics/cardpics-0.4.ebuild b/dev-games/cardpics/cardpics-0.4.ebuild
index e19ce9400fd8..c3ec0a333b02 100644
--- a/dev-games/cardpics/cardpics-0.4.ebuild
+++ b/dev-games/cardpics/cardpics-0.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/cardpics/cardpics-0.4.ebuild,v 1.1 2003/07/14 00:40:11 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/cardpics/cardpics-0.4.ebuild,v 1.2 2003/10/06 20:53:04 vapier Exp $
inherit games
@@ -11,12 +11,6 @@ SRC_URI="http://savannah.gnu.org/download/cardpics/sources/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86"
-IUSE=""
-
-src_compile() {
- egamesconf || die
- emake || die
-}
src_install() {
make install DESTDIR=${D} || die
diff --git a/dev-games/cardpics/metadata.xml b/dev-games/cardpics/metadata.xml
new file mode 100644
index 000000000000..c0ea8fee0e55
--- /dev/null
+++ b/dev-games/cardpics/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+<longdescription>
+rdpics is a set of free cards sets.
+
+If you are programming a card game and are looking for free cards,
+Cardpics was made for you! Get a set of cards and include them in your
+project, as soon as your project is free.
+</longdescription>
+</pkgmetadata>
diff --git a/dev-games/hawknl/metadata.xml b/dev-games/hawknl/metadata.xml
new file mode 100644
index 000000000000..4a84058016ad
--- /dev/null
+++ b/dev-games/hawknl/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+<longdescription>
+HawkNL is a free, open source, game oriented network API released under
+the GNU Library General Public License (LGPL). HawkNL (NL) is a fairly
+low level API, a wrapper over Berkeley/Unix Sockets and Winsock. But NL
+also provides other features including support for many OSs, groups of
+sockets, socket statistics, high accuracy timer, CRC functions, macros
+to read and write data to packets with endian conversion, and support
+for multiple network transports. NL has been tested on Windows
+9x/ME/NT/2000/XP/CE, Linux, Solaris, IRIX, AIX, BSDs, MacOS 7-9 and
+MacOS X. There are also the two high level APIs, HawkNLU(tm) (NLU)
+and HawkVoice(tm), which are built on top of NL. It is NLU and
+HawkVoice(tm) that are most exciting, since they give developers
+portable, easy to use alternatives to Microsoft®'s DirectPlay® and
+DirectPlay® Voice.
+</longdescription>
+</pkgmetadata>
diff --git a/dev-games/hlsdk/hlsdk-2.3.ebuild b/dev-games/hlsdk/hlsdk-2.3.ebuild
index dd117f90857d..7c685cde8cf3 100644
--- a/dev-games/hlsdk/hlsdk-2.3.ebuild
+++ b/dev-games/hlsdk/hlsdk-2.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/hlsdk/hlsdk-2.3.ebuild,v 1.1 2003/07/13 03:13:40 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/hlsdk/hlsdk-2.3.ebuild,v 1.2 2003/10/06 20:55:50 vapier Exp $
inherit games
@@ -12,8 +12,6 @@ LICENSE="ValveSDK"
SLOT="0"
KEYWORDS="x86"
-S=${WORKDIR}/${P}
-
src_compile() {
find -iname '*.orig' -exec rm -f '{}' \;
}
diff --git a/dev-games/hlsdk/metadata.xml b/dev-games/hlsdk/metadata.xml
new file mode 100644
index 000000000000..eb47ddf26ae4
--- /dev/null
+++ b/dev-games/hlsdk/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+<maintainer>
+ <email>vapier@gentoo.org</email>
+ <name>Mike Frysinger</name>
+</maintainer>
+<longdescription>
+Half-Life SDK
+
+The current version of the Half-Life SDK is 2.3, which includes new functionality
+for mod authors, greatly increasing their power to create a wide variety of games
+using the Half-Life engine. The new features included with version 2.3 are the
+inclusion of the Ricochet source code (with multi-serve technology), first-person
+spectator code, and updated information on the server query protocol.
+
+Note:
+This is the version from metamod ... it's been ported and updated for use in linux.
+</longdescription>
+</pkgmetadata>
diff --git a/dev-games/libnw/libnw-1.30.01.ebuild b/dev-games/libnw/libnw-1.30.01.ebuild
index f1cd5121141e..76f4dae1e31f 100644
--- a/dev-games/libnw/libnw-1.30.01.ebuild
+++ b/dev-games/libnw/libnw-1.30.01.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/libnw/libnw-1.30.01.ebuild,v 1.1 2003/07/13 03:13:40 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/libnw/libnw-1.30.01.ebuild,v 1.2 2003/10/06 21:02:55 vapier Exp $
DESCRIPTION="Tools and libraries for NWN file manipulation"
-HOMEPAGE="http://openknights.sf.net/"
+HOMEPAGE="http://openknights.sourceforge.net/"
SRC_URI="mirror://sourceforge/openknights/${P}.tar.gz"
-SLOT="0"
LICENSE="openknights"
+SLOT="0"
KEYWORDS="x86 ppc"
DEPEND="sys-devel/bison
diff --git a/dev-games/libnw/metadata.xml b/dev-games/libnw/metadata.xml
new file mode 100644
index 000000000000..1226b24a9992
--- /dev/null
+++ b/dev-games/libnw/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+<longdescription>
+libnw - libnw's aim is to provide platform-independent routines for the low- and
+mid-level manipulation of NWN resources, as members of game data files, modules, hak
+paks, export files, or stand alone. As a side effect, command-line programs are
+often produced to exercise portions of the library. Ultimately, these routines are
+intended to be assembled along with some form of GUI to make an equivalent to
+BioWare's Aurora Toolset.
+libnw is very much a work in progress, coded in C, and initially developed on ia32
+hardware running GNU/Linux. Members of the OK Project have assisted in porting the
+code to Mac OS X, as well.
+</longdescription>
+</pkgmetadata>
diff --git a/dev-games/ode/metadata.xml b/dev-games/ode/metadata.xml
new file mode 100644
index 000000000000..7c91771c4bf6
--- /dev/null
+++ b/dev-games/ode/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+<longdescription>
+ODE is a free, industrial quality library for simulating articulated rigid body
+dynamics - for example ground vehicles, legged creatures, and moving objects in VR
+environments. It is fast, flexible, robust and platform independent, with advanced
+joints, contact with friction, and built-in collision detection.
+</longdescription>
+</pkgmetadata>
diff --git a/dev-games/ogre/metadata.xml b/dev-games/ogre/metadata.xml
new file mode 100644
index 000000000000..0d040d6d0bf3
--- /dev/null
+++ b/dev-games/ogre/metadata.xml
@@ -0,0 +1,80 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+<maintainer>
+ <email>vapier@gentoo.org</email>
+ <name>Mike Frysinger</name>
+</maintainer>
+<longdescription>
+OGRE (Object-Oriented Graphics Rendering Engine) is a scene-oriented, flexible 3D
+engine written in C++ designed to make it easier and more intuitive for developers
+to produce games and demos utilising 3D hardware. The class library abstracts all
+the details of using the underlying system libraries like Direct3D and OpenGL and
+provides an interface based on world objects and other intuitive classes.
+
+Productivity features
+
+ * Simple, easy to use OO interface designed to minimise the effort required to render 3D scenes, and to be independent of 3D implementation e.g. Direct3D/OpenGL/Glide etc.
+ * Extensible example framework makes getting your application running is quick and simple
+ * Common requirements like render state management, hierarchical culling, dealing with transparency are done for you automatically saving you valuable time
+ * Clean, uncluttered design and full documentation of all engine classes
+
+Platform & 3D API support
+
+ * Direct3D and OpenGL support
+ * Windows (all major versions), Linux and Mac OSX support
+ * Builds on Visual C++ 6 (with STLport), Visual C++.Net (with STLport), Visual C++.Net 2003
+ * Builds on gcc 3+ on Linux / Mac OSX
+
+Material / Shader support
+
+ * Load textures from PNG, JPEG or TGA files, MipMaps generated automatically, resizes maps to align with hardware requirements
+ * Procedural texture coordinate generation (e.g. environment mapping) and modification (scrolls, warps, rotations)
+ * Unbounded number of texture layers with many texture blending effects, animated textures
+ * Multitexturing hardware used to best effect automatically, combined with automatic fallback to mulitpass rendering
+ * Object transparency and other scene-level blending effects
+ * All defineable through text scripts to allow you to set up & tweak advanced materials without recompiling
+
+Meshes
+
+ * Flexible mesh data formats accepted
+ * Export from Milkshape3D direct to OGRE .mesh and .skeleton format
+ * Skeletal animation (including blending of multiple animations)
+ * Biquadric Bezier patches for curved surfaces
+ * Progressive meshes
+
+Scene Features
+
+ * Highly customisable, flexible scene management, not tied to any single scene type. Use predefined classes for scene organisation if they suit or plug in your own subclass to gain full control over the scene organisation
+ * Generic SceneManager hierarchically culls by bounding volumes
+ * Example plugin (BspSceneManager) specialises to allow fast indoor renders, loading Quake3 levels inc. shader script parsing support
+ * Hierarchical scene graph; nodes allow objects to be attached to each other and follow each others movements, articulated structures etc
+ * Scene querying features
+
+Special Effects
+
+ * Particle Systems, including easily extensible emitters and affectors (customisable through plugins). Systems can be defined in text scripts for easy tweaking. Automatic use of particle pooling for maximum performance
+ * Support for skyboxes, skyplanes and skydomes, very easy to use
+ * Billboarding for sprite graphics
+ * Transparent objects automatically managed (rendering order & depth buffer settings all set up for you)
+
+Misc features
+
+ * Common resource infrastructure for memory management and loading from archives (ZIP, PK3)
+ * Flexible plugin architecture allows engine to be extended without recompilation
+ * 'Controllers' allow you to easily organise derived values between objects e.g. changing the colour of a ship based on shields left
+ * Debugging memory manager for identifying memory leaks
+ * ReferenceAppLayer provides an example of how to combine OGRE with other libraries, for example ODE for collision & physics
+ * XMLConverter to convert efficient runtime binary formats to/from XML for interchange or editing
+
+Exporters
+
+ * 3D Studio Max (meshes and animation)
+ * Milkshape 3D (meshes and animation)
+ * Blender3D (meshes)
+ * Wings3D (meshes)
+ * VRML97 (meshes)
+ * Maya (meshes)
+</longdescription>
+</pkgmetadata>
diff --git a/dev-games/physfs/metadata.xml b/dev-games/physfs/metadata.xml
new file mode 100644
index 000000000000..410bd1073a8c
--- /dev/null
+++ b/dev-games/physfs/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+<longdescription>
+PhysicsFS is a library to provide abstract access to various archives. It is
+intended for use in video games, and the design was somewhat inspired by Quake 3's
+file subsystem. The programmer defines a "write directory" on the physical
+filesystem. No file writing done through the PhysicsFS API can leave that write
+directory, for security. For example, an embedded scripting language cannot write
+outside of this path if it uses PhysFS for all of its I/O, which means that
+untrusted scripts can run more safely. Symbolic links can be disabled as well, for
+added safety. For file reading, the programmer lists directories and archives that
+form a "search path". Once the search path is defined, it becomes a single,
+transparent hierarchical filesystem. This makes for easy access to ZIP files in the
+same way as you access a file directly on the disk, and it makes it easy to ship a
+new archive that will override a previous archive on a per-file basis. Finally,
+PhysicsFS gives you platform-abstracted means to determine if CD-ROMs are available,
+the user's home directory, where in the real filesystem your program is running,
+etc.
+</longdescription>
+</pkgmetadata>
diff --git a/dev-games/simgear/metadata.xml b/dev-games/simgear/metadata.xml
new file mode 100644
index 000000000000..5b61c3fc20b7
--- /dev/null
+++ b/dev-games/simgear/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+<longdescription>
+SimGear is a set of open-source libraries designed to be used as building blocks for
+quickly assembling 3d simulations, games, and visualization applications.
+
+The purpose of this project is to develop open-source libraries and
+building blocks to assist with rapid construction/prototyping of 3d
+simulation, game, and visualization software.
+</longdescription>
+</pkgmetadata>