summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-libs/Ice/ChangeLog7
-rw-r--r--dev-libs/Ice/Ice-3.3.1-r1.ebuild4
-rw-r--r--dev-libs/Ice/Ice-3.3.1-r2.ebuild4
-rw-r--r--dev-libs/Ice/Ice-3.3.1.ebuild4
-rw-r--r--dev-libs/Ice/Ice-3.4.0.ebuild4
-rw-r--r--dev-libs/Ice/Ice-3.4.1.ebuild4
-rw-r--r--dev-libs/Ice/Ice-3.4.2.ebuild4
-rw-r--r--dev-libs/dbxml/ChangeLog5
-rw-r--r--dev-libs/dbxml/dbxml-2.5.16-r1.ebuild4
-rw-r--r--dev-libs/ppl/ChangeLog6
-rw-r--r--dev-libs/ppl/ppl-0.10.2-r1.ebuild4
-rw-r--r--dev-libs/ppl/ppl-0.11.2.ebuild4
12 files changed, 33 insertions, 21 deletions
diff --git a/dev-libs/Ice/ChangeLog b/dev-libs/Ice/ChangeLog
index 44c364672c14..96b4df87e90e 100644
--- a/dev-libs/Ice/ChangeLog
+++ b/dev-libs/Ice/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/Ice
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/Ice/ChangeLog,v 1.9 2011/11/13 20:27:38 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/Ice/ChangeLog,v 1.10 2011/11/14 11:22:34 flameeyes Exp $
+
+ 14 Nov 2011; Diego E. Pettenò <flameeyes@gentoo.org> Ice-3.3.1-r1.ebuild,
+ Ice-3.3.1-r2.ebuild, Ice-3.3.1.ebuild, Ice-3.4.0.ebuild, Ice-3.4.1.ebuild,
+ Ice-3.4.2.ebuild:
+ QA: cxx conditional was broken, fix it.
13 Nov 2011; Mike Frysinger <vapier@gentoo.org> Ice-3.3.1.ebuild,
Ice-3.3.1-r1.ebuild, Ice-3.3.1-r2.ebuild, Ice-3.4.0.ebuild, Ice-3.4.1.ebuild,
diff --git a/dev-libs/Ice/Ice-3.3.1-r1.ebuild b/dev-libs/Ice/Ice-3.3.1-r1.ebuild
index bc08618e2f57..cf30d8239685 100644
--- a/dev-libs/Ice/Ice-3.3.1-r1.ebuild
+++ b/dev-libs/Ice/Ice-3.3.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/Ice/Ice-3.3.1-r1.ebuild,v 1.2 2011/11/13 20:27:38 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/Ice/Ice-3.3.1-r1.ebuild,v 1.3 2011/11/14 11:22:34 flameeyes Exp $
EAPI=2
@@ -18,7 +18,7 @@ IUSE="ncurses test debug"
RDEPEND=">=dev-libs/expat-2.0.1
>=app-arch/bzip2-1.0.4
>=dev-libs/openssl-0.9.8g
- || ( =sys-libs/db-4.6.21*[cxx] =sys-libs/db-4.6.21*[-nocxx] )
+ =sys-libs/db-4.6.21*[cxx]
=dev-cpp/libmcpp-2.7.2"
DEPEND="${RDEPEND}
diff --git a/dev-libs/Ice/Ice-3.3.1-r2.ebuild b/dev-libs/Ice/Ice-3.3.1-r2.ebuild
index b9b0b3ecfd6e..f402ef51c201 100644
--- a/dev-libs/Ice/Ice-3.3.1-r2.ebuild
+++ b/dev-libs/Ice/Ice-3.3.1-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/Ice/Ice-3.3.1-r2.ebuild,v 1.2 2011/11/13 20:27:38 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/Ice/Ice-3.3.1-r2.ebuild,v 1.3 2011/11/14 11:22:34 flameeyes Exp $
EAPI="2"
@@ -23,7 +23,7 @@ IUSE="doc examples +ncurses mono python ruby test debug"
RDEPEND=">=dev-libs/expat-2.0.1
>=app-arch/bzip2-1.0.4
>=dev-libs/openssl-0.9.8g
- || ( >=sys-libs/db-4.6.21:4.6[cxx] >=sys-libs/db-4.6.21:4.6[-nocxx] )
+ >=sys-libs/db-4.6.21:4.6[cxx]
=dev-cpp/libmcpp-2.7.2
ruby? ( $(ruby_implementation_depend ruby18) )
mono? ( dev-lang/mono )
diff --git a/dev-libs/Ice/Ice-3.3.1.ebuild b/dev-libs/Ice/Ice-3.3.1.ebuild
index 6d762698a9f7..25d884ae86a6 100644
--- a/dev-libs/Ice/Ice-3.3.1.ebuild
+++ b/dev-libs/Ice/Ice-3.3.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/Ice/Ice-3.3.1.ebuild,v 1.2 2011/11/13 20:27:38 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/Ice/Ice-3.3.1.ebuild,v 1.3 2011/11/14 11:22:34 flameeyes Exp $
EAPI=2
@@ -18,7 +18,7 @@ IUSE="ncurses test debug"
RDEPEND=">=dev-libs/expat-2.0.1
>=app-arch/bzip2-1.0.4
>=dev-libs/openssl-0.9.8g
- || ( =sys-libs/db-4.6.21*[cxx] =sys-libs/db-4.6.21*[-nocxx] )
+ =sys-libs/db-4.6.21*[cxx]
=dev-cpp/libmcpp-2.7.2"
DEPEND="${RDEPEND}
diff --git a/dev-libs/Ice/Ice-3.4.0.ebuild b/dev-libs/Ice/Ice-3.4.0.ebuild
index 0686cb9098eb..2f5967f17fcc 100644
--- a/dev-libs/Ice/Ice-3.4.0.ebuild
+++ b/dev-libs/Ice/Ice-3.4.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/Ice/Ice-3.4.0.ebuild,v 1.3 2011/11/13 20:27:38 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/Ice/Ice-3.4.0.ebuild,v 1.4 2011/11/14 11:22:34 flameeyes Exp $
EAPI="2"
@@ -23,7 +23,7 @@ IUSE="doc examples +ncurses mono python ruby test debug"
RDEPEND=">=dev-libs/expat-2.0.1
>=app-arch/bzip2-1.0.4
>=dev-libs/openssl-0.9.8o
- || ( >=sys-libs/db-4.8.30:4.8[cxx] >=sys-libs/db-4.8.30:4.8[-nocxx] )
+ >=sys-libs/db-4.8.30:4.8[cxx]
=dev-cpp/libmcpp-2.7.2
ruby? ( $(ruby_implementation_depend ruby18) )
mono? ( dev-lang/mono )
diff --git a/dev-libs/Ice/Ice-3.4.1.ebuild b/dev-libs/Ice/Ice-3.4.1.ebuild
index 66d9ab7ab587..f9953656c992 100644
--- a/dev-libs/Ice/Ice-3.4.1.ebuild
+++ b/dev-libs/Ice/Ice-3.4.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/Ice/Ice-3.4.1.ebuild,v 1.4 2011/11/13 20:27:38 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/Ice/Ice-3.4.1.ebuild,v 1.5 2011/11/14 11:22:34 flameeyes Exp $
EAPI="2"
@@ -24,7 +24,7 @@ IUSE="doc examples +ncurses mono python ruby test debug"
RDEPEND=">=dev-libs/expat-2.0.1
>=app-arch/bzip2-1.0.5
>=dev-libs/openssl-0.9.8o
- || ( >=sys-libs/db-4.8.30:4.8[cxx] >=sys-libs/db-4.8.30:4.8[-nocxx] )
+ >=sys-libs/db-4.8.30:4.8[cxx]
~dev-cpp/libmcpp-2.7.2
ruby? ( $(ruby_implementation_depend ruby18) )
mono? ( dev-lang/mono )
diff --git a/dev-libs/Ice/Ice-3.4.2.ebuild b/dev-libs/Ice/Ice-3.4.2.ebuild
index 0ffc57cab95d..211dbbb456bf 100644
--- a/dev-libs/Ice/Ice-3.4.2.ebuild
+++ b/dev-libs/Ice/Ice-3.4.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/Ice/Ice-3.4.2.ebuild,v 1.3 2011/11/13 20:27:38 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/Ice/Ice-3.4.2.ebuild,v 1.4 2011/11/14 11:22:34 flameeyes Exp $
EAPI="2"
@@ -24,7 +24,7 @@ IUSE="doc examples +ncurses mono python ruby test debug"
RDEPEND=">=dev-libs/expat-2.0.1
>=app-arch/bzip2-1.0.5
>=dev-libs/openssl-0.9.8o
- || ( >=sys-libs/db-4.8.30[cxx] >=sys-libs/db-4.8.30[-nocxx] )
+ >=sys-libs/db-4.8.30[cxx]
~dev-cpp/libmcpp-2.7.2
ruby? ( $(ruby_implementation_depend ruby18) )
mono? ( dev-lang/mono )
diff --git a/dev-libs/dbxml/ChangeLog b/dev-libs/dbxml/ChangeLog
index edde551aefc4..e0c0a9616986 100644
--- a/dev-libs/dbxml/ChangeLog
+++ b/dev-libs/dbxml/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-libs/dbxml
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/dbxml/ChangeLog,v 1.13 2011/11/13 20:34:59 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/dbxml/ChangeLog,v 1.14 2011/11/14 11:21:42 flameeyes Exp $
+
+ 14 Nov 2011; Diego E. Pettenò <flameeyes@gentoo.org> dbxml-2.5.16-r1.ebuild:
+ QA: cxx conditional was broken, fix it.
13 Nov 2011; Mike Frysinger <vapier@gentoo.org> dbxml-2.5.16-r1.ebuild,
dbxml-2.5.16-r2.ebuild:
diff --git a/dev-libs/dbxml/dbxml-2.5.16-r1.ebuild b/dev-libs/dbxml/dbxml-2.5.16-r1.ebuild
index fe7bb8bf321b..370aafa78a97 100644
--- a/dev-libs/dbxml/dbxml-2.5.16-r1.ebuild
+++ b/dev-libs/dbxml/dbxml-2.5.16-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/dbxml/dbxml-2.5.16-r1.ebuild,v 1.3 2011/11/13 20:34:59 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/dbxml/dbxml-2.5.16-r1.ebuild,v 1.4 2011/11/14 11:21:42 flameeyes Exp $
EAPI="3"
PYTHON_DEPEND="python? 2"
@@ -25,7 +25,7 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="doc examples java perl python tcl"
-RDEPEND="|| ( sys-libs/db:${DB_VER}[cxx,java?] sys-libs/db:${DB_VER}[-nocxx,java?] )
+RDEPEND="sys-libs/db:${DB_VER}[cxx,java?]
>=dev-libs/xerces-c-3
>=dev-libs/xqilla-2.1.2
sys-libs/zlib
diff --git a/dev-libs/ppl/ChangeLog b/dev-libs/ppl/ChangeLog
index bda593b97ad8..ebae749df63a 100644
--- a/dev-libs/ppl/ChangeLog
+++ b/dev-libs/ppl/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-libs/ppl
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/ppl/ChangeLog,v 1.37 2011/11/13 19:27:25 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/ppl/ChangeLog,v 1.38 2011/11/14 11:18:56 flameeyes Exp $
+
+ 14 Nov 2011; Diego E. Pettenò <flameeyes@gentoo.org> ppl-0.10.2-r1.ebuild,
+ ppl-0.11.2.ebuild:
+ QA: cxx conditional was broken, fix it.
13 Nov 2011; Mike Frysinger <vapier@gentoo.org> ppl-0.10.2-r1.ebuild,
ppl-0.11.2.ebuild:
diff --git a/dev-libs/ppl/ppl-0.10.2-r1.ebuild b/dev-libs/ppl/ppl-0.10.2-r1.ebuild
index b247c603d3fe..7ddd9e209ea6 100644
--- a/dev-libs/ppl/ppl-0.10.2-r1.ebuild
+++ b/dev-libs/ppl/ppl-0.10.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/ppl/ppl-0.10.2-r1.ebuild,v 1.12 2011/11/13 19:27:25 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/ppl/ppl-0.10.2-r1.ebuild,v 1.13 2011/11/14 11:18:56 flameeyes Exp $
EAPI=2
@@ -16,7 +16,7 @@ SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~sparc-fbsd ~x86-fbsd"
IUSE="doc lpsol pch test watchdog"
-RDEPEND="|| ( >=dev-libs/gmp-4.1.3[cxx] >=dev-libs/gmp-4.1.3[-nocxx] )
+RDEPEND=">=dev-libs/gmp-4.1.3[cxx]
lpsol? ( sci-mathematics/glpk )"
DEPEND="${RDEPEND}
sys-devel/m4"
diff --git a/dev-libs/ppl/ppl-0.11.2.ebuild b/dev-libs/ppl/ppl-0.11.2.ebuild
index 848ec0e7974a..18a5c0c92983 100644
--- a/dev-libs/ppl/ppl-0.11.2.ebuild
+++ b/dev-libs/ppl/ppl-0.11.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/ppl/ppl-0.11.2.ebuild,v 1.3 2011/11/13 19:27:25 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/ppl/ppl-0.11.2.ebuild,v 1.4 2011/11/14 11:18:56 flameeyes Exp $
EAPI="3"
@@ -15,7 +15,7 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd ~amd64-linux ~sparc-solaris"
IUSE="doc lpsol pch test watchdog"
-RDEPEND="|| ( >=dev-libs/gmp-4.1.3[cxx] >=dev-libs/gmp-4.1.3[-nocxx] )
+RDEPEND=">=dev-libs/gmp-4.1.3[cxx]
lpsol? ( sci-mathematics/glpk )
!<dev-libs/cloog-ppl-0.15.10"
DEPEND="${RDEPEND}