summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-libs/gtk+/ChangeLog5
-rw-r--r--x11-libs/gtk+/Manifest5
-rw-r--r--x11-libs/gtk+/files/gtk+-2.2-notificationarea_loop.patch12
-rw-r--r--x11-libs/gtk+/gtk+-2.2.4-r1.ebuild12
4 files changed, 27 insertions, 7 deletions
diff --git a/x11-libs/gtk+/ChangeLog b/x11-libs/gtk+/ChangeLog
index 079966758097..cc9bc2ec273c 100644
--- a/x11-libs/gtk+/ChangeLog
+++ b/x11-libs/gtk+/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for x11-libs/gtk+
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/ChangeLog,v 1.78 2003/10/06 04:45:52 obz Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/ChangeLog,v 1.79 2003/10/09 12:34:50 foser Exp $
+
+ 08 Oct 2003; foser <foser@gentoo.org> gtk+-2.2.4-r1.ebuild :
+ Added patch to fix notification area, submitted by <pat@engsoc.org>
06 Oct 2003; Mike Gardiner <obz@gentoo.org> gtk+-2.2.4-r1.ebuild:
Marked stable on x86
diff --git a/x11-libs/gtk+/Manifest b/x11-libs/gtk+/Manifest
index fa9342ffa3a9..582b68d07aa0 100644
--- a/x11-libs/gtk+/Manifest
+++ b/x11-libs/gtk+/Manifest
@@ -1,7 +1,7 @@
-MD5 71fdbc2c98bdb91d1fac7c35467bd23d gtk+-2.2.4-r1.ebuild 2363
+MD5 ad213e9d4c49ac68f892ae2b3b437756 gtk+-2.2.4-r1.ebuild 2515
MD5 9f86b5b174549b5348c439235ed161d3 gtk+-2.2.1.ebuild 2324
MD5 33a5d19d9439db9c54b1dfc15e4e9928 gtk+-1.2.10-r10.ebuild 1848
-MD5 baed7d28b853e8372e5355abe3efe6bf ChangeLog 13110
+MD5 4cf5dd3ae7a83c874551bc59773a0db4 ChangeLog 13246
MD5 03ad2e6c4ab41244af1015a8bbb0b39f metadata.xml 158
MD5 d9cb8ab454327ffa0a26501e687127cc gtk+-2.2.1-r1.ebuild 2438
MD5 dab380359be57a8b0234710651374e96 files/digest-gtk+-2.2.1 64
@@ -9,6 +9,7 @@ MD5 621a7db3e7e6856c66eec5caeea1e88e files/digest-gtk+-1.2.10-r10 138
MD5 36d00cf3b4035e6cb9873ade9ed1a9ce files/gtkrc 627
MD5 5e3ff7fa761495300d3f30c9207c13f8 files/gtk+-1.2-locale_fix.patch 419
MD5 60abaa583c04f16be6d0703cc9684e45 files/gtk+-2.2.2-gtkwidget_pixmap_expose.patch 757
+MD5 897d9bcb56e9f9303b1e35c6f521ae35 files/gtk+-2.2-notificationarea_loop.patch 440
MD5 a0e14ed281fc891fd169e2bf7e247ad4 files/gtk+-2.2.1-gdkpixbuf-bigendian.patch 724
MD5 69a6335566f344b004a5db02b68008ed files/gtk+-2.0.6-exportsymbols.patch 558
MD5 c979d9262eccf5bdf8dbfa50b8d57b13 files/gtk+-2-xftprefs.patch 6711
diff --git a/x11-libs/gtk+/files/gtk+-2.2-notificationarea_loop.patch b/x11-libs/gtk+/files/gtk+-2.2-notificationarea_loop.patch
new file mode 100644
index 000000000000..b67e218a0cdf
--- /dev/null
+++ b/x11-libs/gtk+/files/gtk+-2.2-notificationarea_loop.patch
@@ -0,0 +1,12 @@
+diff -ur gtk+-2.2.4.orig/gtk/gtksocket.c gtk+-2.2.4/gtk/gtksocket.c
+--- gtk+-2.2.4.orig/gtk/gtksocket.c 2003-10-06 20:42:48.679102912 -0400
++++ gtk+-2.2.4/gtk/gtksocket.c 2003-10-06 20:43:02.267037232 -0400
+@@ -840,7 +840,7 @@
+ if (socket->plug_widget)
+ return gtk_widget_child_focus (socket->plug_widget, direction);
+
+- if (!GTK_WIDGET_HAS_FOCUS (widget))
++ if (!gtk_widget_is_focus (widget))
+ {
+ switch (direction)
+ {
diff --git a/x11-libs/gtk+/gtk+-2.2.4-r1.ebuild b/x11-libs/gtk+/gtk+-2.2.4-r1.ebuild
index 162f0f3ea874..daf6c10bd6be 100644
--- a/x11-libs/gtk+/gtk+-2.2.4-r1.ebuild
+++ b/x11-libs/gtk+/gtk+-2.2.4-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/gtk+-2.2.4-r1.ebuild,v 1.6 2003/10/06 04:45:52 obz Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/gtk+-2.2.4-r1.ebuild,v 1.7 2003/10/09 12:34:50 foser Exp $
inherit eutils libtool flag-o-matic
@@ -31,15 +31,19 @@ DEPEND="${RDEPEND}
src_unpack() {
unpack ${A}
+ cd ${S}
# Turn of --export-symbols-regex for now, since it removes
# the wrong symbols
- cd ${S}; epatch ${FILESDIR}/gtk+-2.0.6-exportsymbols.patch
+ epatch ${FILESDIR}/gtk+-2.0.6-exportsymbols.patch
# should speed up metacity
- cd ${S}; epatch ${FILESDIR}/gtk+-wm.patch
+ epatch ${FILESDIR}/gtk+-wm.patch
# beautifying patch for disabled icons
epatch ${FILESDIR}/${PN}-2.2.1-disable_icons_smooth_alpha.patch
# xft/slighthint stuff from RH
- cd ${S}; epatch ${FILESDIR}/${PN}-2-xftprefs.patch
+ epatch ${FILESDIR}/${PN}-2-xftprefs.patch
+ # notification area loop fix (http://bugs.gnome.org/show_bug.cgi?id=122327)
+ # submitted by <pat@engsoc.org>
+ epatch ${FILESDIR}/${PN}-2.2-notificationarea_loop.patch
autoconf || die
}