summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-office/abiword/ChangeLog7
-rw-r--r--app-office/abiword/Manifest17
-rw-r--r--app-office/abiword/abiword-2.0.3-r1.ebuild8
-rw-r--r--app-office/abiword/files/abiword-2.0.3-amd64.patch183
4 files changed, 204 insertions, 11 deletions
diff --git a/app-office/abiword/ChangeLog b/app-office/abiword/ChangeLog
index 7cb7fe33e7f7..8a9135e602c9 100644
--- a/app-office/abiword/ChangeLog
+++ b/app-office/abiword/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/abiword
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/abiword/ChangeLog,v 1.63 2004/02/18 15:59:40 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/abiword/ChangeLog,v 1.64 2004/03/02 16:47:14 augustus Exp $
+
+ 02 Mar 2004; <augustus@gentoo.org> abiword-2.0.3-r1.ebuild,
+ files/abiword-2.0.3-amd64.patch:
+ Added support for amd64 via a small patch which fixes pointer to 32-bit data
+ type conversion. Marked ~amd64 for now.
*abiword-2.0.3-r1 (18 Feb 2004)
diff --git a/app-office/abiword/Manifest b/app-office/abiword/Manifest
index 08558a23ebcd..082efe15e8b9 100644
--- a/app-office/abiword/Manifest
+++ b/app-office/abiword/Manifest
@@ -1,16 +1,17 @@
-MD5 c2d95202f224404420bc31e823155b4f abiword-2.0.3-r1.ebuild 2372
-MD5 81d41cc62b92ac1adba7924fa528c48a abiword-2.0.0.ebuild 2215
+MD5 4a14767aa8d03a98a1532f94d2610f39 ChangeLog 9787
MD5 7921df3134ed60f1eb9c3d1c920bde16 abiword-1.0.6-r1.ebuild 1927
-MD5 2cea2a3dd4030bc2ad09765a5f083ef4 abiword-2.0.2.ebuild 2255
+MD5 81d41cc62b92ac1adba7924fa528c48a abiword-2.0.0.ebuild 2215
MD5 32730f5ef95f89d3f059ae26a72f7cbf abiword-2.0.1.ebuild 2171
-MD5 04a206dc6d2a3d70dd1cc53383a46752 abiword-2.0.3.ebuild 2134
-MD5 1c9152a3e70878a8b56c94a1c20b31ed ChangeLog 9565
+MD5 2cea2a3dd4030bc2ad09765a5f083ef4 abiword-2.0.2.ebuild 2255
MD5 03ad2e6c4ab41244af1015a8bbb0b39f metadata.xml 158
+MD5 04a206dc6d2a3d70dd1cc53383a46752 abiword-2.0.3.ebuild 2134
+MD5 58f4f455b57d36a428740f743220f425 abiword-2.0.3-r1.ebuild 2530
+MD5 31616e14907aefda2489036cc3d1db3d files/AbiWord.desktop 901
+MD5 1ebcd22c6249c06e631c13491113d8ef files/AbiWord2.desktop 166
+MD5 55d85bca7cd645ef338336da3d6e6a7e files/digest-abiword-1.0.6-r1 67
MD5 53a88ebee6a70ad41f3eb428b4a3a3e7 files/digest-abiword-2.0.0 142
MD5 28dcae4a10f58c12a4a73346a7ab1ed0 files/digest-abiword-2.0.1 142
MD5 20b01c6c3348c63e1b088cf107398e0c files/digest-abiword-2.0.2 68
MD5 ddf70a53b4fc5671c7ed5cb4acb4a6e8 files/digest-abiword-2.0.3 68
-MD5 31616e14907aefda2489036cc3d1db3d files/AbiWord.desktop 901
MD5 ddf70a53b4fc5671c7ed5cb4acb4a6e8 files/digest-abiword-2.0.3-r1 68
-MD5 1ebcd22c6249c06e631c13491113d8ef files/AbiWord2.desktop 166
-MD5 55d85bca7cd645ef338336da3d6e6a7e files/digest-abiword-1.0.6-r1 67
+MD5 cd037c182094f6ba10b7dd9e15035efd files/abiword-2.0.3-amd64.patch 8632
diff --git a/app-office/abiword/abiword-2.0.3-r1.ebuild b/app-office/abiword/abiword-2.0.3-r1.ebuild
index aca25559172e..d66fb13c7482 100644
--- a/app-office/abiword/abiword-2.0.3-r1.ebuild
+++ b/app-office/abiword/abiword-2.0.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/abiword/abiword-2.0.3-r1.ebuild,v 1.1 2004/02/18 15:59:40 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/abiword/abiword-2.0.3-r1.ebuild,v 1.2 2004/03/02 16:47:14 augustus Exp $
inherit eutils
@@ -15,7 +15,7 @@ HOMEPAGE="http://www.abisource.com"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
-KEYWORDS="~x86 ~sparc ~alpha ~ppc"
+KEYWORDS="~x86 ~sparc ~alpha ~ppc ~amd64"
LICENSE="GPL-2"
SLOT="2"
@@ -40,6 +40,10 @@ DEPEND="${RDEPEND}
dev-util/pkgconfig"
src_compile() {
+ # Abiword is not 64-bit safe. This is a patch for AMD64.
+ if [ $ARCH = "amd64" ] ; then
+ epatch ${FILESDIR}/abiword-2.0.3-amd64.patch || die
+ fi
# this is a hack since I don't want to go hack in the gnome-vfs headerfiles.
# The issue is about gnome-vfs containing "long long" which makes gcc 3.3.1 balk
diff --git a/app-office/abiword/files/abiword-2.0.3-amd64.patch b/app-office/abiword/files/abiword-2.0.3-amd64.patch
new file mode 100644
index 000000000000..a977b7013256
--- /dev/null
+++ b/app-office/abiword/files/abiword-2.0.3-amd64.patch
@@ -0,0 +1,183 @@
+diff -ur abiword-2.0.3/abi/src/af/xap/unix/xap_UnixFont.cpp abiword-2.0.3-amd64/abi/src/af/xap/unix/xap_UnixFont.cpp
+--- abiword-2.0.3/abi/src/af/xap/unix/xap_UnixFont.cpp 2003-08-22 16:52:07.000000000 -0400
++++ abiword-2.0.3-amd64/abi/src/af/xap/unix/xap_UnixFont.cpp 2004-03-02 11:15:19.138416528 -0500
+@@ -400,10 +400,10 @@
+ size_t idx = 0;
+ for (size_t i = 0; i < coverage.size(); i += 2)
+ {
+- UT_UCSChar c1 = static_cast<UT_UCSChar>(reinterpret_cast<UT_uint32>(coverage[i]));
++ UT_UCSChar c1 = static_cast<UT_UCSChar>(reinterpret_cast<unsigned long>(coverage[i]));
+ UT_UCSChar c2 =
+ static_cast<UT_UCSChar>(static_cast<UT_uint32>(c1)) +
+- static_cast<UT_UCSChar>(reinterpret_cast<UT_uint32>(coverage[i + 1]));
++ static_cast<UT_UCSChar>(reinterpret_cast<unsigned long>(coverage[i + 1]));
+ for (UT_UCSChar c = c1; c < c2; ++c)
+ {
+ FT_UInt glyph_idx = FT_Get_Char_Index(face, c);
+diff -ur abiword-2.0.3/abi/src/af/xap/xp/xap_Draw_Symbol.cpp abiword-2.0.3-amd64/abi/src/af/xap/xp/xap_Draw_Symbol.cpp
+--- abiword-2.0.3/abi/src/af/xap/xp/xap_Draw_Symbol.cpp 2003-05-07 13:40:40.000000000 -0400
++++ abiword-2.0.3-amd64/abi/src/af/xap/xp/xap_Draw_Symbol.cpp 2004-03-02 11:15:15.767928920 -0500
+@@ -153,7 +153,7 @@
+
+ for (i = 0; i < m_vCharSet.size(); i += 2)
+ {
+- UT_UCSChar base = static_cast<UT_UCSChar>(reinterpret_cast<UT_uint32>(m_vCharSet[i]));
++ UT_UCSChar base = static_cast<UT_UCSChar>(reinterpret_cast<unsigned long>(m_vCharSet[i]));
+ size_t nb_chars = reinterpret_cast<size_t>(m_vCharSet[i + 1]);
+
+ for (UT_UCSChar j = base; j < base + nb_chars; ++j)
+@@ -194,11 +194,11 @@
+ UT_DEBUGMSG(("calcSymbolFromCoords(x = [%u], y = [%u]) =", ix, iy));
+ for (size_t i = 0; i < m_vCharSet.size(); i += 2)
+ {
+- count += reinterpret_cast<UT_uint32>(m_vCharSet[i + 1]);
++ count += reinterpret_cast<unsigned long>(m_vCharSet[i + 1]);
+ if (count > index)
+ {
+- UT_DEBUGMSG((" %u\n", static_cast<UT_uint32>(reinterpret_cast<UT_uint32>(m_vCharSet[i]) + index - count + reinterpret_cast<UT_uint32>(m_vCharSet[i + 1]))));
+- return static_cast<UT_UCSChar>(reinterpret_cast<UT_uint32>(m_vCharSet[i]) + index - count + reinterpret_cast<UT_uint32>(m_vCharSet[i + 1]));
++ UT_DEBUGMSG((" %u\n", static_cast<UT_uint32>(reinterpret_cast<unsigned long>(m_vCharSet[i]) + index - count + reinterpret_cast<UT_uint32>(m_vCharSet[i + 1]))));
++ return static_cast<UT_UCSChar>(reinterpret_cast<unsigned long>(m_vCharSet[i]) + index - count + reinterpret_cast<unsigned long>(m_vCharSet[i + 1]));
+ }
+ }
+
+@@ -227,8 +227,8 @@
+
+ for (size_t i = 0; i < m_vCharSet.size(); i += 2)
+ {
+- UT_uint32 base = reinterpret_cast<UT_uint32>(m_vCharSet[i]);
+- UT_uint32 size = reinterpret_cast<UT_uint32>(m_vCharSet[i + 1]);
++ UT_uint32 base = reinterpret_cast<unsigned long>(m_vCharSet[i]);
++ UT_uint32 size = reinterpret_cast<unsigned long>(m_vCharSet[i + 1]);
+
+ if (base + size > c)
+ {
+diff -ur abiword-2.0.3/abi/src/wp/impexp/xp/ie_Table.cpp abiword-2.0.3-amd64/abi/src/wp/impexp/xp/ie_Table.cpp
+--- abiword-2.0.3/abi/src/wp/impexp/xp/ie_Table.cpp 2003-08-24 21:45:11.000000000 -0400
++++ abiword-2.0.3-amd64/abi/src/wp/impexp/xp/ie_Table.cpp 2004-03-02 11:15:25.290481272 -0500
+@@ -1028,7 +1028,7 @@
+ UT_sint32 j = 0;
+ for(j=0; !bMatch && (j < static_cast<UT_sint32>(m_vecCellX.getItemCount())); j++)
+ {
+- UT_sint32 prevX = reinterpret_cast<UT_sint32>(m_vecCellX.getNthItem(j));
++ UT_sint32 prevX = reinterpret_cast<signed long>(m_vecCellX.getNthItem(j));
+ UT_DEBUGMSG(("Prev cell %d cellx %d \n",j,prevX));
+ bool bLast = ((j-1) == szCurRow);
+ bMatch = doCellXMatch(prevX,curX,bLast);
+@@ -1179,7 +1179,7 @@
+ sColWidth.clear();
+ for(i=0; i< static_cast<UT_sint32>(m_vecCellX.getItemCount()); i++)
+ {
+- UT_sint32 iCellx = reinterpret_cast<UT_sint32>(m_vecCellX.getNthItem(i));
++ UT_sint32 iCellx = reinterpret_cast<signed long>(m_vecCellX.getNthItem(i));
+ xxx_UT_DEBUGMSG(("final cellx import cellx %d iPrev %x \n",iCellx,iPrev));
+ UT_sint32 iDiffCellx = iCellx - iPrev;
+ double dCellx = static_cast<double>(iDiffCellx)/1440.0 -dColSpace;
+@@ -1377,7 +1377,7 @@
+ UT_sint32 iSub = 0;
+ for(i=0; !bFound && (i< static_cast<UT_sint32>(m_vecCellX.getItemCount())); i++)
+ {
+- UT_sint32 icellx = reinterpret_cast<UT_sint32>(m_vecCellX.getNthItem(i));
++ UT_sint32 icellx = reinterpret_cast<signed long>(m_vecCellX.getNthItem(i));
+ if(icellx == -1)
+ {
+ iSub++;
+diff -ur abiword-2.0.3/abi/src/wp/impexp/xp/ie_exp_HTML.cpp abiword-2.0.3-amd64/abi/src/wp/impexp/xp/ie_exp_HTML.cpp
+--- abiword-2.0.3/abi/src/wp/impexp/xp/ie_exp_HTML.cpp 2004-01-12 03:31:23.000000000 -0500
++++ abiword-2.0.3-amd64/abi/src/wp/impexp/xp/ie_exp_HTML.cpp 2004-03-02 11:15:21.021130312 -0500
+@@ -777,7 +777,7 @@
+ void * vptr = 0;
+ m_tagStack.pop (&vptr);
+
+- if (reinterpret_cast<UT_uint32>(vptr) == tagID) return;
++ if (reinterpret_cast<unsigned long>(vptr) == tagID) return;
+
+ UT_DEBUGMSG(("WARNING: possible tag mis-match in XHTML output!\n"));
+ }
+@@ -821,7 +821,7 @@
+ UT_uint32 s_HTML_Listener::tagTop ()
+ {
+ void * vptr = 0;
+- if (m_tagStack.viewTop (&vptr)) return reinterpret_cast<UT_uint32>(vptr);
++ if (m_tagStack.viewTop (&vptr)) return reinterpret_cast<unsigned long>(vptr);
+ return 0;
+ }
+
+@@ -1899,7 +1899,7 @@
+ {
+ void * vptr = 0;
+ m_utsListType.viewTop (&vptr);
+- return static_cast<UT_uint16>(reinterpret_cast<UT_uint32>(vptr));
++ return static_cast<UT_uint16>(reinterpret_cast<unsigned long>(vptr));
+ }
+
+ void s_HTML_Listener::listPush (UT_uint16 type, const char * ClassName)
+@@ -1938,7 +1938,7 @@
+
+ void * vptr = 0;
+ m_utsListType.pop (&vptr);
+- UT_uint16 type = static_cast<UT_uint16>(reinterpret_cast<UT_uint32>(vptr));
++ UT_uint16 type = static_cast<UT_uint16>(reinterpret_cast<unsigned long>(vptr));
+
+ UT_uint32 tagID;
+
+diff -ur abiword-2.0.3/abi/src/wp/impexp/xp/ie_imp_RTF.cpp abiword-2.0.3-amd64/abi/src/wp/impexp/xp/ie_imp_RTF.cpp
+--- abiword-2.0.3/abi/src/wp/impexp/xp/ie_imp_RTF.cpp 2003-12-26 20:05:47.000000000 -0500
++++ abiword-2.0.3-amd64/abi/src/wp/impexp/xp/ie_imp_RTF.cpp 2004-03-02 11:15:22.517902768 -0500
+@@ -1211,9 +1211,9 @@
+ m_iOverrideLevel = other.m_iOverrideLevel;
+ if(m_tabTypes.getItemCount() > 0)
+ {
+- UT_uint32 dum = reinterpret_cast<UT_uint32>(m_tabTypes.getNthItem(0));
++ UT_uint32 dum = reinterpret_cast<unsigned long>(m_tabTypes.getNthItem(0));
+ m_curTabType = static_cast<eTabType>(dum);
+- dum = reinterpret_cast<UT_uint32>(m_tabLeader.getNthItem(0));
++ dum = reinterpret_cast<unsigned long>(m_tabLeader.getNthItem(0));
+ m_curTabLeader = static_cast<eTabLeader>(dum);
+ }
+ else
+@@ -2458,7 +2458,7 @@
+ {
+ if (colNum < m_colourTable.getItemCount())
+ {
+- return reinterpret_cast<UT_uint32>(m_colourTable.getNthItem(colNum));
++ return reinterpret_cast<unsigned long>(m_colourTable.getNthItem(colNum));
+ }
+ else
+ {
+@@ -2470,7 +2470,7 @@
+ {
+ if (colNum < m_colourTable.getItemCount())
+ {
+- return reinterpret_cast<UT_sint32>(m_colourTable.getNthItem(colNum));
++ return reinterpret_cast<signed long>(m_colourTable.getNthItem(colNum));
+ }
+ else
+ {
+@@ -6327,11 +6327,11 @@
+ if (i > 0)
+ propBuffer += ",";
+
+- UT_sint32 tabTwips = reinterpret_cast<UT_sint32>(m_currentRTFState.m_paraProps.m_tabStops.getNthItem(i));
++ UT_sint32 tabTwips = reinterpret_cast<signed long>(m_currentRTFState.m_paraProps.m_tabStops.getNthItem(i));
+ double tabIn = tabTwips/(20.0*72.);
+- UT_uint32 idum = reinterpret_cast<UT_uint32>(m_currentRTFState.m_paraProps.m_tabTypes.getNthItem(i));
++ UT_uint32 idum = reinterpret_cast<unsigned long>(m_currentRTFState.m_paraProps.m_tabTypes.getNthItem(i));
+ eTabType tabType = static_cast<eTabType>(idum);
+- idum = reinterpret_cast<UT_uint32>((m_currentRTFState.m_paraProps.m_tabLeader.getNthItem(i)));
++ idum = reinterpret_cast<unsigned long>((m_currentRTFState.m_paraProps.m_tabLeader.getNthItem(i)));
+ eTabLeader tabLeader = static_cast<eTabLeader>(idum);
+ char cType = ' ';
+ switch(tabType)
+@@ -9808,9 +9808,9 @@
+ if (i > 0)
+ strcat(propBuffer, ",");
+
+- UT_sint32 tabTwips = reinterpret_cast<UT_sint32>(pParas->m_tabStops.getNthItem(i));
++ UT_sint32 tabTwips = reinterpret_cast<signed long>(pParas->m_tabStops.getNthItem(i));
+ double tabIn = tabTwips/(20.0*72.);
+- UT_uint32 idum = reinterpret_cast<UT_uint32>(pParas->m_tabTypes.getNthItem(i));
++ UT_uint32 idum = reinterpret_cast<unsigned long>(pParas->m_tabTypes.getNthItem(i));
+ eTabType tabType = static_cast<eTabType>(idum);
+ idum = (UT_uint32) (pParas->m_tabLeader.getNthItem(i));
+ eTabLeader tabLeader = static_cast<eTabLeader>(idum);