summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ml/ounit/ChangeLog9
-rw-r--r--dev-ml/ounit/Manifest12
-rw-r--r--dev-ml/ounit/ounit-1.1.0.ebuild46
3 files changed, 60 insertions, 7 deletions
diff --git a/dev-ml/ounit/ChangeLog b/dev-ml/ounit/ChangeLog
index b38fd7781049..7d96b486527c 100644
--- a/dev-ml/ounit/ChangeLog
+++ b/dev-ml/ounit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/ounit
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/ounit/ChangeLog,v 1.19 2009/09/28 16:26:13 betelgeuse Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ounit/ChangeLog,v 1.20 2010/10/09 00:52:50 aballier Exp $
+
+*ounit-1.1.0 (09 Oct 2010)
+
+ 09 Oct 2010; Alexis Ballier <aballier@gentoo.org> +ounit-1.1.0.ebuild:
+ version bump
28 Sep 2009; Petteri Räty <betelgeuse@gentoo.org> ounit-1.0.3.ebuild:
Migrate to EAPI 2 in order to nuke built_with_use.
diff --git a/dev-ml/ounit/Manifest b/dev-ml/ounit/Manifest
index aba65737651d..854efa9cc6af 100644
--- a/dev-ml/ounit/Manifest
+++ b/dev-ml/ounit/Manifest
@@ -2,13 +2,15 @@
Hash: SHA1
DIST ounit-1.0.3.tar.gz 13572 RMD160 35496f9df16121b4246074e79df0c5396e3faba7 SHA1 fd5674ba094ed8d32c11618cd22d4efa58535a76 SHA256 27c5084d67dcf600f7f8cc85e15bd828cefebdedbf3c39817d00541157a6fed8
+DIST ounit-1.1.0.tar.gz 52228 RMD160 f7d82446970f40eccc917a3ee57e7d6526b1b177 SHA1 e477f8a1b4fcd6a838cbbc04450a80b1cea3456c SHA256 1d57292ec2983943a00f4e0b448aa8ba4df89da40cdd216e44ac70dad35b7e8b
EBUILD ounit-1.0.3.ebuild 764 RMD160 d8f3e9cc5500ad708d759c8d721db3dc9b901494 SHA1 2dd553528318fe0ff69d3d0d09018c6c6ccc7f69 SHA256 9aee149a0eeb16a56d29e88ad2fe8334d743c40d4ec0220b9623c6631111caea
-MISC ChangeLog 2365 RMD160 5b4ce4b2c7f8df207cb8684b9e44dfc6baca658a SHA1 c02a39ad0aaa4bc76d4e6b98ab9c66ae5bab7841 SHA256 d3d6d167fe23e6409a240d2fdb97b8c92a8a2e6b149d7de735d57f51abb18d5c
+EBUILD ounit-1.1.0.ebuild 1078 RMD160 75bdd8384a6b4f69638a3d938d9acdcad799ed22 SHA1 9f6da5c01bb86038a14a2a9af7f8b747a700f0ba SHA256 9dc7bfca3e7ac77f818b2bd6a0a35368d5c1ca07848b8213a81a659c58b3e091
+MISC ChangeLog 2480 RMD160 feb6f2066c3ad98b28b9719a9747ff93d4146cde SHA1 6957b3930765a338bc8e7af885ae0c47bbeb65cf SHA256 0286e7407eeb5fa06797b0f0079783b30c5b8d891dd532f2fcebf38db8d8ffea
MISC metadata.xml 155 RMD160 dfaa057e679b01302a807c75a32a910098b26809 SHA1 94024f83dcacbb53e92be090dd0f994ec93dc90d SHA256 118048376ebb76f57628b0819f3de4856e73959c2578c88715d37ea2d1e0af81
-----BEGIN PGP SIGNATURE-----
-Version: GnuPG v2.0.11 (GNU/Linux)
+Version: GnuPG v2.0.16 (GNU/Linux)
-iEYEARECAAYFAkrA468ACgkQcxLzpIGCsLSdFgCfZ1g7c0/i+QKuSrCMoUlllH1j
-i3UAn24WYccjZnze6zT6huM/UCOu5hJm
-=1CCB
+iEYEARECAAYFAkyvvOgACgkQvFcC4BYPU0pFXwCfUzSxCtrxLhiNIggyAonqvp8Z
+u3EAoJz9068+gUuRVAVU//lblmPyiQpt
+=kgAq
-----END PGP SIGNATURE-----
diff --git a/dev-ml/ounit/ounit-1.1.0.ebuild b/dev-ml/ounit/ounit-1.1.0.ebuild
new file mode 100644
index 000000000000..79e291baf453
--- /dev/null
+++ b/dev-ml/ounit/ounit-1.1.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ounit/ounit-1.1.0.ebuild,v 1.1 2010/10/09 00:52:50 aballier Exp $
+
+EAPI="2"
+
+inherit findlib multilib
+
+DESCRIPTION="Unit testing framework for OCaml"
+HOMEPAGE="http://ounit.forge.ocamlcore.org/"
+SRC_URI="https://forge.ocamlcore.org/frs/download.php/495/${P}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+DEPEND=">=dev-lang/ocaml-3.10.2[ocamlopt?]"
+RDEPEND="${DEPEND}"
+IUSE="debug doc +ocamlopt"
+
+oasis_use_enable() {
+ echo "--override $2 `use $1 && echo \"true\" || echo \"false\"`"
+}
+
+src_configure() {
+ chmod +x configure
+ ./configure --prefix usr \
+ --libdir /usr/$(get_libdir) \
+ --docdir /usr/share/doc/${PF}/html \
+ --destdir "${D}" \
+ $(oasis_use_enable debug debug) \
+ $(oasis_use_enable ocamlopt is_native) \
+ || die
+}
+
+src_compile() {
+ emake || die
+ if use doc ; then
+ emake doc || die
+ fi
+}
+
+src_install() {
+ findlib_src_install
+
+ # install documentation
+ dodoc README* AUTHORS* changelog || die
+}