summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-emulation/vice/ChangeLog9
-rw-r--r--app-emulation/vice/Manifest14
-rw-r--r--app-emulation/vice/files/digest-vice-1.191
-rw-r--r--app-emulation/vice/vice-1.19.ebuild53
4 files changed, 74 insertions, 3 deletions
diff --git a/app-emulation/vice/ChangeLog b/app-emulation/vice/ChangeLog
index b32ba70c9461..cff90fafbe6e 100644
--- a/app-emulation/vice/ChangeLog
+++ b/app-emulation/vice/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/vice
-# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/vice/ChangeLog,v 1.31 2005/12/25 02:36:53 mr_bones_ Exp $
+# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/vice/ChangeLog,v 1.32 2006/01/17 22:38:32 hanno Exp $
+
+*vice-1.19 (17 Jan 2006)
+
+ 17 Jan 2006; Hanno Boeck <hanno@gentoo.org> +vice-1.19.ebuild:
+ Version bump.
*vice-1.18 (25 Dec 2005)
diff --git a/app-emulation/vice/Manifest b/app-emulation/vice/Manifest
index 46638160ed2d..a0f80c3355ea 100644
--- a/app-emulation/vice/Manifest
+++ b/app-emulation/vice/Manifest
@@ -1,6 +1,18 @@
-MD5 ecaa46c74c0def12896a57fd060e3692 ChangeLog 3959
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 f8a6d9d802321f81f966b4b0b31c58ae ChangeLog 4063
MD5 feb8195c915d5109dfd6b96df7bf4f91 files/digest-vice-1.17 62
MD5 cd31f7a55868b771220fd5dac0c85413 files/digest-vice-1.18 62
+MD5 a3c398734bf808672ba34c9328f8ef1e files/digest-vice-1.19 62
MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
MD5 55fb0dcd75db1a9a0e93d53e6daa5549 vice-1.17.ebuild 1368
MD5 546ff74a5b9fa1734c8b4eb0afcc66e5 vice-1.18.ebuild 1373
+MD5 5c1753cc3e669c9f0e61e4c8e82ab39c vice-1.19.ebuild 1369
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.2 (GNU/Linux)
+
+iD8DBQFDzXILr2QksT29OyARAnHoAJ9zlf+vhrlhTpQkeimgCaxr3U/E6wCfayEL
+9kALZzZ3EIqgeU65BUnS88U=
+=2L2F
+-----END PGP SIGNATURE-----
diff --git a/app-emulation/vice/files/digest-vice-1.19 b/app-emulation/vice/files/digest-vice-1.19
new file mode 100644
index 000000000000..f4dae3e44ae5
--- /dev/null
+++ b/app-emulation/vice/files/digest-vice-1.19
@@ -0,0 +1 @@
+MD5 92f828f29e05f57d7a498a861d3dab6a vice-1.19.tar.gz 4796181
diff --git a/app-emulation/vice/vice-1.19.ebuild b/app-emulation/vice/vice-1.19.ebuild
new file mode 100644
index 000000000000..e04601433bc9
--- /dev/null
+++ b/app-emulation/vice/vice-1.19.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/vice/vice-1.19.ebuild,v 1.1 2006/01/17 22:38:32 hanno Exp $
+
+inherit eutils games
+
+DESCRIPTION="The Versatile Commodore 8-bit Emulator"
+HOMEPAGE="http://www.viceteam.org/"
+SRC_URI="ftp://ftp.zimmers.net/pub/cbm/crossplatform/emulators/VICE/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="X Xaw3d arts esd ffmpeg gnome nls readline sdl"
+
+DEPEND="esd? ( media-sound/esound )
+ media-libs/libpng
+ sys-libs/zlib
+ arts? ( kde-base/arts )
+ gnome? ( gnome-base/gnome-libs )
+ readline? ( sys-libs/readline )
+ sdl? ( media-libs/libsdl )
+ X? ( virtual/x11 )
+ Xaw3d? ( x11-libs/Xaw3d )
+ ffmpeg? ( media-video/ffmpeg )"
+
+src_compile() {
+ egamesconf \
+ --disable-dependency-tracking \
+ --enable-fullscreen \
+ --enable-textfield \
+ --enable-ethernet \
+ --enable-realdevice \
+ --with-resid \
+ --without-midas \
+ $(use_enable ffmpeg) \
+ $(use_enable gnome gnomeui) \
+ $(use_enable nls) \
+ $(use_with X x) \
+ $(use_with Xaw3d xaw3d) \
+ $(use_with arts) \
+ $(use_with esd) \
+ $(use_with readline) \
+ $(use_with sdl) \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS ChangeLog FEEDBACK README
+ prepgamesdirs
+}