summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-libs/libast/ChangeLog9
-rw-r--r--x11-libs/libast/Manifest10
-rw-r--r--x11-libs/libast/files/digest-libast-99990
-rw-r--r--x11-libs/libast/libast-9999.ebuild51
4 files changed, 64 insertions, 6 deletions
diff --git a/x11-libs/libast/ChangeLog b/x11-libs/libast/ChangeLog
index 9f00be9dea0f..6fcff6d305e6 100644
--- a/x11-libs/libast/ChangeLog
+++ b/x11-libs/libast/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/libast
-# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libast/ChangeLog,v 1.15 2005/03/06 11:01:49 corsair Exp $
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libast/ChangeLog,v 1.16 2005/04/18 23:52:31 vapier Exp $
+
+*libast-9999 (18 Apr 2005)
+
+ 18 Apr 2005; Mike Frysinger <vapier@gentoo.org> +libast-9999.ebuild:
+ Add a cvs ebuild.
06 Mar 2005; Markus Rothe <corsair@gentoo.org> libast-0.6.1.ebuild:
Added ~ppc64 to KEYWORDS
diff --git a/x11-libs/libast/Manifest b/x11-libs/libast/Manifest
index 05539b9657d9..396b7fa2f475 100644
--- a/x11-libs/libast/Manifest
+++ b/x11-libs/libast/Manifest
@@ -1,7 +1,9 @@
-MD5 0a03d3a425e6510136600736fa8b473a ChangeLog 2079
-MD5 4ff5aac6ece5cfa07cd1cea5291e6ffd libast-0.5-r2.ebuild 872
+MD5 f628f715cf5e5da628a68584527b6d9e ChangeLog 2198
MD5 ec45fec065a8eccc43870fc678126de7 metadata.xml 820
-MD5 b679e2438537598ebd25c8693fd532ea libast-0.6.1.ebuild 862
-MD5 2a9e814b7851e9e22178430153da8110 files/digest-libast-0.5-r2 62
+MD5 4ff5aac6ece5cfa07cd1cea5291e6ffd libast-0.5-r2.ebuild 872
+MD5 d0516a88e674f6eb4ede58ff59ea5d1c libast-9999.ebuild 1174
+MD5 121d807760d74693a7869d6a7b3ee6c5 libast-0.6.1.ebuild 854
MD5 bb5de296213b5928dd8f956e40436668 files/libast-64bit.patch 441
+MD5 2a9e814b7851e9e22178430153da8110 files/digest-libast-0.5-r2 62
MD5 0cf4b65fa766332e528bddb7cf3d74e2 files/digest-libast-0.6.1 64
+MD5 d41d8cd98f00b204e9800998ecf8427e files/digest-libast-9999 0
diff --git a/x11-libs/libast/files/digest-libast-9999 b/x11-libs/libast/files/digest-libast-9999
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/x11-libs/libast/files/digest-libast-9999
diff --git a/x11-libs/libast/libast-9999.ebuild b/x11-libs/libast/libast-9999.ebuild
new file mode 100644
index 000000000000..d0e216ac7c9b
--- /dev/null
+++ b/x11-libs/libast/libast-9999.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libast/libast-9999.ebuild,v 1.1 2005/04/18 23:52:31 vapier Exp $
+
+ECVS_MODULE="eterm/libast"
+ECVS_SERVER="cvs.sourceforge.net:/cvsroot/enlightenment"
+inherit eutils cvs
+
+DESCRIPTION="LIBrary of Assorted Spiffy Things"
+HOMEPAGE="http://www.eterm.org/download/"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~sparc ~x86 ~ppc64"
+IUSE="imlib mmx pcre"
+
+DEPEND="virtual/x11
+ =media-libs/freetype-2*
+ imlib? ( media-libs/imlib2 )
+ pcre? ( dev-libs/libpcre )"
+
+S=${WORKDIR}/${ECVS_MODULE}
+
+src_unpack() {
+ cvs_src_unpack
+ cd "${S}"
+ # autogen.sh is broken so do this ourselves
+ #./autogen.sh || die "autogen failed"
+ aclocal -I . && \
+ autoheader && \
+ libtoolize -c -f && \
+ autoconf && \
+ automake -a -c || die "autotools failed"
+}
+
+src_compile() {
+ local myregexp="posix"
+ use pcre && myregexp="pcre"
+ econf \
+ $(use_with imlib) \
+ $(use_enable mmx) \
+ --with-regexp=${myregexp} \
+ || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc README DESIGN ChangeLog
+}