summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-libs/libselinux/ChangeLog8
-rw-r--r--sys-libs/libselinux/libselinux-2.0.85.ebuild71
-rw-r--r--sys-libs/libsemanage/ChangeLog8
-rw-r--r--sys-libs/libsemanage/libsemanage-2.0.33.ebuild72
-rw-r--r--sys-libs/libsepol/ChangeLog7
-rw-r--r--sys-libs/libsepol/libsepol-2.0.37.ebuild43
6 files changed, 206 insertions, 3 deletions
diff --git a/sys-libs/libselinux/ChangeLog b/sys-libs/libselinux/ChangeLog
index d23822a4e572..4e057aa6fe48 100644
--- a/sys-libs/libselinux/ChangeLog
+++ b/sys-libs/libselinux/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-libs/libselinux
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libselinux/ChangeLog,v 1.62 2009/07/22 13:25:49 pebenito Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libselinux/ChangeLog,v 1.63 2009/08/02 01:13:01 pebenito Exp $
+
+*libselinux-2.0.85 (02 Aug 2009)
+
+ 02 Aug 2009; Chris PeBenito <pebenito@gentoo.org>
+ +libselinux-2.0.85.ebuild:
+ New upstream release.
18 Jul 2009; Chris PeBenito <pebenito@gentoo.org>
-libselinux-1.34.14.ebuild, libselinux-2.0.71.ebuild:
diff --git a/sys-libs/libselinux/libselinux-2.0.85.ebuild b/sys-libs/libselinux/libselinux-2.0.85.ebuild
new file mode 100644
index 000000000000..2f0062d5d509
--- /dev/null
+++ b/sys-libs/libselinux/libselinux-2.0.85.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libselinux/libselinux-2.0.85.ebuild,v 1.1 2009/08/02 01:13:01 pebenito Exp $
+
+IUSE="ruby"
+RUBY_OPTIONAL="yes"
+
+inherit eutils multilib python ruby
+
+#BUGFIX_PATCH="${FILESDIR}/libselinux-1.30.3.diff"
+
+SEPOL_VER="2.0"
+
+DESCRIPTION="SELinux userland library"
+HOMEPAGE="http://userspace.selinuxproject.org"
+SRC_URI="http://userspace.selinuxproject.org/releases/current/devel/${P}.tar.gz"
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="=sys-libs/libsepol-${SEPOL_VER}*
+ dev-lang/swig
+ ruby? ( dev-lang/ruby )"
+
+RDEPEND="=sys-libs/libsepol-${SEPOL_VER}*
+ ruby? ( dev-lang/ruby )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ [ ! -z "${BUGFIX_PATCH}" ] && epatch "${BUGFIX_PATCH}"
+
+ # fix up paths for multilib
+ sed -i -e "/^LIBDIR/s/lib/$(get_libdir)/" "${S}/src/Makefile" \
+ || die "Fix for multilib LIBDIR failed."
+ sed -i -e "/^SHLIBDIR/s/lib/$(get_libdir)/" "${S}/src/Makefile" \
+ || die "Fix for multilib SHLIBDIR failed."
+}
+
+src_compile() {
+ python_version
+ emake LDFLAGS="-fPIC ${LDFLAGS}" all || die
+ emake PYLIBVER="python${PYVER}" LDFLAGS="-fPIC ${LDFLAGS}" pywrap || die
+
+ if use ruby; then
+ emake rubywrap || die
+ fi
+
+ # add compatability aliases to swig wrapper
+ cat "${FILESDIR}/compat.py" >> "${S}/src/selinux.py" || die
+}
+
+src_install() {
+ python_version
+ make DESTDIR="${D}" PYLIBVER="python${PYVER}" install install-pywrap || die
+
+ if use ruby; then
+ emake DESTDIR="${D}" install-rubywrap || die
+ fi
+}
+
+pkg_postinst() {
+ python_version
+ python_mod_optimize /usr/$(get_libdir)/python${PYVER}/site-packages
+}
+
+pkg_postrm() {
+ python_version
+ python_mod_cleanup /usr/$(get_libdir)/python${PYVER}/site-packages
+}
diff --git a/sys-libs/libsemanage/ChangeLog b/sys-libs/libsemanage/ChangeLog
index 44ecf65586e1..0158f2dca5b9 100644
--- a/sys-libs/libsemanage/ChangeLog
+++ b/sys-libs/libsemanage/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-libs/libsemanage
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libsemanage/ChangeLog,v 1.24 2009/07/22 13:25:19 pebenito Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libsemanage/ChangeLog,v 1.25 2009/08/02 01:14:14 pebenito Exp $
+
+*libsemanage-2.0.33 (02 Aug 2009)
+
+ 02 Aug 2009; Chris PeBenito <pebenito@gentoo.org>
+ +libsemanage-2.0.33.ebuild:
+ New upstream release.
18 Jul 2009; Chris PeBenito <pebenito@gentoo.org>
-libsemanage-1.10.9.ebuild, libsemanage-2.0.27.ebuild:
diff --git a/sys-libs/libsemanage/libsemanage-2.0.33.ebuild b/sys-libs/libsemanage/libsemanage-2.0.33.ebuild
new file mode 100644
index 000000000000..125661772c0d
--- /dev/null
+++ b/sys-libs/libsemanage/libsemanage-2.0.33.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libsemanage/libsemanage-2.0.33.ebuild,v 1.1 2009/08/02 01:14:14 pebenito Exp $
+
+IUSE=""
+
+inherit eutils multilib python
+
+# BUGFIX_PATCH="${FILESDIR}/libsemanage-1.6.6.diff"
+
+SEPOL_VER="2.0"
+SELNX_VER="2.0"
+
+DESCRIPTION="SELinux kernel and policy management library"
+HOMEPAGE="http://userspace.selinuxproject.org"
+SRC_URI="http://userspace.selinuxproject.org/releases/current/devel/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+DEPEND="=sys-libs/libsepol-${SEPOL_VER}*
+ =sys-libs/libselinux-${SELNX_VER}*
+ dev-libs/ustr"
+
+# tests are not meant to be run outside of the
+# full SELinux userland repo
+RESTRICT="test"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ [ ! -z "${BUGFIX_PATCH}" ] && epatch "${BUGFIX_PATCH}"
+
+ echo "# Set this to true to save the linked policy." >> "${S}/src/semanage.conf"
+ echo "# This is normally only useful for analysis" >> "${S}/src/semanage.conf"
+ echo "# or debugging of policy." >> "${S}/src/semanage.conf"
+ echo "save-linked=false" >> "${S}/src/semanage.conf"
+ echo >> "${S}/src/semanage.conf"
+ echo "# Set this to 0 to disable assertion checking." >> "${S}/src/semanage.conf"
+ echo "# This should speed up building the kernel policy" >> "${S}/src/semanage.conf"
+ echo "# from policy modules, but may leave you open to" >> "${S}/src/semanage.conf"
+ echo "# dangerous rules which assertion checking" >> "${S}/src/semanage.conf"
+ echo "# would catch." >> "${S}/src/semanage.conf"
+ echo "expand-check=1" >> "${S}/src/semanage.conf"
+
+ # fix up paths for multilib
+ sed -i -e "/^LIBDIR/s/lib/$(get_libdir)/" "${S}/src/Makefile" \
+ || die "Fix for multilib LIBDIR failed."
+ sed -i -e "/^SHLIBDIR/s/lib/$(get_libdir)/" "${S}/src/Makefile" \
+ || die "Fix for multilib SHLIBDIR failed."
+}
+
+src_compile() {
+ python_version
+ emake PYLIBVER="python${PYVER}" all || die
+ emake PYLIBVER="python${PYVER}" pywrap || die
+}
+
+src_install() {
+ python_version
+ make DESTDIR="${D}" PYLIBVER="python${PYVER}" install install-pywrap
+}
+
+pkg_postinst() {
+ python_version
+ python_mod_optimize /usr/$(get_libdir)/python${PYVER}/site-packages
+}
+
+pkg_postrm() {
+ python_version
+ python_mod_cleanup /usr/$(get_libdir)/python${PYVER}/site-packages
+}
diff --git a/sys-libs/libsepol/ChangeLog b/sys-libs/libsepol/ChangeLog
index 4f9eca510ed0..f9ecdd96aec0 100644
--- a/sys-libs/libsepol/ChangeLog
+++ b/sys-libs/libsepol/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/libsepol
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libsepol/ChangeLog,v 1.33 2009/07/22 13:26:16 pebenito Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libsepol/ChangeLog,v 1.34 2009/08/02 01:12:10 pebenito Exp $
+
+*libsepol-2.0.37 (02 Aug 2009)
+
+ 02 Aug 2009; Chris PeBenito <pebenito@gentoo.org> +libsepol-2.0.37.ebuild:
+ New upstream release.
18 Jul 2009; Chris PeBenito <pebenito@gentoo.org>
-files/libsepol-1.12.2.diff, -libsepol-1.16.11.ebuild,
diff --git a/sys-libs/libsepol/libsepol-2.0.37.ebuild b/sys-libs/libsepol/libsepol-2.0.37.ebuild
new file mode 100644
index 000000000000..41145a4fb3b0
--- /dev/null
+++ b/sys-libs/libsepol/libsepol-2.0.37.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libsepol/libsepol-2.0.37.ebuild,v 1.1 2009/08/02 01:12:10 pebenito Exp $
+
+IUSE=""
+
+inherit multilib eutils
+
+#BUGFIX_PATCH="${FILESDIR}/libsepol-2.0.32-expand_rule.diff"
+
+DESCRIPTION="SELinux binary policy representation library"
+HOMEPAGE="http://userspace.selinuxproject.org"
+SRC_URI="http://userspace.selinuxproject.org/releases/current/devel/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="virtual/libc"
+
+# tests are not meant to be run outside of the
+# full SELinux userland repo
+RESTRICT="test"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ [ ! -z "$BUGFIX_PATCH" ] && epatch "${BUGFIX_PATCH}"
+
+ # fix up paths for multilib
+ sed -i -e "/^LIBDIR/s/lib/$(get_libdir)/" src/Makefile \
+ || die "Fix for multilib LIBDIR failed."
+ sed -i -e "/^SHLIBDIR/s/lib/$(get_libdir)/" src/Makefile \
+ || die "Fix for multilib SHLIBDIR failed."
+}
+
+src_compile() {
+ emake || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install
+}