summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ruby/actionmailer/ChangeLog7
-rw-r--r--dev-ruby/actionmailer/actionmailer-3.1.6.ebuild39
-rw-r--r--dev-ruby/actionpack/ChangeLog7
-rw-r--r--dev-ruby/actionpack/actionpack-3.1.6.ebuild66
-rw-r--r--dev-ruby/activemodel/ChangeLog7
-rw-r--r--dev-ruby/activemodel/activemodel-3.1.6.ebuild43
-rw-r--r--dev-ruby/activerecord/ChangeLog7
-rw-r--r--dev-ruby/activerecord/activerecord-3.1.6.ebuild68
-rw-r--r--dev-ruby/activeresource/ChangeLog7
-rw-r--r--dev-ruby/activeresource/activeresource-3.1.6.ebuild41
-rw-r--r--dev-ruby/activesupport/ChangeLog7
-rw-r--r--dev-ruby/activesupport/activesupport-3.1.6.ebuild59
-rw-r--r--dev-ruby/rails/ChangeLog7
-rw-r--r--dev-ruby/rails/rails-3.1.6.ebuild56
-rw-r--r--dev-ruby/railties/ChangeLog7
-rw-r--r--dev-ruby/railties/railties-3.1.6.ebuild54
16 files changed, 474 insertions, 8 deletions
diff --git a/dev-ruby/actionmailer/ChangeLog b/dev-ruby/actionmailer/ChangeLog
index aa2648cebd20..50ba37d0f289 100644
--- a/dev-ruby/actionmailer/ChangeLog
+++ b/dev-ruby/actionmailer/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/actionmailer
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/ChangeLog,v 1.190 2012/06/13 17:42:54 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/ChangeLog,v 1.191 2012/06/17 09:27:29 graaff Exp $
+
+*actionmailer-3.1.6 (17 Jun 2012)
+
+ 17 Jun 2012; Hans de Graaff <graaff@gentoo.org> +actionmailer-3.1.6.ebuild:
+ Version bump for Rails 3.1.6.
*actionmailer-3.0.15 (13 Jun 2012)
diff --git a/dev-ruby/actionmailer/actionmailer-3.1.6.ebuild b/dev-ruby/actionmailer/actionmailer-3.1.6.ebuild
new file mode 100644
index 000000000000..4e7bc8c2078e
--- /dev/null
+++ b/dev-ruby/actionmailer/actionmailer-3.1.6.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/actionmailer-3.1.6.ebuild,v 1.1 2012/06/17 09:27:29 graaff Exp $
+
+EAPI=4
+USE_RUBY="ruby18 ruby19 ree18"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="actionmailer.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Framework for designing email-service layers"
+HOMEPAGE="http://rubyforge.org/projects/actionmailer/"
+SRC_URI="http://github.com/rails/rails/tarball/v${PV} -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="3.1"
+KEYWORDS="~amd64 ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RUBY_S="rails-rails-*/actionmailer"
+
+ruby_add_rdepend "~dev-ruby/actionpack-${PV}
+ >=dev-ruby/mail-2.3.3:2.3"
+ruby_add_bdepend "test? (
+ >=dev-ruby/mocha-0.9.5
+ virtual/ruby-test-unit
+)"
+
+all_ruby_prepare() {
+ # Set test environment to our hand.
+ rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
+ sed -i -e '/\/load_paths/d' test/abstract_unit.rb || die "Unable to remove load paths"
+
+ sed -i -e '/dependency.*mail/s:~>:>=:' "${RUBY_FAKEGEM_GEMSPEC}" || die
+}
diff --git a/dev-ruby/actionpack/ChangeLog b/dev-ruby/actionpack/ChangeLog
index db492929bec8..dbf69a5cd163 100644
--- a/dev-ruby/actionpack/ChangeLog
+++ b/dev-ruby/actionpack/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/actionpack
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionpack/ChangeLog,v 1.208 2012/06/13 17:42:31 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionpack/ChangeLog,v 1.209 2012/06/17 09:27:10 graaff Exp $
+
+*actionpack-3.1.6 (17 Jun 2012)
+
+ 17 Jun 2012; Hans de Graaff <graaff@gentoo.org> +actionpack-3.1.6.ebuild:
+ Version bump for Rails 3.1.6.
*actionpack-3.0.15 (13 Jun 2012)
diff --git a/dev-ruby/actionpack/actionpack-3.1.6.ebuild b/dev-ruby/actionpack/actionpack-3.1.6.ebuild
new file mode 100644
index 000000000000..c508c101dcdf
--- /dev/null
+++ b/dev-ruby/actionpack/actionpack-3.1.6.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionpack/actionpack-3.1.6.ebuild,v 1.1 2012/06/17 09:27:10 graaff Exp $
+
+EAPI=4
+
+USE_RUBY="ruby18 ruby19 ree18"
+
+# The default test task tries to test activerecord with SQLite as well.
+RUBY_FAKEGEM_TASK_TEST="test_action_pack"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="actionpack.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Eases web-request routing, handling, and response."
+HOMEPAGE="http://rubyforge.org/projects/actionpack/"
+SRC_URI="http://github.com/rails/rails/tarball/v${PV} -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="3.1"
+KEYWORDS="~amd64 ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RUBY_S="rails-rails-*/actionpack"
+
+ruby_add_rdepend "
+ ~dev-ruby/activemodel-${PV}
+ ~dev-ruby/activesupport-${PV}
+ >=dev-ruby/rack-cache-1.2
+ >=dev-ruby/builder-3.0.0:3
+ >=dev-ruby/erubis-2.7.0
+ >=dev-ruby/i18n-0.6:0.6
+ >=dev-ruby/rack-1.3.6:1.3
+ >=dev-ruby/rack-mount-0.8.2:0.8
+ >=dev-ruby/rack-test-0.6.1:0.6
+ >=dev-ruby/sprockets-2.0.4:2.0"
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/bundler
+ ~dev-ruby/activerecord-${PV}
+ ~dev-ruby/actionmailer-${PV}
+ >=dev-ruby/tzinfo-0.3.29
+ )"
+
+all_ruby_prepare() {
+ # Remove items from the common Gemfile that we don't need for this
+ # test run. This also requires handling some gemspecs.
+ sed -i -e '/\(uglifier\|system_timer\|sdoc\|w3c_validators\|pg\|jquery-rails\|"mysql"\|ruby-prof\)/d' ../Gemfile || die
+
+ sed -i -e '/rack-ssl/d' ../railties/railties.gemspec || die
+ sed -i -e '/mail/d' ../actionmailer/actionmailer.gemspec || die
+ sed -i -e "s/, '< 1.3'//" ../activesupport/activesupport.gemspec || die
+
+ # Avoid fragile tests depending on hash ordering
+ sed -i -e '/cookie_3=chocolate/ s:^:#:' test/controller/integration_test.rb || die
+ sed -i -e '/test_to_s/,/end/ s:^:#:' test/template/html-scanner/tag_node_test.rb || die
+ sed -i -e '/"name":"david"/ s:^:#:' test/controller/mime_responds_test.rb || die
+ sed -i -e '/test_option_html_attributes_with_multiple_element_hash/, / end/ s:^:#:' test/template/form_options_helper_test.rb || die
+ sed -i -e '/test_option_html_attributes_with_multiple_hashes/, / end/ s:^:#:' test/template/form_options_helper_test.rb || die
+}
diff --git a/dev-ruby/activemodel/ChangeLog b/dev-ruby/activemodel/ChangeLog
index a16aed5c0221..fe982964d754 100644
--- a/dev-ruby/activemodel/ChangeLog
+++ b/dev-ruby/activemodel/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/activemodel
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activemodel/ChangeLog,v 1.30 2012/06/13 17:41:03 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activemodel/ChangeLog,v 1.31 2012/06/17 09:26:27 graaff Exp $
+
+*activemodel-3.1.6 (17 Jun 2012)
+
+ 17 Jun 2012; Hans de Graaff <graaff@gentoo.org> +activemodel-3.1.6.ebuild:
+ Version bump for Rails 3.1.6.
*activemodel-3.0.15 (13 Jun 2012)
diff --git a/dev-ruby/activemodel/activemodel-3.1.6.ebuild b/dev-ruby/activemodel/activemodel-3.1.6.ebuild
new file mode 100644
index 000000000000..941511c37e55
--- /dev/null
+++ b/dev-ruby/activemodel/activemodel-3.1.6.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activemodel/activemodel-3.1.6.ebuild,v 1.1 2012/06/17 09:26:27 graaff Exp $
+
+EAPI=4
+
+USE_RUBY="ruby18 ruby19 ree18"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="activemodel.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A toolkit for building modeling frameworks like Active Record and Active Resource."
+HOMEPAGE="http://github.com/rails/rails"
+SRC_URI="http://github.com/rails/rails/tarball/v${PV} -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="3.1"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RUBY_S="rails-rails-*/activemodel"
+
+ruby_add_rdepend "
+ ~dev-ruby/activesupport-${PV}
+ >=dev-ruby/builder-3.0.0
+ >=dev-ruby/i18n-0.6.0:0.6
+ >=dev-ruby/bcrypt-ruby-3.0.0"
+
+ruby_add_bdepend "
+ test? (
+ >=dev-ruby/mocha-0.9.5
+ )"
+
+all_ruby_prepare() {
+ # Set test environment to our hand.
+ rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
+ sed -i -e '/load_paths/d' test/cases/helper.rb || die "Unable to remove load paths"
+}
diff --git a/dev-ruby/activerecord/ChangeLog b/dev-ruby/activerecord/ChangeLog
index ce0307517299..c88bd6bfa28e 100644
--- a/dev-ruby/activerecord/ChangeLog
+++ b/dev-ruby/activerecord/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/activerecord
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/ChangeLog,v 1.187 2012/06/13 17:43:17 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/ChangeLog,v 1.188 2012/06/17 09:27:53 graaff Exp $
+
+*activerecord-3.1.6 (17 Jun 2012)
+
+ 17 Jun 2012; Hans de Graaff <graaff@gentoo.org> +activerecord-3.1.6.ebuild:
+ Version bump for Rails 3.1.6.
*activerecord-3.0.15 (13 Jun 2012)
diff --git a/dev-ruby/activerecord/activerecord-3.1.6.ebuild b/dev-ruby/activerecord/activerecord-3.1.6.ebuild
new file mode 100644
index 000000000000..d3f5496eded2
--- /dev/null
+++ b/dev-ruby/activerecord/activerecord-3.1.6.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/activerecord-3.1.6.ebuild,v 1.1 2012/06/17 09:27:53 graaff Exp $
+
+EAPI=4
+USE_RUBY="ruby18 ruby19 ree18"
+
+# this is not null so that the dependencies will actually be filled
+RUBY_FAKEGEM_TASK_TEST="test"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="activerecord.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Implements the ActiveRecord pattern (Fowler, PoEAA) for ORM"
+HOMEPAGE="http://rubyforge.org/projects/activerecord/"
+SRC_URI="http://github.com/rails/rails/tarball/v${PV} -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="3.1"
+KEYWORDS="~amd64 ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="mysql postgres sqlite3"
+
+RUBY_S="rails-rails-*/activerecord"
+
+ruby_add_rdepend "~dev-ruby/activesupport-${PV}
+ ~dev-ruby/activemodel-${PV}
+ >=dev-ruby/arel-2.2.3:2.1
+ >=dev-ruby/tzinfo-0.3.29
+ sqlite3? ( >=dev-ruby/sqlite3-ruby-1.3.4 )
+ mysql? ( >=dev-ruby/mysql2-0.3.6:0.3 )
+ postgres? ( >=dev-ruby/pg-0.11.0 )"
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/bundler
+ ~dev-ruby/actionpack-${PV}
+ >=dev-ruby/sqlite3-ruby-1.3.3
+ >=dev-ruby/mocha-0.9.5
+ virtual/ruby-test-unit
+ )"
+
+all_ruby_prepare() {
+ # Remove items from the common Gemfile that we don't need for this
+ # test run. This also requires handling some gemspecs.
+ sed -i -e '/\(uglifier\|system_timer\|sdoc\|w3c_validators\|pg\|jquery-rails\|"mysql"\|ruby-prof\)/d' ../Gemfile || die
+ sed -i -e '/rack-ssl/d' ../railties/railties.gemspec || die
+ sed -i -e '/mail/d' ../actionmailer/actionmailer.gemspec || die
+ sed -i -e "s/, '< 1.3'//" ../activesupport/activesupport.gemspec || die
+
+ # Avoid tests depending on hash ordering
+ sed -i -e '/test_should_automatically_build_new_associated/,/ end/ s:^:#:' test/cases/nested_attributes_test.rb || die
+}
+
+each_ruby_test() {
+ case ${RUBY} in
+ *jruby)
+ ;;
+ *)
+ if use sqlite3; then
+ ${RUBY} -S rake test_sqlite3 || die "sqlite3 tests failed"
+ fi
+ ;;
+ esac
+}
diff --git a/dev-ruby/activeresource/ChangeLog b/dev-ruby/activeresource/ChangeLog
index 84ff8cb92a09..6b6d524a80b5 100644
--- a/dev-ruby/activeresource/ChangeLog
+++ b/dev-ruby/activeresource/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/activeresource
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activeresource/ChangeLog,v 1.112 2012/06/13 17:41:26 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activeresource/ChangeLog,v 1.113 2012/06/17 09:26:49 graaff Exp $
+
+*activeresource-3.1.6 (17 Jun 2012)
+
+ 17 Jun 2012; Hans de Graaff <graaff@gentoo.org> +activeresource-3.1.6.ebuild:
+ Version bump for Rails 3.1.6.
*activeresource-3.0.15 (13 Jun 2012)
diff --git a/dev-ruby/activeresource/activeresource-3.1.6.ebuild b/dev-ruby/activeresource/activeresource-3.1.6.ebuild
new file mode 100644
index 000000000000..3fd0900f98a0
--- /dev/null
+++ b/dev-ruby/activeresource/activeresource-3.1.6.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activeresource/activeresource-3.1.6.ebuild,v 1.1 2012/06/17 09:26:49 graaff Exp $
+
+EAPI=4
+
+USE_RUBY="ruby18 ruby19 ree18"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="activeresource.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Think Active Record for web resources.."
+HOMEPAGE="http://rubyforge.org/projects/activeresource/"
+SRC_URI="http://github.com/rails/rails/tarball/v${PV} -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="3.1"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RUBY_S="rails-rails-*/activeresource"
+
+ruby_add_rdepend "~dev-ruby/activesupport-${PV}
+ ~dev-ruby/activemodel-${PV}"
+ruby_add_bdepend "
+ test? (
+ >=dev-ruby/mocha-0.9.5
+ virtual/ruby-test-unit
+ )"
+
+all_ruby_prepare() {
+ # Set test environment to our hand.
+ rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
+ sed -i -e '/load_paths/d' test/abstract_unit.rb || die "Unable to remove load paths"
+
+}
diff --git a/dev-ruby/activesupport/ChangeLog b/dev-ruby/activesupport/ChangeLog
index 0bd874d7d72f..4443f5c819df 100644
--- a/dev-ruby/activesupport/ChangeLog
+++ b/dev-ruby/activesupport/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/activesupport
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/ChangeLog,v 1.173 2012/06/13 17:40:36 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/ChangeLog,v 1.174 2012/06/17 09:25:37 graaff Exp $
+
+*activesupport-3.1.6 (17 Jun 2012)
+
+ 17 Jun 2012; Hans de Graaff <graaff@gentoo.org> +activesupport-3.1.6.ebuild:
+ Version bump for Rails 3.1.6.
*activesupport-3.0.15 (13 Jun 2012)
diff --git a/dev-ruby/activesupport/activesupport-3.1.6.ebuild b/dev-ruby/activesupport/activesupport-3.1.6.ebuild
new file mode 100644
index 000000000000..c2aab88a73db
--- /dev/null
+++ b/dev-ruby/activesupport/activesupport-3.1.6.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/activesupport-3.1.6.ebuild,v 1.1 2012/06/17 09:25:37 graaff Exp $
+
+EAPI=4
+
+# jruby fails tests.
+USE_RUBY="ruby18 ree18 ruby19"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="activesupport.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Utility Classes and Extension to the Standard Library"
+HOMEPAGE="http://rubyforge.org/projects/activesupport/"
+SRC_URI="https://github.com/rails/rails/tarball/v${PV} -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="3.1"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RUBY_S="rails-rails-*/${PN}"
+
+ruby_add_rdepend ">=dev-ruby/memcache-client-1.5.8
+ >=dev-ruby/multi_json-1.0
+ dev-ruby/i18n:0.6
+ !!<dev-ruby/activesupport-3.0.11-r1:3.0"
+
+# libxml-ruby, nokogiri, and builder are not strictly needed, but there
+# are tests using this code.
+ruby_add_bdepend "test? (
+ virtual/ruby-test-unit
+ >=dev-ruby/libxml-2.0.0
+ dev-ruby/nokogiri
+ dev-ruby/builder:0
+ )"
+
+all_ruby_prepare() {
+ # don't support older mocha versions as the optional codepath
+ # breaks JRuby
+ epatch "${FILESDIR}"/${PN}-3.0.3-mocha-0.9.5.patch
+
+ # Set test environment to our hand.
+# rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
+ sed -i -e '/load_paths/d' test/abstract_unit.rb || die "Unable to remove load paths"
+
+ # Remove upper restriction from gemspec. All tests pass with
+ # multi_json 1.3.5. The upstream commit doesn't give details but
+ # most likely this was added to avoid multi_json 1.3.0 which broke
+ # compatibility. This was later fixed in 1.3.1. 1.3.0 is no longer
+ # in portage so from a Gentoo point of view it is safe to depend on
+ # => 1.0.
+ sed -i -e "s/, '< 1.3'//" activesupport.gemspec || die
+}
diff --git a/dev-ruby/rails/ChangeLog b/dev-ruby/rails/ChangeLog
index 6ba1c53176f2..d420fe7b0e88 100644
--- a/dev-ruby/rails/ChangeLog
+++ b/dev-ruby/rails/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/rails
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rails/ChangeLog,v 1.223 2012/06/13 17:44:02 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rails/ChangeLog,v 1.224 2012/06/17 09:28:37 graaff Exp $
+
+*rails-3.1.6 (17 Jun 2012)
+
+ 17 Jun 2012; Hans de Graaff <graaff@gentoo.org> +rails-3.1.6.ebuild:
+ Version bump for Rails 3.1.6.
*rails-3.0.15 (13 Jun 2012)
diff --git a/dev-ruby/rails/rails-3.1.6.ebuild b/dev-ruby/rails/rails-3.1.6.ebuild
new file mode 100644
index 000000000000..5075c8c64f40
--- /dev/null
+++ b/dev-ruby/rails/rails-3.1.6.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rails/rails-3.1.6.ebuild,v 1.1 2012/06/17 09:28:37 graaff Exp $
+
+EAPI=4
+USE_RUBY="ruby18 ruby19 ree18"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_TASK_TEST=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="ruby on rails is a web-application and persistance framework"
+HOMEPAGE="http://www.rubyonrails.org"
+
+LICENSE="MIT"
+SLOT="3.1"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+IUSE="+asset-pipeline"
+
+RDEPEND=">=app-admin/eselect-rails-0.18"
+
+ruby_add_rdepend "
+ ~dev-ruby/actionmailer-${PV}
+ ~dev-ruby/actionpack-${PV}
+ ~dev-ruby/activerecord-${PV}
+ ~dev-ruby/activeresource-${PV}
+ ~dev-ruby/activesupport-${PV}
+ =dev-ruby/bundler-1*
+ ~dev-ruby/railties-${PV}
+ asset-pipeline? (
+ dev-ruby/jquery-rails:0
+ dev-ruby/sass-rails
+ dev-ruby/uglifier
+ dev-ruby/coffee-rails
+ )"
+
+all_ruby_install() {
+ all_fakegem_install
+
+ ruby_fakegem_binwrapper rails rails-${PV}
+}
+
+pkg_postinst() {
+ elog "To select between slots of rails, use:"
+ elog "\teselect rails"
+
+ eselect rails update
+}
+
+pkg_postrm() {
+ eselect rails update
+}
diff --git a/dev-ruby/railties/ChangeLog b/dev-ruby/railties/ChangeLog
index 52112ffe47cb..19c16c82b925 100644
--- a/dev-ruby/railties/ChangeLog
+++ b/dev-ruby/railties/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/railties
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/railties/ChangeLog,v 1.27 2012/06/13 17:43:37 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/railties/ChangeLog,v 1.28 2012/06/17 09:28:13 graaff Exp $
+
+*railties-3.1.6 (17 Jun 2012)
+
+ 17 Jun 2012; Hans de Graaff <graaff@gentoo.org> +railties-3.1.6.ebuild:
+ Version bump for Rails 3.1.6.
*railties-3.0.15 (13 Jun 2012)
diff --git a/dev-ruby/railties/railties-3.1.6.ebuild b/dev-ruby/railties/railties-3.1.6.ebuild
new file mode 100644
index 000000000000..765268e171ed
--- /dev/null
+++ b/dev-ruby/railties/railties-3.1.6.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/railties/railties-3.1.6.ebuild,v 1.1 2012/06/17 09:28:13 graaff Exp $
+
+EAPI=4
+USE_RUBY="ruby18 ruby19 ree18"
+
+RUBY_FAKEGEM_TASK_TEST="test:regular"
+RUBY_FAKEGEM_TASK_DOC="generate_guides"
+RUBY_FAKEGEM_DOCDIR="guides/output"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="railties.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Tools for creating, working with, and running Rails applications."
+HOMEPAGE="http://github.com/rails/rails"
+SRC_URI="http://github.com/rails/rails/tarball/v${PV} -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="3.1"
+KEYWORDS="~amd64 ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RUBY_S="rails-rails-*/railties"
+
+# The test suite has many failures, most likely due to a mismatch in
+# exact dependencies or environment specifics. Needs further
+# investigation.
+RESTRICT="test"
+
+ruby_add_rdepend "
+ ~dev-ruby/activesupport-${PV}
+ ~dev-ruby/actionpack-${PV}
+ >=dev-ruby/rdoc-3.4
+ >=dev-ruby/thor-0.14.6
+ >=dev-ruby/rack-ssl-1.3.2:1.3
+ >=dev-ruby/rake-0.8.7"
+
+ruby_add_bdepend "
+ test? (
+ >=dev-ruby/mocha-0.9.5
+ virtual/ruby-test-unit
+ )
+ doc? (
+ >=dev-ruby/redcloth-4.1.1
+ )"
+
+all_ruby_prepare() {
+ # Remove items from the common Gemfile that we don't need for this
+ # test run. This also requires handling some gemspecs.
+ sed -i -e '/\(uglifier\|system_timer\|sdoc\|w3c_validators\|pg\)/d' ../Gemfile || die
+}