summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-misc/oroborus-keylaunch/ChangeLog10
-rw-r--r--x11-misc/oroborus-keylaunch/metadata.xml10
-rw-r--r--x11-misc/oroborus-keylaunch/oroborus-keylaunch-1.3.9.ebuild32
3 files changed, 52 insertions, 0 deletions
diff --git a/x11-misc/oroborus-keylaunch/ChangeLog b/x11-misc/oroborus-keylaunch/ChangeLog
new file mode 100644
index 000000000000..d4fbda8e5e2d
--- /dev/null
+++ b/x11-misc/oroborus-keylaunch/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for x11-misc/oroborus-keylaunch
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/oroborus-keylaunch/ChangeLog,v 1.1 2010/05/31 15:52:47 xarthisius Exp $
+
+*oroborus-keylaunch-1.3.9 (31 May 2010)
+
+ 31 May 2010; Kacper Kowalik <xarthisius@gentoo.org>
+ +oroborus-keylaunch-1.3.9.ebuild, +metadata.xml:
+ New ebuild for oroborus-keylaunch, formerly part of x11-wm/oroborus-extras
+
diff --git a/x11-misc/oroborus-keylaunch/metadata.xml b/x11-misc/oroborus-keylaunch/metadata.xml
new file mode 100644
index 000000000000..4950b1838794
--- /dev/null
+++ b/x11-misc/oroborus-keylaunch/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>desktop-wm</herd>
+ <longdescription>
+ KeyLaunch is a small utility for binding commands to a hot key. It reads a configuration
+ file in ~/.keylaunchrc. KeyLaunch uses Ctrl, Alt and Shift as modifier keys,
+ the hotkey is up to the user.
+ </longdescription>
+</pkgmetadata>
diff --git a/x11-misc/oroborus-keylaunch/oroborus-keylaunch-1.3.9.ebuild b/x11-misc/oroborus-keylaunch/oroborus-keylaunch-1.3.9.ebuild
new file mode 100644
index 000000000000..d8b58723a079
--- /dev/null
+++ b/x11-misc/oroborus-keylaunch/oroborus-keylaunch-1.3.9.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/oroborus-keylaunch/oroborus-keylaunch-1.3.9.ebuild,v 1.1 2010/05/31 15:52:47 xarthisius Exp $
+
+EAPI=2
+
+MY_PN=${PN/oroborus-//}
+
+DESCRIPTION="utility for binding keys in Oroborus"
+HOMEPAGE="http://www.oroborus.org"
+SRC_URI="http://ftp.debian.org/debian/pool/main/k/${MY_PN}/${MY_PN}_${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="x11-libs/libX11
+ !x11-wm/oroborus-extras"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_PN}-${PV}
+
+src_prepare() {
+ sed -i -e "s: -g -O2 -Wall::" \
+ -e "/^install:/s/install-docs//" Makefile.in || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc README docs/example_rc debian/changelog || die
+}