summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrad Teaford Cowan <bcowan@gentoo.org>2003-12-24 06:11:52 +0000
committerBrad Teaford Cowan <bcowan@gentoo.org>2003-12-24 06:11:52 +0000
commitdc929619eab47b125b9c5e0dc080766332d94579 (patch)
treeb088a425dbb244c9f6e2524d2e9ffb42649f00f5 /xfce-base/libxfcegui4/libxfcegui4-4.0.2.ebuild
parentbump version (diff)
downloadhistorical-dc929619eab47b125b9c5e0dc080766332d94579.tar.gz
historical-dc929619eab47b125b9c5e0dc080766332d94579.tar.bz2
historical-dc929619eab47b125b9c5e0dc080766332d94579.zip
bugfix release of xfce4.
Diffstat (limited to 'xfce-base/libxfcegui4/libxfcegui4-4.0.2.ebuild')
-rw-r--r--xfce-base/libxfcegui4/libxfcegui4-4.0.2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/xfce-base/libxfcegui4/libxfcegui4-4.0.2.ebuild b/xfce-base/libxfcegui4/libxfcegui4-4.0.2.ebuild
new file mode 100644
index 000000000000..7381e4916ab5
--- /dev/null
+++ b/xfce-base/libxfcegui4/libxfcegui4-4.0.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/libxfcegui4/libxfcegui4-4.0.2.ebuild,v 1.1 2003/12/24 05:57:50 bcowan Exp $
+
+IUSE="xinerama X"
+S=${WORKDIR}/${P}
+
+DESCRIPTION="Libraries for XFCE4"
+HOMEPAGE="http://www.xfce.org/"
+SRC_URI="http://www.xfce.org/archive/xfce-${PV}/src/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~ia64 ~x86 ~ppc ~alpha ~sparc ~amd64 ~hppa"
+
+DEPEND=">=x11-libs/gtk+-2.0.6
+ dev-util/pkgconfig
+ dev-libs/libxml2
+ =xfce-base/libxfce4util-${PV}"
+
+src_compile() {
+ local myconf
+ myconf=""
+
+ use xinerama && myconf="${myconf} --enable-xinerama"
+ use X && myconf="${myconf} --with-x"
+
+ econf ${myconf} || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS INSTALL COPYING README ChangeLog
+}