summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof Pawlik <nelchael@gentoo.org>2006-06-11 12:09:07 +0000
committerKrzysztof Pawlik <nelchael@gentoo.org>2006-06-11 12:09:07 +0000
commit44e660798434075a25feb20db0f92d3f144d307d (patch)
treea24de9cddf09e660b94fbda29bddb6848213bd75 /x11-wm/vtwm/vtwm-5.4.6a.ebuild
parentThis package is a set of tools that are useful in receiving, analyzing, or pr... (diff)
downloadhistorical-44e660798434075a25feb20db0f92d3f144d307d.tar.gz
historical-44e660798434075a25feb20db0f92d3f144d307d.tar.bz2
historical-44e660798434075a25feb20db0f92d3f144d307d.zip
Migrated to modular X.
Package-Manager: portage-2.1
Diffstat (limited to 'x11-wm/vtwm/vtwm-5.4.6a.ebuild')
-rw-r--r--x11-wm/vtwm/vtwm-5.4.6a.ebuild26
1 files changed, 20 insertions, 6 deletions
diff --git a/x11-wm/vtwm/vtwm-5.4.6a.ebuild b/x11-wm/vtwm/vtwm-5.4.6a.ebuild
index 246b6a2736e9..2829e6e4c24f 100644
--- a/x11-wm/vtwm/vtwm-5.4.6a.ebuild
+++ b/x11-wm/vtwm/vtwm-5.4.6a.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/vtwm/vtwm-5.4.6a.ebuild,v 1.9 2004/08/30 19:19:31 pvdabeel Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/vtwm/vtwm-5.4.6a.ebuild,v 1.10 2006/06/11 12:09:07 nelchael Exp $
IUSE=""
@@ -10,11 +10,25 @@ SRC_URI="ftp://ftp.visi.com/users/hawkeyd/X/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="x86 alpha ppc sparc"
-DEPEND="virtual/x11"
+
+RDEPEND="|| ( (
+ x11-libs/libX11
+ x11-libs/libXmu
+ x11-libs/libXt
+ x11-libs/libXext
+ x11-libs/libXpm )
+ virtual/x11 )"
+DEPEND="${RDEPEND}
+ || ( (
+ x11-misc/imake
+ app-text/rman
+ x11-proto/xproto
+ x11-proto/xextproto )
+ virtual/x11 )"
src_compile() {
- xmkmf || die
- make || die
+ xmkmf || die "xmkmf failed"
+ emake || die "emake failed"
}
src_install() {
@@ -22,7 +36,7 @@ src_install() {
make BINDIR=/usr/bin \
LIBDIR=/etc/X11 \
MANPATH=/usr/share/man \
- DESTDIR=${D} install || die
+ DESTDIR=${D} install || die "make install failed"
echo "#!/bin/sh" > vtwm
echo "xsetroot -cursor_name left_ptr &" >> vtwm