summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2009-09-23 16:33:23 +0000
committerJeroen Roovers <jer@gentoo.org>2009-09-23 16:33:23 +0000
commit48cc3fbe7e66f6175ee9a4eafccfa63ca5a7342e (patch)
tree1c52a5ddd7b2e1ccabbc011ea347ac9b0d463ccd /x11-wm/ratpoison/ratpoison-1.4.5.ebuild
parentRemove virtual/libc (diff)
downloadhistorical-48cc3fbe7e66f6175ee9a4eafccfa63ca5a7342e.tar.gz
historical-48cc3fbe7e66f6175ee9a4eafccfa63ca5a7342e.tar.bz2
historical-48cc3fbe7e66f6175ee9a4eafccfa63ca5a7342e.zip
Version bump. Remove old.
Package-Manager: portage-2.2_rc41/cvs/Linux i686
Diffstat (limited to 'x11-wm/ratpoison/ratpoison-1.4.5.ebuild')
-rw-r--r--x11-wm/ratpoison/ratpoison-1.4.5.ebuild76
1 files changed, 76 insertions, 0 deletions
diff --git a/x11-wm/ratpoison/ratpoison-1.4.5.ebuild b/x11-wm/ratpoison/ratpoison-1.4.5.ebuild
new file mode 100644
index 000000000000..5a8214798ce1
--- /dev/null
+++ b/x11-wm/ratpoison/ratpoison-1.4.5.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/ratpoison/ratpoison-1.4.5.ebuild,v 1.1 2009/09/23 16:33:23 jer Exp $
+
+EAPI=2
+
+inherit elisp-common eutils autotools
+
+DESCRIPTION="Ratpoison is an extremely light-weight and barebones wm modelled after screen"
+HOMEPAGE="http://www.nongnu.org/ratpoison/"
+SRC_URI="http://savannah.nongnu.org/download/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE="debug emacs +history +xft"
+
+DEPEND="x11-libs/libXinerama
+ x11-libs/libXtst
+ virtual/perl-PodParser
+ emacs? ( virtual/emacs )
+ history? ( sys-libs/readline )
+ xft? ( x11-libs/libXft )"
+RDEPEND="${DEPEND}"
+
+SITEFILE=50ratpoison-gentoo.el
+
+src_prepare() {
+ cd "${S}/contrib"
+ epatch "${FILESDIR}/ratpoison.el-gentoo.patch"
+
+ cd "${S}"
+ epatch "${FILESDIR}/${PN}-1.4.4-glibc210.patch"
+
+ eautoreconf
+}
+
+src_configure() {
+ local myconf
+ use history || myconf="--disable-history"
+ econf ${myconf} $(use_with xft) $(use_enable debug) || die "econf failed"
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS}" || die "emake failed"
+ if use emacs; then
+ elisp-compile contrib/ratpoison.el || die "elisp-compile failed"
+ fi
+}
+
+src_install() {
+ einstall || die
+
+ exeinto /etc/X11/Sessions
+ newexe "${FILESDIR}/ratpoison.xsession" ratpoison
+
+ dodoc INSTALL TODO README NEWS AUTHORS ChangeLog
+ docinto example
+ dodoc contrib/{genrpbindings,split.sh} \
+ doc/{ipaq.ratpoisonrc,sample.ratpoisonrc}
+
+ rm -rf "${D}/usr/share/"{doc/ratpoison,ratpoison}
+
+ if use emacs; then
+ elisp-install ${PN} contrib/ratpoison.*
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}