summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2012-08-25 09:41:35 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2012-08-25 09:41:35 +0000
commit9adcee24338e4e2a7bc4109f53f20ad0db7c2818 (patch)
treeafd5be559316499bed767899baac2583f6d05612 /x11-wm/openbox/openbox-9999.ebuild
parentStable arm, bug #421479 (diff)
downloadhistorical-9adcee24338e4e2a7bc4109f53f20ad0db7c2818.tar.gz
historical-9adcee24338e4e2a7bc4109f53f20ad0db7c2818.tar.bz2
historical-9adcee24338e4e2a7bc4109f53f20ad0db7c2818.zip
Add new Gentoo openbox theme thanks to David Abbott <dabbott@gentoo.org>
Package-Manager: portage-2.1.11.11/cvs/Linux x86_64
Diffstat (limited to 'x11-wm/openbox/openbox-9999.ebuild')
-rw-r--r--x11-wm/openbox/openbox-9999.ebuild15
1 files changed, 13 insertions, 2 deletions
diff --git a/x11-wm/openbox/openbox-9999.ebuild b/x11-wm/openbox/openbox-9999.ebuild
index e9a8d5ccf13e..e81894a2af6e 100644
--- a/x11-wm/openbox/openbox-9999.ebuild
+++ b/x11-wm/openbox/openbox-9999.ebuild
@@ -1,18 +1,20 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/openbox/openbox-9999.ebuild,v 1.17 2012/06/04 19:00:52 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/openbox/openbox-9999.ebuild,v 1.18 2012/08/25 09:41:35 hwoarang Exp $
EAPI="2"
inherit multilib autotools eutils git-2
DESCRIPTION="A standards compliant, fast, light-weight, extensible window manager"
HOMEPAGE="http://openbox.org/"
+SRC_URI="branding? (
+http://dev.gentoo.org/~hwoarang/distfiles/surreal-gentoo.tar.gz )"
EGIT_REPO_URI="git://git.openbox.org/dana/openbox"
LICENSE="GPL-2"
SLOT="3"
KEYWORDS=""
-IUSE="debug imlib nls python session startup-notification static-libs"
+IUSE="branding debug imlib nls python session startup-notification static-libs"
RDEPEND="dev-libs/glib:2
>=dev-libs/libxml2-2.0
@@ -60,6 +62,15 @@ src_install() {
echo "/usr/bin/openbox-session" > "${D}/etc/X11/Sessions/${PN}"
fperms a+x /etc/X11/Sessions/${PN}
emake DESTDIR="${D}" install || die "emake install failed"
+ if use branding; then
+ insinto /usr/share/themes
+ doins -r "${WORKDIR}"/Surreal_Gentoo
+ # make it the default theme
+ sed -i \
+ "/<theme>/{n; s@<name>.*</name>@<name>Surreal_Gentoo</name>@}" \
+ "${D}"/etc/xdg/openbox/rc.xml \
+ || die "failed to set Surreal Gentoo as the default theme"
+ fi
! use static-libs && rm "${D}"/usr/$(get_libdir)/lib{obt,obrender}.la
! use python && rm "${D}"/usr/libexec/openbox-xdg-autostart
}