summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-05-15 22:21:40 +0000
committerAchim Gottinger <achim@gentoo.org>2001-05-15 22:21:40 +0000
commita7ed3e814fd1e5fe561a6547819acafe81902fe4 (patch)
tree9daad24c91094cfb3d8506d4dafcb494bf467fa4 /x11-wm/fvwm
parentFixed install bug (diff)
downloadhistorical-a7ed3e814fd1e5fe561a6547819acafe81902fe4.tar.gz
historical-a7ed3e814fd1e5fe561a6547819acafe81902fe4.tar.bz2
historical-a7ed3e814fd1e5fe561a6547819acafe81902fe4.zip
FHS2.1 fix
Diffstat (limited to 'x11-wm/fvwm')
-rw-r--r--x11-wm/fvwm/fvwm-2.3.28.ebuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/x11-wm/fvwm/fvwm-2.3.28.ebuild b/x11-wm/fvwm/fvwm-2.3.28.ebuild
index 89fb7e2bddaa..05269f2bb495 100644
--- a/x11-wm/fvwm/fvwm-2.3.28.ebuild
+++ b/x11-wm/fvwm/fvwm-2.3.28.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Peter Gavin <pete@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/fvwm/fvwm-2.3.28.ebuild,v 1.2 2001/05/07 15:45:41 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/fvwm/fvwm-2.3.28.ebuild,v 1.3 2001/05/15 22:21:40 achim Exp $
#P=
A=${P}.tar.bz2
@@ -17,12 +17,15 @@ DEPEND=">=x11-base/xfree-4.0
gnome? ( >=gnome-base/gnome-libs-1.2.8 )"
src_compile() {
+ local myconf
if [ -n "$( use gnome )" ]
then
- try ./configure --prefix=/usr/X11R6 --host=${CHOST} --with-gnome
+ myconf="--with-gnome"
else
- try ./configure --prefix=/usr/X11R6 --host=${CHOST} --without-gnome
+ myconf="--without-gnome"
fi
+ try ./configure --prefix=/usr/X11R6 --libexecdir=/usr/X11R6/lib \
+ --host=${CHOST} ${myconf}
try make
}