summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2006-02-13 21:14:38 +0000
committerMichael Januszewski <spock@gentoo.org>2006-02-13 21:14:38 +0000
commit6f4fa235e6530e05b38ef66a183257f3faced3c4 (patch)
tree45c66a37d61ebd47da1c726e631d7bb5cac4cbce /x11-wm/afterstep/afterstep-2.2.0.ebuild
parentAdded the latest version for bug #122639. (diff)
downloadhistorical-6f4fa235e6530e05b38ef66a183257f3faced3c4.tar.gz
historical-6f4fa235e6530e05b38ef66a183257f3faced3c4.tar.bz2
historical-6f4fa235e6530e05b38ef66a183257f3faced3c4.zip
Ported AfterStep to modular X.
Package-Manager: portage-2.1_pre4-r1
Diffstat (limited to 'x11-wm/afterstep/afterstep-2.2.0.ebuild')
-rw-r--r--x11-wm/afterstep/afterstep-2.2.0.ebuild27
1 files changed, 23 insertions, 4 deletions
diff --git a/x11-wm/afterstep/afterstep-2.2.0.ebuild b/x11-wm/afterstep/afterstep-2.2.0.ebuild
index 3a2510f18e59..a55248e2d00d 100644
--- a/x11-wm/afterstep/afterstep-2.2.0.ebuild
+++ b/x11-wm/afterstep/afterstep-2.2.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/afterstep/afterstep-2.2.0.ebuild,v 1.2 2006/02/09 11:52:30 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/afterstep/afterstep-2.2.0.ebuild,v 1.3 2006/02/13 21:14:38 spock Exp $
inherit flag-o-matic
@@ -13,14 +13,33 @@ SLOT="0"
KEYWORDS="~amd64 hppa ~mips ~ppc ~ppc64 ~sparc ~x86"
IUSE="debug gif jpeg mmx nls png tiff xinerama"
-DEPEND="virtual/libc
- virtual/x11
+RDEPEND="virtual/libc
media-libs/freetype
debug? ( !hppa? ( !ppc? ( dev-util/efence ) ) )
png? ( >=media-libs/libpng-1.2.5 )
jpeg? ( >=media-libs/jpeg-6b )
gif? ( >=media-libs/giflib-4.1.0 )
- tiff? ( >=media-libs/tiff-3.5.7 )"
+ tiff? ( >=media-libs/tiff-3.5.7 )
+ || ( ( x11-libs/libICE
+ x11-libs/libXext
+ x11-libs/libSM
+ x11-libs/libXmu
+ x11-libs/libXt
+ x11-libs/libX11
+ x11-libs/libXpm
+ x11-libs/libXrender
+ xinerama? ( x11-libs/libXinerama )
+ )
+ virtual/x11
+ )"
+
+DEPEND="${RDEPEND}
+ || ( ( x11-proto/xextproto
+ x11-proto/xproto
+ xinerama? ( x11-proto/xineramaproto )
+ )
+ virtual/x11
+ )"
S="${WORKDIR}/AfterStep-${PV}"