summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJim Ramsay <lack@gentoo.org>2007-03-12 14:30:06 +0000
committerJim Ramsay <lack@gentoo.org>2007-03-12 14:30:06 +0000
commit0a284bfbf6b907396ff67a6a80fb189efdeb36ea (patch)
treec6daa85f5925f70de000e289523e5cca7b4f1fed /x11-plugins
parentnew upstream release. (diff)
downloadhistorical-0a284bfbf6b907396ff67a6a80fb189efdeb36ea.tar.gz
historical-0a284bfbf6b907396ff67a6a80fb189efdeb36ea.tar.bz2
historical-0a284bfbf6b907396ff67a6a80fb189efdeb36ea.zip
Updated to use new gkrellm-plugin eclass
Package-Manager: portage-2.1.2-r10
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/gkrellm-radio/ChangeLog6
-rw-r--r--x11-plugins/gkrellm-radio/gkrellm-radio-2.0.3-r1.ebuild17
-rw-r--r--x11-plugins/gkrellm-radio/gkrellm-radio-2.0.4.ebuild17
-rw-r--r--x11-plugins/gkrellm-reminder/ChangeLog5
-rw-r--r--x11-plugins/gkrellm-reminder/gkrellm-reminder-2.0.0.ebuild15
5 files changed, 26 insertions, 34 deletions
diff --git a/x11-plugins/gkrellm-radio/ChangeLog b/x11-plugins/gkrellm-radio/ChangeLog
index 77de08018710..72cf972a46a4 100644
--- a/x11-plugins/gkrellm-radio/ChangeLog
+++ b/x11-plugins/gkrellm-radio/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-plugins/gkrellm-radio
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrellm-radio/ChangeLog,v 1.16 2007/02/21 21:32:31 lack Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrellm-radio/ChangeLog,v 1.17 2007/03/12 14:26:24 lack Exp $
+
+ 12 Mar 2007; Jim Ramsay <lack@gentoo.org> gkrellm-radio-2.0.3-r1.ebuild,
+ gkrellm-radio-2.0.4.ebuild:
+ Updated to use new gkrellm-plugin eclass
21 Feb 2007; Jim Ramsay <lack@gentoo.org> metadata.xml,
-gkrellm-radio-0.3.3.ebuild:
diff --git a/x11-plugins/gkrellm-radio/gkrellm-radio-2.0.3-r1.ebuild b/x11-plugins/gkrellm-radio/gkrellm-radio-2.0.3-r1.ebuild
index 3c236a3d2e3a..962ed49ca843 100644
--- a/x11-plugins/gkrellm-radio/gkrellm-radio-2.0.3-r1.ebuild
+++ b/x11-plugins/gkrellm-radio/gkrellm-radio-2.0.3-r1.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrellm-radio/gkrellm-radio-2.0.3-r1.ebuild,v 1.7 2004/06/24 22:57:09 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrellm-radio/gkrellm-radio-2.0.3-r1.ebuild,v 1.8 2007/03/12 14:26:24 lack Exp $
+
+inherit gkrellm-plugin
IUSE="lirc"
@@ -9,21 +11,16 @@ DESCRIPTION="A minimalistic GKrellM2 plugin to control radio tuners."
SRC_URI="http://gkrellm.luon.net/files/${P}.tar.gz"
HOMEPAGE="http://gkrellm.luon.net/gkrellm-radio.phtml"
-DEPEND="=app-admin/gkrellm-2*
- >=media-libs/imlib-1.9.14-r1
- lirc? ( app-misc/lirc )"
+DEPEND="lirc? ( app-misc/lirc )"
SLOT="2"
LICENSE="GPL-2"
KEYWORDS="x86 ppc sparc"
+PLUGIN_SO=radio.so
+
src_compile() {
use lirc && myconf="${myconf} WITH_LIRC=1"
emake ${myconf} || die
}
-src_install () {
- exeinto /usr/lib/gkrellm2/plugins
- doexe radio.so
- dodoc README CHANGES
-}
diff --git a/x11-plugins/gkrellm-radio/gkrellm-radio-2.0.4.ebuild b/x11-plugins/gkrellm-radio/gkrellm-radio-2.0.4.ebuild
index eb3c186f0c24..f926f0921a90 100644
--- a/x11-plugins/gkrellm-radio/gkrellm-radio-2.0.4.ebuild
+++ b/x11-plugins/gkrellm-radio/gkrellm-radio-2.0.4.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrellm-radio/gkrellm-radio-2.0.4.ebuild,v 1.3 2004/09/02 18:22:39 pvdabeel Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrellm-radio/gkrellm-radio-2.0.4.ebuild,v 1.4 2007/03/12 14:26:24 lack Exp $
+
+inherit gkrellm-plugin
IUSE="lirc"
@@ -9,21 +11,16 @@ DESCRIPTION="A minimalistic GKrellM2 plugin to control radio tuners."
SRC_URI="http://gkrellm.luon.net/files/${P}.tar.gz"
HOMEPAGE="http://gkrellm.luon.net/gkrellm-radio.phtml"
-DEPEND="=app-admin/gkrellm-2*
- >=media-libs/imlib-1.9.14-r1
- lirc? ( app-misc/lirc )"
+DEPEND="lirc? ( app-misc/lirc )"
SLOT="2"
LICENSE="GPL-2"
KEYWORDS="~x86 ppc ~sparc"
+PLUGIN_SO=radio.so
+
src_compile() {
use lirc && myconf="${myconf} WITH_LIRC=1"
emake ${myconf} || die
}
-src_install () {
- exeinto /usr/lib/gkrellm2/plugins
- doexe radio.so
- dodoc README CHANGES
-}
diff --git a/x11-plugins/gkrellm-reminder/ChangeLog b/x11-plugins/gkrellm-reminder/ChangeLog
index 49f5be5d9980..69a684cdf8b6 100644
--- a/x11-plugins/gkrellm-reminder/ChangeLog
+++ b/x11-plugins/gkrellm-reminder/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for x11-plugins/gkrellm-reminder
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrellm-reminder/ChangeLog,v 1.14 2007/02/21 17:28:59 lack Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrellm-reminder/ChangeLog,v 1.15 2007/03/12 14:30:06 lack Exp $
+
+ 12 Mar 2007; Jim Ramsay <lack@gentoo.org> gkrellm-reminder-2.0.0.ebuild:
+ Updated to use new gkrellm-plugin eclass
21 Feb 2007; Jim Ramsay <lack@gentoo.org> +metadata.xml,
-gkrellm-reminder-0.3.5.ebuild, gkrellm-reminder-2.0.0.ebuild:
diff --git a/x11-plugins/gkrellm-reminder/gkrellm-reminder-2.0.0.ebuild b/x11-plugins/gkrellm-reminder/gkrellm-reminder-2.0.0.ebuild
index 6fe75216c270..583f7657d7bb 100644
--- a/x11-plugins/gkrellm-reminder/gkrellm-reminder-2.0.0.ebuild
+++ b/x11-plugins/gkrellm-reminder/gkrellm-reminder-2.0.0.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrellm-reminder/gkrellm-reminder-2.0.0.ebuild,v 1.12 2007/02/21 17:28:59 lack Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrellm-reminder/gkrellm-reminder-2.0.0.ebuild,v 1.13 2007/03/12 14:30:05 lack Exp $
-inherit multilib
+inherit gkrellm-plugin
IUSE=""
DESCRIPTION="a Reminder Plugin for GKrellM2"
@@ -13,14 +13,5 @@ SLOT="2"
LICENSE="GPL-2"
KEYWORDS="x86 ppc sparc alpha amd64"
-DEPEND="=app-admin/gkrellm-2*"
+PLUGIN_SO=reminder.so
-src_compile() {
- make || die
-}
-
-src_install () {
- insinto /usr/$(get_libdir)/gkrellm2/plugins
- doins reminder.so
- dodoc README ChangeLog COPYING
-}