summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Kursawe <phosphan@gentoo.org>2004-02-11 09:39:44 +0000
committerPatrick Kursawe <phosphan@gentoo.org>2004-02-11 09:39:44 +0000
commit3bdfe9ff7f40082ec9537abc177f210d7c47869b (patch)
treef81431a3ba5ddcad3966ca49d448c38b5b128041 /x11-plugins/wmbiff/wmbiff-0.4.20.ebuild
parentSee bug #37745 (diff)
downloadhistorical-3bdfe9ff7f40082ec9537abc177f210d7c47869b.tar.gz
historical-3bdfe9ff7f40082ec9537abc177f210d7c47869b.tar.bz2
historical-3bdfe9ff7f40082ec9537abc177f210d7c47869b.zip
See bug #37745
Diffstat (limited to 'x11-plugins/wmbiff/wmbiff-0.4.20.ebuild')
-rw-r--r--x11-plugins/wmbiff/wmbiff-0.4.20.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/x11-plugins/wmbiff/wmbiff-0.4.20.ebuild b/x11-plugins/wmbiff/wmbiff-0.4.20.ebuild
new file mode 100644
index 000000000000..8be84be9521b
--- /dev/null
+++ b/x11-plugins/wmbiff/wmbiff-0.4.20.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmbiff/wmbiff-0.4.20.ebuild,v 1.1 2004/02/11 09:39:35 phosphan Exp $
+
+DESCRIPTION="WMBiff is a dock applet for WindowMaker which can monitor up to 5 mailboxes."
+SRC_URI="mirror://sourceforge/wmbiff/${P}.tar.gz"
+HOMEPAGE="http://sourceforge.net/projects/wmbiff/"
+
+DEPEND="virtual/x11
+ crypt? ( net-libs/gnutls
+ dev-libs/libgcrypt )"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~sparc ~amd64"
+IUSE="crypt"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ if use crypt; then
+ if has_version ">dev-libs/libgcrypt-1.1.12"; then
+ epatch ${FILESDIR}/${P}-crypto-api-fix.patch
+ fi
+ fi
+}
+
+src_compile() {
+ local myconf
+ if ! use crypt; then
+ myconf="--disable-crypto"
+ fi
+ econf ${myconf} || die
+ emake || die
+}
+
+src_install () {
+ make DESTDIR="${D}" install || die
+ dodoc ChangeLog FAQ NEWS README README.licq TODO
+}