summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichele Noberasco <s4t4n@gentoo.org>2004-07-08 12:33:43 +0000
committerMichele Noberasco <s4t4n@gentoo.org>2004-07-08 12:33:43 +0000
commit415e8760a426f136bc9c34400425ecc24ef7d869 (patch)
treed2fc366f966800f9d325483ffc885a2b19487360 /x11-plugins/wmacpimon/wmacpimon-0.2.1.ebuild
parentVersion bump; submitted by Josh Glover in bug #54196 (diff)
downloadhistorical-415e8760a426f136bc9c34400425ecc24ef7d869.tar.gz
historical-415e8760a426f136bc9c34400425ecc24ef7d869.tar.bz2
historical-415e8760a426f136bc9c34400425ecc24ef7d869.zip
Initial import of x11-plugins/wmacpimon, version 0.2.1
Diffstat (limited to 'x11-plugins/wmacpimon/wmacpimon-0.2.1.ebuild')
-rw-r--r--x11-plugins/wmacpimon/wmacpimon-0.2.1.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/x11-plugins/wmacpimon/wmacpimon-0.2.1.ebuild b/x11-plugins/wmacpimon/wmacpimon-0.2.1.ebuild
new file mode 100644
index 000000000000..b1806e751955
--- /dev/null
+++ b/x11-plugins/wmacpimon/wmacpimon-0.2.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmacpimon/wmacpimon-0.2.1.ebuild,v 1.1 2004/07/08 12:33:43 s4t4n Exp $
+
+inherit eutils
+
+IUSE=""
+
+DESCRIPTION="WMaker DockApp that monitors the temperature and Speedstep features in new ACPI-based systems."
+HOMEPAGE="http://www.vrlteam.org/wmacpimon/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND="virtual/x11"
+
+src_unpack()
+{
+ unpack ${A}
+
+ # patch wmacpimon.c file to set default path for
+ # wmacpimon.prc to /var/tmp/
+ cd ${S}
+ epatch ${FILESDIR}/wmacpimon.c.patch
+}
+
+src_compile()
+{
+ make \
+ CFLAGS="${CFLAGS} -DACPI -Wall -I/usr/X11R6/include" \
+ LDFLAGS="${CFLAGS} -DACPI -L/usr/X11R6/lib -lX11 -lXpm -lXext" \
+ || die "Compilation failed"
+}
+
+src_install()
+{
+ dobin wmacpimond wmacpimon
+ dodoc AUTHORS ChangeLog README INSTALL
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/wmacpimon.initscript wmacpimon
+}
+
+pkg_postinst()
+{
+ einfo "Remember to start the wmacpimond daemon"
+ einfo "(by issuing the \"/etc/init.d/wmacpimon start\" command)"
+ einfo "before you attempt to run wmacpimon..."
+}