summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-12-08 15:03:26 +0000
committerMike Frysinger <vapier@gentoo.org>2003-12-08 15:03:26 +0000
commit7269b5f1531a9a8d692c55ec612ff8644b4c9622 (patch)
tree5e3e8e5f618444e4e80327cdbf90858bb12d2e9b /x11-misc
parentFixed build problem when mkdirhier is missing, bug 35332 (diff)
downloadhistorical-7269b5f1531a9a8d692c55ec612ff8644b4c9622.tar.gz
historical-7269b5f1531a9a8d692c55ec612ff8644b4c9622.tar.bz2
historical-7269b5f1531a9a8d692c55ec612ff8644b4c9622.zip
auto setup session stuff #32278
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/entrance/entrance-0.9.0.20031129.ebuild24
1 files changed, 23 insertions, 1 deletions
diff --git a/x11-misc/entrance/entrance-0.9.0.20031129.ebuild b/x11-misc/entrance/entrance-0.9.0.20031129.ebuild
index e7f716cad192..125787cdf892 100644
--- a/x11-misc/entrance/entrance-0.9.0.20031129.ebuild
+++ b/x11-misc/entrance/entrance-0.9.0.20031129.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/entrance/entrance-0.9.0.20031129.ebuild,v 1.1 2003/11/30 02:42:55 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/entrance/entrance-0.9.0.20031129.ebuild,v 1.2 2003/12/08 15:03:26 vapier Exp $
inherit enlightenment eutils
@@ -28,3 +28,25 @@ src_install() {
doexe data/config/build_config.sh
edb_ed ${D}/etc/entrance_config.db add /entrance/theme str Nebulous.eet
}
+
+pkg_postinst() {
+ enlightenment_pkg_postinst
+ cd /etc/X11/Sessions
+ local edb=/etc/entrance_config.db
+ local count=`edb_ed ${edb} get /entrance/session/count int`
+ while [ ${count} -ge 0 ] ; do
+ edb_ed ${edb} del /entrance/session/${count}/icon
+ edb_ed ${edb} del /entrance/session/${count}/session
+ edb_ed ${edb} del /entrance/session/${count}/title
+ count=$((${count} - 1))
+ done
+ count=0
+ for s in * failsafe ; do
+ [ "${s}" == "Xsession" ] && continue
+ edb_ed ${edb} add /entrance/session/${count}/icon str ${s}.png
+ edb_ed ${edb} add /entrance/session/${count}/session str ${s}
+ edb_ed ${edb} add /entrance/session/${count}/title ${s}
+ count=$((${count} + 1))
+ done
+ edb_ed ${edb} add /entrance/session/count int ${count}
+}