summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarl Trygve Kalleberg <karltk@gentoo.org>2003-11-09 22:48:19 +0000
committerKarl Trygve Kalleberg <karltk@gentoo.org>2003-11-09 22:48:19 +0000
commit32918f995f5eceac32d61bff251b343837e089ac (patch)
tree572fcab5ab50f7d6b5365b91bede0384be539727 /x11-misc
parentInitial import. Fixes #31439. (diff)
downloadhistorical-32918f995f5eceac32d61bff251b343837e089ac.tar.gz
historical-32918f995f5eceac32d61bff251b343837e089ac.tar.bz2
historical-32918f995f5eceac32d61bff251b343837e089ac.zip
Initial import. Fixes #31439.
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/pypanel/Manifest5
-rw-r--r--x11-misc/pypanel/files/digest-pypanel-0.81
-rw-r--r--x11-misc/pypanel/metadata.xml23
-rw-r--r--x11-misc/pypanel/pypanel-0.8.ebuild25
4 files changed, 52 insertions, 2 deletions
diff --git a/x11-misc/pypanel/Manifest b/x11-misc/pypanel/Manifest
index 25292ac5e3a3..8f908c4974dd 100644
--- a/x11-misc/pypanel/Manifest
+++ b/x11-misc/pypanel/Manifest
@@ -1,3 +1,4 @@
-MD5 4e95756079d1b4fd00e26f1d0d06d037 pypanel-0.8.ebuild~ 790
-MD5 8d72a65a17cab12033ac0d7b9b2a2e0a pypanel-0.8.ebuild 799
+MD5 93e8fc2290e1175e968372aa273d9701 pypanel-0.8.ebuild 682
+MD5 78a0111ed7eac9c64c038f3692cf5e66 ChangeLog 421
+MD5 3933fb9abc4bc97ee019569a7d6eadf5 metadata.xml 870
MD5 5949fb0f40385b33ecf68dce659aaaad files/digest-pypanel-0.8 62
diff --git a/x11-misc/pypanel/files/digest-pypanel-0.8 b/x11-misc/pypanel/files/digest-pypanel-0.8
new file mode 100644
index 000000000000..933498e6baa5
--- /dev/null
+++ b/x11-misc/pypanel/files/digest-pypanel-0.8
@@ -0,0 +1 @@
+MD5 6949329c504bc1c5b1cea686add17c70 PyPanel-0.8.tar.gz 20934
diff --git a/x11-misc/pypanel/metadata.xml b/x11-misc/pypanel/metadata.xml
new file mode 100644
index 000000000000..89b38e49ee21
--- /dev/null
+++ b/x11-misc/pypanel/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>desktop-misc,python</herd>
+<maintainer>
+ <email>karltk@gentoo.org</email>
+ <name>Karl Trygve Kalleberg</name>
+ <description>Temporary maintainer until the herds accept maintainership</description>
+</maintainer>
+
+<longdescription>
+PyPanel is a lightweight panel/taskbar for X11 window managers that can
+be easily customized to match any desktop theme or taste.
+
+Some of the customizable features include transparency w/ shading, panel
+dimensions and location, font type and colors, button events/actions,
+clock and workspace name display.
+
+PyPanel should work with any WM that supports the EWMH specification.
+The following have been tested: Kahakai, Openbox3, PekWM, WindowMaker.
+</longdescription>
+
+</pkgmetadata>
diff --git a/x11-misc/pypanel/pypanel-0.8.ebuild b/x11-misc/pypanel/pypanel-0.8.ebuild
new file mode 100644
index 000000000000..d032894bf60b
--- /dev/null
+++ b/x11-misc/pypanel/pypanel-0.8.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/pypanel/pypanel-0.8.ebuild,v 1.1 2003/11/09 22:48:09 karltk Exp $
+
+DESCRIPTION="PyPanel is a lightweight panel/taskbar for X11 window managers."
+HOMEPAGE="http://pypanel.sourceforge.net"
+SRC_URI="mirror://sourceforge/pypanel/PyPanel-${PV}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND=">=x11-base/xfree-4.3.0-r2
+ >=dev-lang/python-2.2.3-r1
+ >=dev-python/python-xlib-0.12"
+S="${WORKDIR}/PyPanel-${PV}"
+
+inherit distutils
+
+src_compile() {
+ distutils_src_install
+}
+
+src_install() {
+ distutils_src_install
+}