summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBryan Stine <battousai@gentoo.org>2004-02-19 15:47:35 +0000
committerBryan Stine <battousai@gentoo.org>2004-02-19 15:47:35 +0000
commitac89058938f479360ffc14818c953f89de6456bd (patch)
tree77fd99b89499cde3ddfc023960f0c1385e586139 /x11-misc/linuxwacom
parentUpdated ebuild to include text-to-speech and server browser ping patches from... (diff)
downloadhistorical-ac89058938f479360ffc14818c953f89de6456bd.tar.gz
historical-ac89058938f479360ffc14818c953f89de6456bd.tar.bz2
historical-ac89058938f479360ffc14818c953f89de6456bd.zip
Initial import.
Diffstat (limited to 'x11-misc/linuxwacom')
-rw-r--r--x11-misc/linuxwacom/ChangeLog10
-rw-r--r--x11-misc/linuxwacom/Manifest4
-rw-r--r--x11-misc/linuxwacom/files/digest-linuxwacom-0.6.01
-rw-r--r--x11-misc/linuxwacom/linuxwacom-0.6.0.ebuild51
-rw-r--r--x11-misc/linuxwacom/metadata.xml6
5 files changed, 72 insertions, 0 deletions
diff --git a/x11-misc/linuxwacom/ChangeLog b/x11-misc/linuxwacom/ChangeLog
new file mode 100644
index 000000000000..50b12a510d2f
--- /dev/null
+++ b/x11-misc/linuxwacom/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for x11-misc/linuxwacom
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/linuxwacom/ChangeLog,v 1.1 2004/02/19 15:47:35 battousai Exp $
+
+*linuxwacom-0.6.0 (19 Feb 2004)
+
+ 19 Feb 2004; Bryan Stine <battousai@gentoo.org>; linuxwacom-0.6.0.ebuild:
+ Initial import. Builds against the SDK, and replaces the driver distributed
+ with xfree.
+
diff --git a/x11-misc/linuxwacom/Manifest b/x11-misc/linuxwacom/Manifest
new file mode 100644
index 000000000000..88551e66d78d
--- /dev/null
+++ b/x11-misc/linuxwacom/Manifest
@@ -0,0 +1,4 @@
+MD5 ab7c9165f80ea7cb1d5f75f365dfa9cf linuxwacom-0.6.0.ebuild 1602
+MD5 9f4a7ce34076c6321c76d6b84250a820 ChangeLog 425
+MD5 8d7e11f3df16afb79b7dd9778e4bf706 metadata.xml 262
+MD5 902d6a465a6ca9137494581a6423fe59 files/digest-linuxwacom-0.6.0 69
diff --git a/x11-misc/linuxwacom/files/digest-linuxwacom-0.6.0 b/x11-misc/linuxwacom/files/digest-linuxwacom-0.6.0
new file mode 100644
index 000000000000..2144251c80e7
--- /dev/null
+++ b/x11-misc/linuxwacom/files/digest-linuxwacom-0.6.0
@@ -0,0 +1 @@
+MD5 aa34b8968bdab8305511d74244246e9c linuxwacom-0.6.0.tar.bz2 431010
diff --git a/x11-misc/linuxwacom/linuxwacom-0.6.0.ebuild b/x11-misc/linuxwacom/linuxwacom-0.6.0.ebuild
new file mode 100644
index 000000000000..9066aafc5e7c
--- /dev/null
+++ b/x11-misc/linuxwacom/linuxwacom-0.6.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/linuxwacom/linuxwacom-0.6.0.ebuild,v 1.1 2004/02/19 15:47:35 battousai Exp $
+
+DESCRIPTION="Input driver for Wacom tablets and drawing devices"
+HOMEPAGE="http://linuxwacom.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND=">=x11-base/xfree-4.3.0-r6"
+
+pkg_setup() {
+ if [ ! "`grep sdk /var/db/pkg/x11-base/xfree-[0-9]*/USE`" ]
+ then
+ eerror "This package builds against the XFree86 SDK, and therefore requires"
+ eerror "that you have emerged xfree with the sdk USE flag enabled."
+ die "Please remerge xfree with the sdk USE flag enabled."
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+
+ # Simple fixes to configure to check the actual location of the XFree86 SDK
+ cd ${S}
+ sed -i -e "s:XF86SUBDIR=.*:XF86SUBDIR=include:" configure
+ sed -i -e "s:XF86V3SUBDIR=.*:XF86V3SUBDIR=include:" configure
+}
+
+src_compile() {
+ myconf="--enable-wacomdrv --enable-wacomdrvv3 --with-xf86=/usr/X11R6/lib/Server \
+ --with-xf86v3=/usr/X11R6/lib/Server"
+ econf ${myconf} || die "configure failed."
+
+ # Makefile fix for build against SDK
+ cd ${S}/src
+ cp Makefile Makefile.orig
+ sed -i -e "s:XF86_DIR = .*:XF86_DIR = /usr/X11R6/lib/Server:" Makefile
+ sed -i -e "s:XF86_V3_DIR = .*:XF86_V3_DIR = /usr/X11R6/lib/Server:" Makefile
+ sed -i -e "s:/include/extensions:/include:g" Makefile
+ cd ${S}
+
+ emake || die "build failed."
+}
+
+src_install() {
+ emake DESTDIR=${D} install || die "Install failed."
+}
diff --git a/x11-misc/linuxwacom/metadata.xml b/x11-misc/linuxwacom/metadata.xml
new file mode 100644
index 000000000000..083f5682641e
--- /dev/null
+++ b/x11-misc/linuxwacom/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>xfree</herd>
+<longdescription>linuxwacom is an open-source XFree86 input driver for Wacom tablets.</longdescription>
+</pkgmetadata>