summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2011-07-22 08:14:00 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2011-07-22 08:14:00 +0000
commit490cfb2b7dc9a8de59f7e3a4fbd1a586fd7b33e5 (patch)
tree3494ac73075ee337b6bf9c1d1143c1aaa465acf2 /x11-misc/i3status
parentRemove invalid USE unmask (diff)
downloadhistorical-490cfb2b7dc9a8de59f7e3a4fbd1a586fd7b33e5.tar.gz
historical-490cfb2b7dc9a8de59f7e3a4fbd1a586fd7b33e5.tar.bz2
historical-490cfb2b7dc9a8de59f7e3a4fbd1a586fd7b33e5.zip
Initial import. Fixes bug 296434. Thanks to Simeon Maryasin <marsoft@ya.ru> and Oleg Akimov <akimov.shop@gmail.com> for their work
Package-Manager: portage-2.2.0_alpha45/cvs/Linux x86_64
Diffstat (limited to 'x11-misc/i3status')
-rw-r--r--x11-misc/i3status/ChangeLog11
-rw-r--r--x11-misc/i3status/Manifest16
-rw-r--r--x11-misc/i3status/i3status-2.3.ebuild74
-rw-r--r--x11-misc/i3status/metadata.xml17
4 files changed, 118 insertions, 0 deletions
diff --git a/x11-misc/i3status/ChangeLog b/x11-misc/i3status/ChangeLog
new file mode 100644
index 000000000000..cf1b9733fffb
--- /dev/null
+++ b/x11-misc/i3status/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for x11-misc/i3status
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/i3status/ChangeLog,v 1.1 2011/07/22 08:14:00 xarthisius Exp $
+
+*i3status-2.3 (22 Jul 2011)
+
+ 22 Jul 2011; Kacper Kowalik <xarthisius@gentoo.org> +i3status-2.3.ebuild,
+ +metadata.xml:
+ Initial import. Fixes bug 296434. Thanks to Simeon Maryasin <marsoft@ya.ru>
+ and Oleg Akimov <akimov.shop@gmail.com> for their work
+
diff --git a/x11-misc/i3status/Manifest b/x11-misc/i3status/Manifest
new file mode 100644
index 000000000000..564c0d0c36e9
--- /dev/null
+++ b/x11-misc/i3status/Manifest
@@ -0,0 +1,16 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+DIST i3status-2.3.tar.bz2 24814 RMD160 f37cbb61efe274d974bd38686755cd94d45ac230 SHA1 3d02ae2bc46f5a81453b4cab713211e04d466c16 SHA256 552dac4649f4e142c88ad3c42faace1fc372515c1b9dd979ebca58d36fa4bb1a
+EBUILD i3status-2.3.ebuild 1978 RMD160 9054166c1cd31d9b80cac9dcc3289d809b5b00ca SHA1 2ae2830d8c4936c0ac7554669a730dff29001009 SHA256 ea9ff1f5cdaa9e24a273f8389ed0646c980bce01e4966180a6a1563fb45fb51f
+MISC ChangeLog 469 RMD160 8116c85908ad42520b472e51cb02731be3d67dd8 SHA1 e54d6504e98d49654268b0bdfa0f770d2a77c110 SHA256 597e8388f876eec965233a1d7f9e39d7cb92f1ab1c2fac4c725d72b2a0df7d2c
+MISC metadata.xml 781 RMD160 41843de6254f08a4cd9519b20c86e9a28f0c1f20 SHA1 1d6ecc85ed13e42018d388b4249ce98d565fcdbd SHA256 97cc7157bfe2d05a4c77793b89190fef0f94d1decd52e41c717c37583696f3f4
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.17 (GNU/Linux)
+
+iJwEAQECAAYFAk4pMVEACgkQIiMqcbOVdxQwTwQAnqbfaJ4F47N3j8191UsLeb6O
+kGLuZULp/pgQTn62Wp3xDiV5yDD2jQqB0k2LnYotekBdhP8tdvBQ0ps5xwTopKSg
+b38iAn/WEnorKhQVZU+Wj2aeo60Yhp5uZJrjTFfZXFs9SdqxZD2JgmgLtvAwt7o+
+LsHMzn0vMlWJ5rOqOIw=
+=ZTIQ
+-----END PGP SIGNATURE-----
diff --git a/x11-misc/i3status/i3status-2.3.ebuild b/x11-misc/i3status/i3status-2.3.ebuild
new file mode 100644
index 000000000000..cc51b40cd3a6
--- /dev/null
+++ b/x11-misc/i3status/i3status-2.3.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/i3status/i3status-2.3.ebuild,v 1.1 2011/07/22 08:14:00 xarthisius Exp $
+
+EAPI=4
+
+inherit toolchain-funcs
+
+DESCRIPTION="generates a status bar for dzen2, xmobar or similar"
+HOMEPAGE="http://i3wm.org/i3status/"
+SRC_URI="http://i3wm.org/${PN}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+caps"
+
+RDEPEND="dev-libs/confuse
+ media-libs/alsa-lib
+ net-wireless/wireless-tools"
+DEPEND="${RDEPEND}
+ caps? ( sys-libs/libcap )"
+
+# borrowed from GSoC2010_Gentoo_Capabilities by constanze and flameyeys
+# @FUNCTION: fcaps
+# @USAGE: fcaps {uid:gid} {file-mode} {cap1[,cap2,...]} {file}
+# @RETURN: 0 if all okay; non-zero if failure and fallback
+# @DESCRIPTION:
+# fcaps sets the specified capabilities in the effective and permitted set of
+# the given file. In case of failure fcaps sets the given file-mode.
+fcaps() {
+ local uid_gid=$1
+ local perms=$2
+ local capset=$3
+ local path=$4
+ local res
+
+ chmod $perms $path && \
+ chown $uid_gid $path
+ res=$?
+
+ use caps || return $res
+
+ #set the capability
+ setcap "$capset=ep" "$path" &> /dev/null
+ #check if the capabilitiy got set correctly
+ setcap -v "$capset=ep" "$path" &> /dev/null
+ res=$?
+
+ if [ $res -ne 0 ]; then
+ ewarn "Failed to set capabilities. Probable reason is missed kernel support."
+ ewarn "Kernel must have SECURITY_FILE_CAPABILITIES, and <FS>_FS_SECURITY"
+ ewarn "enabled (e.g. EXT3_FS_SECURITY) where <FS> is the filesystem to store"
+ ewarn "${path}"
+ ewarn
+ ewarn "Falling back to suid now..."
+ chmod u+s ${path}
+ fi
+ return $res
+}
+
+pkg_setup() {
+ tc-export CC
+}
+
+src_prepare() {
+ sed -i -e "/@echo/d" -e "s:@\$(:\$(:g" -e "/setcap/d" Makefile || die
+}
+
+pkg_postinst() {
+ fcaps 0:users 550 cap_net_admin "${ROOT}"/usr/bin/${PN}
+ elog "You need to install x11-misc/xmobar or x11-misc/dzen to use ${PN}."
+ elog "Please refer to manual: man ${PN}"
+}
diff --git a/x11-misc/i3status/metadata.xml b/x11-misc/i3status/metadata.xml
new file mode 100644
index 000000000000..f2ab65f7a817
--- /dev/null
+++ b/x11-misc/i3status/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>desktop-misc</herd>
+ <maintainer>
+ <email>xarthisius@gentoo.org</email>
+ <name>Kacper Kowalik</name>
+ </maintainer>
+ <longdescription>
+ i3status is a small program (about 1500 SLOC) for generating a status bar for
+ dzen2, xmobar or similar programs. It is designed to be very efficient by
+ issuing a very small number of system calls, as one generally wants to update
+ such a status line every second. This ensures that even under high load, your
+ status bar is updated correctly. Also, it saves a bit of energy by not hogging
+ your CPU as much as spawning the corresponding amount of shell commands would.
+ </longdescription>
+</pkgmetadata>