summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorD.M.D. Ljungmark <spider@gentoo.org>2002-04-24 13:57:59 +0000
committerD.M.D. Ljungmark <spider@gentoo.org>2002-04-24 13:57:59 +0000
commite0f529c27787ae692e5a7b34f0e01058f19219f0 (patch)
treed05bf60e4aba24167bca5e0191a0cdf22e757f51 /x11-libs
parentremoved cron lifeline (diff)
downloadhistorical-e0f529c27787ae692e5a7b34f0e01058f19219f0.tar.gz
historical-e0f529c27787ae692e5a7b34f0e01058f19219f0.tar.bz2
historical-e0f529c27787ae692e5a7b34f0e01058f19219f0.zip
update gtk2 with more use and libtoolize
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/gtk+/ChangeLog6
-rw-r--r--x11-libs/gtk+/files/digest-gtk+-2.0.2-r21
-rw-r--r--x11-libs/gtk+/gtk+-2.0.2-r2.ebuild62
3 files changed, 68 insertions, 1 deletions
diff --git a/x11-libs/gtk+/ChangeLog b/x11-libs/gtk+/ChangeLog
index 24e183f32476..373e33bcd4f3 100644
--- a/x11-libs/gtk+/ChangeLog
+++ b/x11-libs/gtk+/ChangeLog
@@ -1,11 +1,15 @@
# ChangeLog for x11-libs/gtk+
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/ChangeLog,v 1.9 2002/04/14 09:28:18 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/ChangeLog,v 1.10 2002/04/24 13:57:59 spider Exp $
14 Apr 2002; M.Schlemmer <azarah@gentoo.org>; gtk+-1.2.10-r7.ebuild :
Libtoolize.
+*gtk+-2.0.2-r2 (24 Apr 2002)
+ 24 Apr 2002; Spider <spider@gentoo.org>; gtk+-2.0.2-r2.ebuild:
+ Libtoolize
+
*gtk+-2.0.2-r2 (12 Apr 2002)
12 Apr 2002; Spider <spider@gentoo.org>; gtk+-2.0.2-r2.ebuild:
Update so a user can disable png, jpeg, tiff support for gtk+
diff --git a/x11-libs/gtk+/files/digest-gtk+-2.0.2-r2 b/x11-libs/gtk+/files/digest-gtk+-2.0.2-r2
new file mode 100644
index 000000000000..665e7da38da8
--- /dev/null
+++ b/x11-libs/gtk+/files/digest-gtk+-2.0.2-r2
@@ -0,0 +1 @@
+MD5 b8df4c513323b9efc9a157703f25a07f gtk+-2.0.2.tar.bz2 5683089
diff --git a/x11-libs/gtk+/gtk+-2.0.2-r2.ebuild b/x11-libs/gtk+/gtk+-2.0.2-r2.ebuild
new file mode 100644
index 000000000000..e1d55d915830
--- /dev/null
+++ b/x11-libs/gtk+/gtk+-2.0.2-r2.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Spider <spider@gentoo.org>
+# /space/gentoo/cvsroot/gentoo-x86/dev-libs/glib/glib-1.3.14.ebuild,v 1.1 2002/02/20 22:11:06 gbevin Exp
+
+# ACONFVER=2.52f
+# AMAKEVER=1.5b
+# Source inherit.eclass and inherit AutoTools
+# . /usr/portage/eclass/inherit.eclass || die
+# inherit autotools
+
+SLOT="2"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Gimp ToolKit + "
+SRC_URI="ftp://ftp.gtk.org/pub/gtk/v2.0/${P}.tar.bz2"
+HOMEPAGE="http://www.gtk.org/"
+
+DEPEND="virtual/x11
+ >=dev-util/pkgconfig-0.12.0
+ >=dev-libs/glib-2.0.1
+ >=dev-libs/atk-1.0.1
+ >=x11-libs/pango-1.0.1
+ png? ( >=media-libs/libpng-1.2.1 )
+ jpeg? ( >=media-libs/jpeg-6b-r2 )
+ tiff ( >=media-libs/tiff-3.5.7 )
+ doc? ( >=dev-util/gtk-doc-0.9-r2 )"
+
+src_compile() {
+ libtoolize --copy --force
+ local myconf
+ use doc && myconf="${myconf} --enable-gtk-doc" || myconf="${myconf} --disable-gtk-doc"
+ use png || myconf="${myconf} --without-libpng"
+ use jpeg || myconf="${myconf} --without-libjpeg"
+ use tiff || myconf="${myconf} --without-libtiff"
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --with-gdktarget=x11 \
+ ${myconf} \
+ --enable-debug || die
+# enable debug since glib fails if we disable it
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} \
+ prefix=/usr \
+ sysconfdir=/etc \
+ infodir=/usr/share/info \
+ mandir=/usr/share/man \
+ install || die
+ dodoc AUTHORS COPYING ChangeLog* HACKING* INSTALL NEWS* README* TODO
+}
+
+
+
+
+