summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Alexander <wired@gentoo.org>2010-11-09 15:51:33 +0000
committerAlex Alexander <wired@gentoo.org>2010-11-09 15:51:33 +0000
commiteb8dc3c44826fd3dcf7fb37b00d14d268f9f381e (patch)
tree050b9454b303a5f559b7d6334182cc3037c50fc9 /x11-libs/qt-webkit
parentVersion bump wrt bug #342281. (diff)
downloadhistorical-eb8dc3c44826fd3dcf7fb37b00d14d268f9f381e.tar.gz
historical-eb8dc3c44826fd3dcf7fb37b00d14d268f9f381e.tar.bz2
historical-eb8dc3c44826fd3dcf7fb37b00d14d268f9f381e.zip
version bump
Package-Manager: portage-2.2.0_alpha4/cvs/Linux x86_64
Diffstat (limited to 'x11-libs/qt-webkit')
-rw-r--r--x11-libs/qt-webkit/ChangeLog7
-rw-r--r--x11-libs/qt-webkit/qt-webkit-4.7.1.ebuild49
2 files changed, 55 insertions, 1 deletions
diff --git a/x11-libs/qt-webkit/ChangeLog b/x11-libs/qt-webkit/ChangeLog
index c3d4947fe176..5d28410447bb 100644
--- a/x11-libs/qt-webkit/ChangeLog
+++ b/x11-libs/qt-webkit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/qt-webkit
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-webkit/ChangeLog,v 1.109 2010/11/09 10:06:26 wired Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-webkit/ChangeLog,v 1.110 2010/11/09 15:50:40 wired Exp $
+
+*qt-webkit-4.7.1 (09 Nov 2010)
+
+ 09 Nov 2010; Alex Alexander <wired@gentoo.org> +qt-webkit-4.7.1.ebuild:
+ version bump
*qt-webkit-4.7.0-r1 (09 Nov 2010)
*qt-webkit-4.6.3-r2 (09 Nov 2010)
diff --git a/x11-libs/qt-webkit/qt-webkit-4.7.1.ebuild b/x11-libs/qt-webkit/qt-webkit-4.7.1.ebuild
new file mode 100644
index 000000000000..cd2adc79ce0f
--- /dev/null
+++ b/x11-libs/qt-webkit/qt-webkit-4.7.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-webkit/qt-webkit-4.7.1.ebuild,v 1.1 2010/11/09 15:50:40 wired Exp $
+
+EAPI="3"
+inherit qt4-build
+
+DESCRIPTION="The Webkit module for the Qt toolkit"
+SLOT="4"
+KEYWORDS="~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 -sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="dbus kde"
+
+DEPEND="
+ dev-db/sqlite:3
+ ~x11-libs/qt-core-${PV}[aqua=,debug=,ssl]
+ ~x11-libs/qt-gui-${PV}[aqua=,dbus?,debug=]
+ ~x11-libs/qt-xmlpatterns-${PV}[aqua=,debug=]
+ dbus? ( ~x11-libs/qt-dbus-${PV}[aqua=,debug=] )
+ !kde? ( || ( ~x11-libs/qt-phonon-${PV}:${SLOT}[aqua=,dbus=,debug=]
+ media-sound/phonon[aqua=] ) )
+ kde? ( || ( media-sound/phonon[aqua=] ~x11-libs/qt-phonon-${PV}:${SLOT}[aqua=,dbus=,debug] ) )"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ QT4_TARGET_DIRECTORIES="
+ src/3rdparty/webkit/JavaScriptCore
+ src/3rdparty/webkit/WebCore
+ tools/designer/src/plugins/qwebview"
+ QT4_EXTRACT_DIRECTORIES="
+ include/
+ src/
+ tools/"
+
+ QCONFIG_ADD="webkit"
+ QCONFIG_DEFINE="QT_WEBKIT"
+
+ qt4-build_pkg_setup
+}
+
+src_prepare() {
+ [[ $(tc-arch) == "ppc64" ]] && append-flags -mminimal-toc #241900
+
+ qt4-build_src_prepare
+}
+
+src_configure() {
+ myconf="${myconf} -webkit -system-sqlite $(qt_use dbus qdbus)"
+ qt4-build_src_configure
+}