summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Chatzimichos <tampakrap@gentoo.org>2009-12-01 15:03:59 +0000
committerTheo Chatzimichos <tampakrap@gentoo.org>2009-12-01 15:03:59 +0000
commit4aa78a0319391f6ddd3b99440b24fc2bdaa19322 (patch)
tree46dccc5b41eb57738b4b09d1dc70ecc655db3bd3 /x11-libs/qt-test
parentmask temporarily qt-4.6 until I finish committing it (diff)
downloadhistorical-4aa78a0319391f6ddd3b99440b24fc2bdaa19322.tar.gz
historical-4aa78a0319391f6ddd3b99440b24fc2bdaa19322.tar.bz2
historical-4aa78a0319391f6ddd3b99440b24fc2bdaa19322.zip
Version bump to 4.6.0
Package-Manager: portage-2.2_rc54/cvs/Linux x86_64
Diffstat (limited to 'x11-libs/qt-test')
-rw-r--r--x11-libs/qt-test/ChangeLog8
-rw-r--r--x11-libs/qt-test/qt-test-4.6.0.ebuild30
2 files changed, 37 insertions, 1 deletions
diff --git a/x11-libs/qt-test/ChangeLog b/x11-libs/qt-test/ChangeLog
index 5b5643a7549e..9474293d0156 100644
--- a/x11-libs/qt-test/ChangeLog
+++ b/x11-libs/qt-test/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/qt-test
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-test/ChangeLog,v 1.52 2009/11/18 20:52:11 wired Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-test/ChangeLog,v 1.53 2009/12/01 15:01:57 tampakrap Exp $
+
+*qt-test-4.6.0 (01 Dec 2009)
+
+ 01 Dec 2009; Theo Chatzimichos <tampakrap@gentoo.org>
+ +qt-test-4.6.0.ebuild:
+ Version Bump to 4.6.0
*qt-test-4.6.0_rc1 (18 Nov 2009)
diff --git a/x11-libs/qt-test/qt-test-4.6.0.ebuild b/x11-libs/qt-test/qt-test-4.6.0.ebuild
new file mode 100644
index 000000000000..eaf10c2e06b7
--- /dev/null
+++ b/x11-libs/qt-test/qt-test-4.6.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-test/qt-test-4.6.0.ebuild,v 1.1 2009/12/01 15:01:57 tampakrap Exp $
+
+EAPI="2"
+inherit qt4-build
+
+DESCRIPTION="The testing framework module for the Qt toolkit"
+SLOT="4"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="iconv"
+
+DEPEND="~x11-libs/qt-core-${PV}[debug=]"
+RDEPEND="${DEPEND}"
+
+QT4_TARGET_DIRECTORIES="src/testlib"
+QT4_EXTRACT_DIRECTORIES="${QT4_TARGET_DIRECTORIES}
+include/QtTest/
+include/QtCore/
+src/corelib/"
+
+src_configure() {
+ myconf="${myconf} $(qt_use iconv) -no-xkb -no-fontconfig -no-xrender -no-xrandr
+ -no-xfixes -no-xcursor -no-xinerama -no-xshape -no-sm -no-opengl
+ -no-nas-sound -no-dbus -no-cups -no-nis -no-gif -no-libpng
+ -no-libmng -no-libjpeg -no-openssl -system-zlib -no-webkit -no-phonon
+ -no-qt3support -no-xmlpatterns -no-freetype -no-libtiff -no-accessibility
+ -no-fontconfig -no-glib -no-opengl -no-svg"
+ qt4-build_src_configure
+}