summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDror Levin <spatz@gentoo.org>2010-01-20 12:38:10 +0000
committerDror Levin <spatz@gentoo.org>2010-01-20 12:38:10 +0000
commit0c56c6b805e6f250f5025d2d7fb141e95de7e760 (patch)
tree88d089ca0f63ac7523010d9aa31ffb93716d522e /x11-libs/qt-test
parentRemove qgraphicsscence patch for 4.6.1 as it was included upstream. (diff)
downloadhistorical-0c56c6b805e6f250f5025d2d7fb141e95de7e760.tar.gz
historical-0c56c6b805e6f250f5025d2d7fb141e95de7e760.tar.bz2
historical-0c56c6b805e6f250f5025d2d7fb141e95de7e760.zip
Remake nolibx11 patch for 4.6.1.
Package-Manager: portage-2.2_rc61/cvs/Linux x86_64
Diffstat (limited to 'x11-libs/qt-test')
-rw-r--r--x11-libs/qt-test/ChangeLog6
-rw-r--r--x11-libs/qt-test/files/qt-4.6.1-nolibx11.patch18
-rw-r--r--x11-libs/qt-test/qt-test-4.6.1.ebuild4
3 files changed, 25 insertions, 3 deletions
diff --git a/x11-libs/qt-test/ChangeLog b/x11-libs/qt-test/ChangeLog
index 718e875b9bfd..9bb1d2f5cfa5 100644
--- a/x11-libs/qt-test/ChangeLog
+++ b/x11-libs/qt-test/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-libs/qt-test
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-test/ChangeLog,v 1.57 2010/01/19 14:58:23 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-test/ChangeLog,v 1.58 2010/01/20 12:36:38 spatz Exp $
+
+ 20 Jan 2010; Dror Levin <spatz@gentoo.org> qt-test-4.6.1.ebuild,
+ +files/qt-4.6.1-nolibx11.patch:
+ Remake nolibx11 patch for 4.6.1.
*qt-test-4.6.1 (19 Jan 2010)
diff --git a/x11-libs/qt-test/files/qt-4.6.1-nolibx11.patch b/x11-libs/qt-test/files/qt-4.6.1-nolibx11.patch
new file mode 100644
index 000000000000..e5d13327b8ce
--- /dev/null
+++ b/x11-libs/qt-test/files/qt-4.6.1-nolibx11.patch
@@ -0,0 +1,18 @@
+--- configure-orig 2010-01-20 14:18:32.466798257 +0200
++++ configure 2010-01-20 14:18:58.516799116 +0200
+@@ -5059,15 +5059,6 @@
+ X11TESTS_FLAGS="$X11TESTS_FLAGS -fpermissive"
+ fi
+
+- # Check we actually have X11 :-)
+- "$unixtests/compile.test" "$XQMAKESPEC" "$QMAKE_CONFIG" $OPT_VERBOSE "$relpath" "$outpath" config.tests/x11/xlib "XLib" $L_FLAGS $I_FLAGS $l_FLAGS $X11TESTS_FLAGS
+- if [ $? != "0" ]; then
+- echo "Basic XLib functionality test failed!"
+- echo " You might need to modify the include and library search paths by editing"
+- echo " QMAKE_INCDIR_X11 and QMAKE_LIBDIR_X11 in ${XQMAKESPEC}."
+- exit 1
+- fi
+-
+ # auto-detect OpenGL support (es1 = OpenGL ES 1.x Common, es1cl = ES 1.x common lite, es2 = OpenGL ES 2.x)
+ if [ "$CFG_OPENGL" = "auto" ] || [ "$CFG_OPENGL" = "yes" ]; then
+ if "$unixtests/compile.test" "$XQMAKESPEC" "$QMAKE_CONFIG" $OPT_VERBOSE "$relpath" "$outpath" config.tests/x11/opengl "OpenGL" $L_FLAGS $I_FLAGS $l_FLAGS $X11TESTS_FLAGS; then
diff --git a/x11-libs/qt-test/qt-test-4.6.1.ebuild b/x11-libs/qt-test/qt-test-4.6.1.ebuild
index 0fc10bb06c9b..4ee0abfedc7e 100644
--- a/x11-libs/qt-test/qt-test-4.6.1.ebuild
+++ b/x11-libs/qt-test/qt-test-4.6.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-test/qt-test-4.6.1.ebuild,v 1.1 2010/01/19 14:58:23 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-test/qt-test-4.6.1.ebuild,v 1.2 2010/01/20 12:36:38 spatz Exp $
EAPI="2"
inherit qt4-build
@@ -20,7 +20,7 @@ include/QtCore/
src/corelib/"
PATCHES=(
- "${FILESDIR}/qt-4.6-nolibx11.diff"
+ "${FILESDIR}/qt-${PV}-nolibx11.patch"
)
src_configure() {