summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2009-04-27 19:52:55 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2009-04-27 19:52:55 +0000
commitadf7340a962ceebd0e4899cba1c9422aa2d5fc7f (patch)
tree26d41592b80bb03898b6fa4816e42f1b8f3e66e4 /x11-libs/qt-sql
parentBump. Thanks to Daniel Pielmeier for reminding me. Import some plnn-handling ... (diff)
downloadhistorical-adf7340a962ceebd0e4899cba1c9422aa2d5fc7f.tar.gz
historical-adf7340a962ceebd0e4899cba1c9422aa2d5fc7f.tar.bz2
historical-adf7340a962ceebd0e4899cba1c9422aa2d5fc7f.zip
Qt 4.5.1 release version bump
Package-Manager: portage-2.2_rc31/cvs/Linux x86_64
Diffstat (limited to 'x11-libs/qt-sql')
-rw-r--r--x11-libs/qt-sql/ChangeLog7
-rw-r--r--x11-libs/qt-sql/qt-sql-4.5.1.ebuild68
2 files changed, 74 insertions, 1 deletions
diff --git a/x11-libs/qt-sql/ChangeLog b/x11-libs/qt-sql/ChangeLog
index f1e7984601e4..c225be0d41cb 100644
--- a/x11-libs/qt-sql/ChangeLog
+++ b/x11-libs/qt-sql/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/qt-sql
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-sql/ChangeLog,v 1.37 2009/04/15 12:19:24 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-sql/ChangeLog,v 1.38 2009/04/27 19:48:44 hwoarang Exp $
+
+*qt-sql-4.5.1 (27 Apr 2009)
+
+ 27 Apr 2009; Markos Chandras <hwoarang@gentoo.org> +qt-sql-4.5.1.ebuild:
+ Version bump to 4.5.1
15 Apr 2009; Brent Baude <ranger@gentoo.org> qt-sql-4.4.2-r1.ebuild:
Marking qt-sql-4.4.2-r1 ppc64 for bug 263945
diff --git a/x11-libs/qt-sql/qt-sql-4.5.1.ebuild b/x11-libs/qt-sql/qt-sql-4.5.1.ebuild
new file mode 100644
index 000000000000..90e2e8cc9498
--- /dev/null
+++ b/x11-libs/qt-sql/qt-sql-4.5.1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-sql/qt-sql-4.5.1.ebuild,v 1.1 2009/04/27 19:48:44 hwoarang Exp $
+
+EAPI="2"
+inherit qt4-build
+
+DESCRIPTION="The SQL module for the Qt toolkit"
+SLOT="4"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="firebird +iconv mysql odbc postgres +qt3support +sqlite"
+
+DEPEND="~x11-libs/qt-core-${PV}[debug=,qt3support=]
+ firebird? ( dev-db/firebird )
+ sqlite? ( dev-db/sqlite:3 )
+ mysql? ( virtual/mysql )
+ postgres? ( virtual/postgresql-base )
+ odbc? ( dev-db/unixODBC )"
+RDEPEND="${DEPEND}"
+
+QT4_TARGET_DIRECTORIES="src/sql src/plugins/sqldrivers"
+QT4_EXTRACT_DIRECTORIES="${QT4_TARGET_DIRECTORIES}
+include/Qt/
+include/QtCore/
+include/QtSql/
+include/QtScript/
+src/src.pro
+src/corelib/
+src/plugins
+src/sql
+src/3rdparty
+src/tools"
+
+pkg_setup() {
+ if ! (use firebird || use mysql || use odbc || use postgres || use sqlite); then
+ ewarn "You need to enable at least one SQL driver. Enable at least"
+ ewarn "one of these USE flags: \"firebird mysql odbc postgres sqlite\""
+ die "Enable at least one SQL driver."
+ fi
+
+ qt4-build_pkg_setup
+}
+
+src_unpack() {
+ qt4-build_src_unpack
+
+ sed -e '/pg_config --libs/d' -i "${S}"/configure \
+ || die 'Sed to fix postgresql usage in ./configure failed.'
+}
+
+src_configure() {
+ # Don't support sqlite2 anymore
+ myconf="${myconf} -no-sql-sqlite2
+ $(qt_use mysql sql-mysql plugin) $(use mysql && echo "-I/usr/include/mysql -L/usr/$(get_libdir)/mysql ")
+ $(qt_use postgres sql-psql plugin) $(use postgres && echo "-I/usr/include/postgresql/pgsql ")
+ $(qt_use sqlite sql-sqlite plugin) $(use sqlite && echo '-system-sqlite')
+ $(qt_use odbc sql-odbc plugin)
+ $(qt_use qt3support)"
+
+ myconf="${myconf} $(qt_use iconv) -no-xkb -no-fontconfig -no-xrender -no-xrandr
+ -no-xfixes -no-xcursor -no-xinerama -no-xshape -no-sm -no-opengl
+ -no-nas-sound -no-dbus -no-cups -no-nis -no-gif -no-libpng
+ -no-libmng -no-libjpeg -no-openssl -system-zlib -no-webkit -no-phonon
+ -no-xmlpatterns -no-freetype -no-libtiff -no-accessibility -no-fontconfig
+ -no-glib -no-opengl -no-svg -no-gtkstyle"
+
+ qt4-build_src_configure
+}