summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Alexander <wired@gentoo.org>2009-10-16 16:51:30 +0000
committerAlex Alexander <wired@gentoo.org>2009-10-16 16:51:30 +0000
commit3b05371a23ca7cc8fcfc8fbf4ee9a5048f1d7453 (patch)
treebff24948b833b165b00231b96b9a1d964c4dc94f /x11-libs/qt-demo
parentStable for HPPA (bug #287369). (diff)
downloadhistorical-3b05371a23ca7cc8fcfc8fbf4ee9a5048f1d7453.tar.gz
historical-3b05371a23ca7cc8fcfc8fbf4ee9a5048f1d7453.tar.bz2
historical-3b05371a23ca7cc8fcfc8fbf4ee9a5048f1d7453.zip
added version 4.6.0_beta1
Package-Manager: portage-2.2_rc46/cvs/Linux x86_64
Diffstat (limited to 'x11-libs/qt-demo')
-rw-r--r--x11-libs/qt-demo/ChangeLog8
-rw-r--r--x11-libs/qt-demo/files/qt-demo-4.6-plugandpaint.patch13
-rw-r--r--x11-libs/qt-demo/qt-demo-4.6.0_beta1.ebuild46
3 files changed, 66 insertions, 1 deletions
diff --git a/x11-libs/qt-demo/ChangeLog b/x11-libs/qt-demo/ChangeLog
index 77b50db1425b..6237ba6ee405 100644
--- a/x11-libs/qt-demo/ChangeLog
+++ b/x11-libs/qt-demo/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/qt-demo
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-demo/ChangeLog,v 1.28 2009/10/09 06:07:37 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-demo/ChangeLog,v 1.29 2009/10/16 16:44:04 wired Exp $
+
+*qt-demo-4.6.0_beta1 (16 Oct 2009)
+
+ 16 Oct 2009; Alex Alexander <wired@gentoo.org>
+ +qt-demo-4.6.0_beta1.ebuild, +files/qt-demo-4.6-plugandpaint.patch:
+ added version 4.6.0_beta1
09 Oct 2009; Markus Meier <maekke@gentoo.org> qt-demo-4.5.2.ebuild:
amd64/arm/x86 stable, bug #286653
diff --git a/x11-libs/qt-demo/files/qt-demo-4.6-plugandpaint.patch b/x11-libs/qt-demo/files/qt-demo-4.6-plugandpaint.patch
new file mode 100644
index 000000000000..262996aa1068
--- /dev/null
+++ b/x11-libs/qt-demo/files/qt-demo-4.6-plugandpaint.patch
@@ -0,0 +1,13 @@
+diff --git a/examples/tools/plugandpaint/plugandpaint.pro b/examples/tools/plugandpaint/plugandpaint.pro
+index 9616eb8..e188bc1 100644
+--- a/examples/tools/plugandpaint/plugandpaint.pro
++++ b/examples/tools/plugandpaint/plugandpaint.pro
+@@ -10,7 +10,7 @@ SOURCES = main.cpp \
+ symbian {
+ LIBS = -lpnp_basictools.lib
+ } else {
+- LIBS = -L$${QT_BUILD_TREE}/examples/tools/plugandpaint/plugins -lpnp_basictools
++ LIBS += -L$${QT_BUILD_TREE}/examples/tools/plugandpaint/plugins -lpnp_basictools
+ }
+
+ if(!debug_and_release|build_pass):CONFIG(debug, debug|release) {
diff --git a/x11-libs/qt-demo/qt-demo-4.6.0_beta1.ebuild b/x11-libs/qt-demo/qt-demo-4.6.0_beta1.ebuild
new file mode 100644
index 000000000000..c1e00d0d6f93
--- /dev/null
+++ b/x11-libs/qt-demo/qt-demo-4.6.0_beta1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-demo/qt-demo-4.6.0_beta1.ebuild,v 1.1 2009/10/16 16:44:04 wired Exp $
+
+EAPI="2"
+inherit qt4-build
+
+DESCRIPTION="Demonstration module of the Qt toolkit"
+SLOT="4"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="~x11-libs/qt-assistant-${PV}:${SLOT}
+ ~x11-libs/qt-core-${PV}:${SLOT}
+ ~x11-libs/qt-dbus-${PV}:${SLOT}
+ ~x11-libs/qt-gui-${PV}:${SLOT}
+ ~x11-libs/qt-multimedia-${PV}:${SLOT}
+ ~x11-libs/qt-opengl-${PV}:${SLOT}
+ || ( ~x11-libs/qt-phonon-${PV}:${SLOT} media-sound/phonon )
+ ~x11-libs/qt-script-${PV}:${SLOT}
+ ~x11-libs/qt-sql-${PV}:${SLOT}
+ ~x11-libs/qt-svg-${PV}:${SLOT}
+ ~x11-libs/qt-test-${PV}:${SLOT}
+ ~x11-libs/qt-webkit-${PV}:${SLOT}
+ ~x11-libs/qt-xmlpatterns-${PV}:${SLOT}"
+
+RDEPEND="${DEPEND}"
+
+QT4_TARGET_DIRECTORIES="demos
+ examples"
+QT4_EXTRACT_DIRECTORIES="${QT4_TARGET_DIRECTORIES}
+ doc/src/images
+ src/
+ include/
+ tools/"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-4.6-plugandpaint.patch"
+)
+
+src_install() {
+ insinto ${QTDOCDIR}/src
+ doins -r "${S}"/doc/src/images || die "Installing images failed."
+
+ qt4-build_src_install
+}