summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorD.M.D. Ljungmark <spider@gentoo.org>2002-06-17 22:57:47 +0000
committerD.M.D. Ljungmark <spider@gentoo.org>2002-06-17 22:57:47 +0000
commit281716783e02939888b0896b9e97bd082c389c44 (patch)
tree84ee57cb8b89109c216489d73e5e9ca7d082c7fc /x11-libs/gtkmm/gtkmm-1.3.15.ebuild
parentversion update (diff)
downloadhistorical-281716783e02939888b0896b9e97bd082c389c44.tar.gz
historical-281716783e02939888b0896b9e97bd082c389c44.tar.bz2
historical-281716783e02939888b0896b9e97bd082c389c44.zip
a new version that pulls in the new libsigc++
Diffstat (limited to 'x11-libs/gtkmm/gtkmm-1.3.15.ebuild')
-rw-r--r--x11-libs/gtkmm/gtkmm-1.3.15.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/x11-libs/gtkmm/gtkmm-1.3.15.ebuild b/x11-libs/gtkmm/gtkmm-1.3.15.ebuild
new file mode 100644
index 000000000000..22564d606bbd
--- /dev/null
+++ b/x11-libs/gtkmm/gtkmm-1.3.15.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author: Achim Gottinger <achim@gentoo.org>
+# Maintainer: Spider <spider@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtkmm/gtkmm-1.3.15.ebuild,v 1.1 2002/06/17 22:57:47 spider Exp $
+
+# we want debug on the unstable branch
+inherit debug
+
+S=${WORKDIR}/${P}
+DESCRIPTION="C++ interface for GTK+"
+SRC_URI="http://download.sourceforge.net/${PN}/${P}.tar.gz"
+HOMEPAGE="http://gtkmm.sourceforge.net/"
+
+SLOT="2"
+DEPEND="virtual/glibc
+ >=x11-libs/gtk+-2.0.5
+ >=dev-libs/libsigc++-1.1.11"
+
+RDEPEND=${DEPEND}
+
+src_compile() {
+ local myconf
+
+ if [ "${DEBUG}" ]
+ then
+ myconf="--enable-debug=yes"
+ else
+ myconf="--enable-debug=no"
+ fi
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --sysconfdir=/etc/X11 \
+ --with-xinput=xfree \
+ --with-x \
+ ${myconf} || die "configure failure"
+
+ emake || die "emake failure."
+}
+
+src_install() {
+
+ make DESTDIR=${D} \
+ install || die "make install failure"
+
+
+ dodoc AUTHORS COPYING ChangeLog* HACKING
+ dodoc NEWS* README* TODO
+}
+
+
+
+