summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Baergen <joshuabaergen@gentoo.org>2006-08-10 22:27:25 +0000
committerJoshua Baergen <joshuabaergen@gentoo.org>2006-08-10 22:27:25 +0000
commit7f2bd563a2bdadfcaa8daab4630d54278dab9f0d (patch)
treed09497818d609492acdd8279dddb029ec82422b5 /x11-drivers
parentffvorbis optimizations, vc-1, other less sounding stuff, please test (diff)
downloadhistorical-7f2bd563a2bdadfcaa8daab4630d54278dab9f0d.tar.gz
historical-7f2bd563a2bdadfcaa8daab4630d54278dab9f0d.tar.bz2
historical-7f2bd563a2bdadfcaa8daab4630d54278dab9f0d.zip
Add a patch from upstream that fixes the DRI ABI. (Bug #143419, Sebastian
Bergmann. Thanks to Roderick B. Greening for the upstream poking.) Package-Manager: portage-2.1.1_pre4-r4
Diffstat (limited to 'x11-drivers')
-rw-r--r--x11-drivers/xf86-video-i810/ChangeLog10
-rw-r--r--x11-drivers/xf86-video-i810/files/1.6.4-fix_dri_abi.patch46
-rw-r--r--x11-drivers/xf86-video-i810/files/digest-xf86-video-i810-1.6.4-r16
-rw-r--r--x11-drivers/xf86-video-i810/xf86-video-i810-1.6.4-r1.ebuild33
4 files changed, 94 insertions, 1 deletions
diff --git a/x11-drivers/xf86-video-i810/ChangeLog b/x11-drivers/xf86-video-i810/ChangeLog
index e94567cc4d12..f95c3d37bd75 100644
--- a/x11-drivers/xf86-video-i810/ChangeLog
+++ b/x11-drivers/xf86-video-i810/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for x11-drivers/xf86-video-i810
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-i810/ChangeLog,v 1.30 2006/08/10 01:36:29 joshuabaergen Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-i810/ChangeLog,v 1.31 2006/08/10 22:27:25 joshuabaergen Exp $
+
+*xf86-video-i810-1.6.4-r1 (10 Aug 2006)
+
+ 10 Aug 2006; Joshua Baergen <joshuabaergen@gentoo.org>
+ +files/1.6.4-fix_dri_abi.patch, -xf86-video-i810-1.6.4.ebuild,
+ +xf86-video-i810-1.6.4-r1.ebuild:
+ Add a patch from upstream that fixes the DRI ABI. (Bug #143419, Sebastian
+ Bergmann. Thanks to Roderick B. Greening for the upstream poking.)
*xf86-video-i810-1.6.4 (10 Aug 2006)
diff --git a/x11-drivers/xf86-video-i810/files/1.6.4-fix_dri_abi.patch b/x11-drivers/xf86-video-i810/files/1.6.4-fix_dri_abi.patch
new file mode 100644
index 000000000000..5845f748efd2
--- /dev/null
+++ b/x11-drivers/xf86-video-i810/files/1.6.4-fix_dri_abi.patch
@@ -0,0 +1,46 @@
+diff --git a/src/i830_dri.h b/src/i830_dri.h
+index f97c1dd..44be353 100644
+--- a/src/i830_dri.h
++++ b/src/i830_dri.h
+@@ -3,7 +3,6 @@
+ #ifndef _I830_DRI_H
+ #define _I830_DRI_H
+
+-#include "xf86dri.h"
+ #include "xf86drm.h"
+ #include "i830_common.h"
+
+@@ -19,6 +18,21 @@ typedef struct _I830DRIRec {
+ drm_handle_t regs;
+ drmSize regsSize;
+
++ drmSize unused1; /* backbufferSize */
++ drm_handle_t unused2; /* backbuffer */
++
++ drmSize unused3; /* depthbufferSize */
++ drm_handle_t unused4; /* depthbuffer */
++
++ drmSize unused5; /* rotatedSize /*/
++ drm_handle_t unused6; /* rotatedbuffer */
++
++ drm_handle_t unused7; /* textures */
++ int unused8; /* textureSize */
++
++ drm_handle_t unused9; /* agp_buffers */
++ drmSize unused10; /* agp_buf_size */
++
+ int deviceID;
+ int width;
+ int height;
+@@ -26,6 +40,11 @@ typedef struct _I830DRIRec {
+ int cpp;
+ int bitsPerPixel;
+
++ int unused11[8]; /* was front/back/depth/rotated offset/pitch */
++
++ int unused12; /* logTextureGranularity */
++ int unused13; /* textureOffset */
++
+ int irq;
+ int sarea_priv_offset;
+ } I830DRIRec, *I830DRIPtr;
diff --git a/x11-drivers/xf86-video-i810/files/digest-xf86-video-i810-1.6.4-r1 b/x11-drivers/xf86-video-i810/files/digest-xf86-video-i810-1.6.4-r1
new file mode 100644
index 000000000000..a2ad3179b915
--- /dev/null
+++ b/x11-drivers/xf86-video-i810/files/digest-xf86-video-i810-1.6.4-r1
@@ -0,0 +1,6 @@
+MD5 1b8cfd2923836ee93eda69abe50dda04 x11-driver-patches-1.tar.bz2 389
+RMD160 0c57d4b235d83f3d7c46691c13857fd121ddec2d x11-driver-patches-1.tar.bz2 389
+SHA256 64787d5b57d2845c0fa9297a9d924093ba191fc3551798239d9983f0bcca9b3e x11-driver-patches-1.tar.bz2 389
+MD5 56e24a79cccb1d3828de48cb9a7a61b6 xf86-video-i810-1.6.4.tar.bz2 444453
+RMD160 d46554a3384cb51b43f28ec51cb51720677d3050 xf86-video-i810-1.6.4.tar.bz2 444453
+SHA256 0d9fe2a4923df6b1d6ff1b17332ff4c9a5f84d4a376ad4b0fd3223b2dd939351 xf86-video-i810-1.6.4.tar.bz2 444453
diff --git a/x11-drivers/xf86-video-i810/xf86-video-i810-1.6.4-r1.ebuild b/x11-drivers/xf86-video-i810/xf86-video-i810-1.6.4-r1.ebuild
new file mode 100644
index 000000000000..ae4658c28c06
--- /dev/null
+++ b/x11-drivers/xf86-video-i810/xf86-video-i810-1.6.4-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-i810/xf86-video-i810-1.6.4-r1.ebuild,v 1.1 2006/08/10 22:27:25 joshuabaergen Exp $
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+
+inherit x-modular
+
+DESCRIPTION="X.Org driver for Intel cards"
+KEYWORDS="~amd64 ~ia64 ~sh ~x86 ~x86-fbsd"
+IUSE="dri"
+RDEPEND=">=x11-base/xorg-server-1.0.99
+ x11-libs/libXvMC"
+DEPEND="${RDEPEND}
+ x11-proto/fontsproto
+ x11-proto/randrproto
+ x11-proto/renderproto
+ x11-proto/xextproto
+ x11-proto/xproto
+ dri? ( x11-proto/xf86driproto
+ >=x11-libs/libdrm-2
+ x11-libs/libX11 )"
+
+PATCHES="${FILESDIR}/${PV}-fix_dri_abi.patch"
+
+CONFIGURE_OPTIONS="$(use_enable dri)"
+
+pkg_setup() {
+ if use dri && ! built_with_use x11-base/xorg-server dri; then
+ die "Build x11-base/xorg-server with USE=dri."
+ fi
+}