summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Baergen <joshuabaergen@gentoo.org>2005-12-18 19:59:51 +0000
committerJoshua Baergen <joshuabaergen@gentoo.org>2005-12-18 19:59:51 +0000
commit866a86bd20b75fc65c9b03c670d932bb44a414c0 (patch)
treeb9067880bbb41123a0e20abb93419898b7f6a339 /x11-apps/xdm
parentBump to new version; bug #115946 (diff)
downloadhistorical-866a86bd20b75fc65c9b03c670d932bb44a414c0.tar.gz
historical-866a86bd20b75fc65c9b03c670d932bb44a414c0.tar.bz2
historical-866a86bd20b75fc65c9b03c670d932bb44a414c0.zip
Bump for 7.0RC4.
Package-Manager: portage-2.1_pre1
Diffstat (limited to 'x11-apps/xdm')
-rw-r--r--x11-apps/xdm/ChangeLog7
-rw-r--r--x11-apps/xdm/files/digest-xdm-1.0.01
-rw-r--r--x11-apps/xdm/xdm-1.0.0.ebuild38
3 files changed, 45 insertions, 1 deletions
diff --git a/x11-apps/xdm/ChangeLog b/x11-apps/xdm/ChangeLog
index fc7e68228dd7..7055958ef990 100644
--- a/x11-apps/xdm/ChangeLog
+++ b/x11-apps/xdm/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-apps/xdm
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-apps/xdm/ChangeLog,v 1.30 2005/12/09 15:25:24 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xdm/ChangeLog,v 1.31 2005/12/18 19:29:54 joshuabaergen Exp $
+
+*xdm-1.0.0 (18 Dec 2005)
+
+ 18 Dec 2005; Joshua Baergen <joshuabaergen@gentoo.org> +xdm-1.0.0.ebuild:
+ Bump for 7.0RC4.
09 Dec 2005; Donnie Berkholz <spyderous@gentoo.org>;
-files/gentoo_locations-0.99.3.patch, -files/gentoo_locations.patch:
diff --git a/x11-apps/xdm/files/digest-xdm-1.0.0 b/x11-apps/xdm/files/digest-xdm-1.0.0
new file mode 100644
index 000000000000..ef2de6361459
--- /dev/null
+++ b/x11-apps/xdm/files/digest-xdm-1.0.0
@@ -0,0 +1 @@
+MD5 8b680eaf629f98638df1bf1919acc6ab xdm-1.0.0.tar.bz2 377686
diff --git a/x11-apps/xdm/xdm-1.0.0.ebuild b/x11-apps/xdm/xdm-1.0.0.ebuild
new file mode 100644
index 000000000000..8e392d40e018
--- /dev/null
+++ b/x11-apps/xdm/xdm-1.0.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xdm/xdm-1.0.0.ebuild,v 1.1 2005/12/18 19:29:54 joshuabaergen Exp $
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+
+inherit multilib x-modular pam
+
+DESCRIPTION="X.Org xdm application"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~s390 ~sh ~sparc ~x86"
+IUSE="xprint ipv6 pam"
+RDEPEND="x11-apps/xrdb
+ x11-libs/libXdmcp
+ x11-libs/libXaw
+ >=x11-apps/xinit-0.99.1_pre20050905-r1
+ x11-libs/libX11
+ x11-libs/libXt"
+DEPEND="${RDEPEND}
+ x11-proto/xproto"
+
+CONFIGURE_OPTIONS="$(use_enable xprint)
+ $(use_enable ipv6)
+ $(use_with pam)
+ --with-xdmconfigdir=/etc/X11/xdm"
+
+pkg_setup() {
+ if use xprint && ! built_with_use x11-libs/libXaw xprint; then
+ die "Build x11-libs/libXaw with USE=xprint."
+ fi
+}
+
+src_install() {
+ x-modular_src_install
+ exeinto /usr/$(get_libdir)/X11/xdm
+ doexe ${FILESDIR}/Xsession
+ newpamd ${FILESDIR}/xdm.pamd xdm
+}