summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKonstantin V. Arkhipov <voxus@gentoo.org>2006-07-07 20:51:17 +0000
committerKonstantin V. Arkhipov <voxus@gentoo.org>2006-07-07 20:51:17 +0000
commit2cc92f57c3ac6c66cd35e027dc5c40c6e2fc8eb5 (patch)
tree4ba3234a16203664628a608f1f9d4b909cf43c37 /www-servers
parentURL update (bug #139357). (diff)
downloadhistorical-2cc92f57c3ac6c66cd35e027dc5c40c6e2fc8eb5.tar.gz
historical-2cc92f57c3ac6c66cd35e027dc5c40c6e2fc8eb5.tar.bz2
historical-2cc92f57c3ac6c66cd35e027dc5c40c6e2fc8eb5.zip
* bump
Package-Manager: portage-2.1.1_pre2-r4
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/nginx/ChangeLog8
-rw-r--r--www-servers/nginx/files/digest-nginx-0.3.533
-rw-r--r--www-servers/nginx/nginx-0.3.53.ebuild79
3 files changed, 89 insertions, 1 deletions
diff --git a/www-servers/nginx/ChangeLog b/www-servers/nginx/ChangeLog
index 78f58d760bfc..1b5bf023f9f8 100644
--- a/www-servers/nginx/ChangeLog
+++ b/www-servers/nginx/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-servers/nginx
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/ChangeLog,v 1.98 2006/07/04 16:58:38 voxus Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/ChangeLog,v 1.99 2006/07/07 20:51:17 voxus Exp $
+
+*nginx-0.3.53 (07 Jul 2006)
+
+ 07 Jul 2006; Konstantin Arkhipov <voxus@gentoo.org> +nginx-0.3.53.ebuild,
+ -nginx-0.3.52.ebuild:
+ Bump, http_realip_module now build automatically with fastcgi enabled.
*nginx-0.3.52 (04 Jul 2006)
diff --git a/www-servers/nginx/files/digest-nginx-0.3.53 b/www-servers/nginx/files/digest-nginx-0.3.53
new file mode 100644
index 000000000000..abead4c9ea1a
--- /dev/null
+++ b/www-servers/nginx/files/digest-nginx-0.3.53
@@ -0,0 +1,3 @@
+MD5 c05426aeaa8a5b142ce3aa24082812f4 nginx-0.3.53.tar.gz 407129
+RMD160 3d8fef05d00560504b39746faa8d777bc9c122cc nginx-0.3.53.tar.gz 407129
+SHA256 944a11986124ddbb43ad303abe951b54ea18479eb1cc396b42beddeeaffc7c41 nginx-0.3.53.tar.gz 407129
diff --git a/www-servers/nginx/nginx-0.3.53.ebuild b/www-servers/nginx/nginx-0.3.53.ebuild
new file mode 100644
index 000000000000..223c2e4d0ff5
--- /dev/null
+++ b/www-servers/nginx/nginx-0.3.53.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/nginx-0.3.53.ebuild,v 1.1 2006/07/07 20:51:17 voxus Exp $
+
+inherit eutils
+
+DESCRIPTION="Robust, small and high performance http and reverse proxy server"
+
+HOMEPAGE="http://sysoev.ru/nginx/"
+SRC_URI="http://sysoev.ru/nginx/${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug fastcgi imap pcre perl threads ssl zlib"
+
+DEPEND="dev-lang/perl
+ pcre? ( >=dev-libs/libpcre-4.2 )
+ ssl? ( dev-libs/openssl )
+ zlib? ( sys-libs/zlib )
+ perl? ( >=dev-lang/perl-5.8 )"
+
+src_compile() {
+ local myconf
+
+ if use threads; then
+ einfo
+ ewarn "threads support is experimental at the moment"
+ ewarn "do not use it on production systems - you've been warned"
+ einfo
+ myconf="${myconf} --with-threads"
+ fi
+
+ use fastcgi || myconf="${myconf} --without-http_fastcgi_module"
+ use fastcgi && myconf="${myconf} --with-http_realip_module"
+ use zlib || myconf="${myconf} --without-http_gzip_module"
+ use pcre || {
+ myconf="${myconf} --without-pcre --without-http_rewrite_module"
+ }
+ use debug && myconf="${myconf} --with-debug"
+ use ssl && myconf="${myconf} --with-http_ssl_module"
+ use imap && myconf="${myconf} --with-imap" # pop3/imap4 proxy support
+ use perl && myconf="${myconf} --with-http_perl_module"
+
+ ./configure \
+ --prefix=/usr \
+ --conf-path=/etc/${PN}/${PN}.conf \
+ --http-log-path=/var/log/${PN}/access_log \
+ --error-log-path=/var/log/${PN}/error_log \
+ --pid-path=/var/run/${PN}.pid \
+ --http-client-body-temp-path=/var/tmp/${PN}/client \
+ --http-proxy-temp-path=/var/tmp/${PN}/proxy \
+ --http-fastcgi-temp-path=/var/tmp/${PN}/fastcgi \
+ --with-md5-asm --with-md5=/usr/include \
+ ${myconf} || die "configure failed"
+
+ emake || die "failed to compile"
+}
+
+src_install() {
+ keepdir /var/log/${PN} /var/tmp/${PN}/{client,proxy,fastcgi}
+
+ dosbin objs/nginx
+ cp ${FILESDIR}/nginx-r1 ${T}/nginx
+ doinitd ${T}/nginx
+
+ rm conf/nginx.conf
+ cp ${FILESDIR}/nginx.conf-r2 ${T}/nginx.conf
+
+ dodir /etc/${PN}
+ insinto /etc/${PN}
+ doins conf/* ${T}/nginx.conf
+
+ dodoc CHANGES{,.ru} LICENSE README
+
+ use perl && {
+ cd ${S}/objs/src/http/modules/perl/
+ make DESTDIR=${D} install || die "failed to install perl stuff"
+ }
+}