summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2015-07-22 12:21:14 +0000
committerPatrice Clement <monsieurp@gentoo.org>2015-07-22 12:21:14 +0000
commitbd90cf8e83c793deb342dc9970de6b3f5315802f (patch)
tree42e4f997bd12bac8ebac3dcbead63922d6fdbfa1 /www-servers/tomcat/tomcat-7.0.59-r2.ebuild
parentRemove old. (diff)
downloadhistorical-bd90cf8e83c793deb342dc9970de6b3f5315802f.tar.gz
historical-bd90cf8e83c793deb342dc9970de6b3f5315802f.tar.bz2
historical-bd90cf8e83c793deb342dc9970de6b3f5315802f.zip
Feed dodir and fperms functions with the ${dest} variable. This variable is
already formatted with the $CATALINA_BASE full path. Fix security bug 458890. Signed-off-by: Patrice Clement <monsieurp@gentoo.org> Package-Manager: portage-2.2.18/cvs/Linux x86_64 Manifest-Sign-Key: 0x93491BB8
Diffstat (limited to 'www-servers/tomcat/tomcat-7.0.59-r2.ebuild')
-rw-r--r--www-servers/tomcat/tomcat-7.0.59-r2.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/www-servers/tomcat/tomcat-7.0.59-r2.ebuild b/www-servers/tomcat/tomcat-7.0.59-r2.ebuild
index 0c083f945c73..ea658fdbfd6d 100644
--- a/www-servers/tomcat/tomcat-7.0.59-r2.ebuild
+++ b/www-servers/tomcat/tomcat-7.0.59-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/tomcat/tomcat-7.0.59-r2.ebuild,v 1.1 2015/07/21 15:33:26 monsieurp Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/tomcat/tomcat-7.0.59-r2.ebuild,v 1.2 2015/07/22 12:21:07 monsieurp Exp $
EAPI=5
@@ -109,8 +109,8 @@ src_install() {
# create "logs" directory in $CATALINA_BASE
# and set correct perms, see #458890
- dodir logs
- fperms 0750 logs
+ dodir "${dest}"/logs
+ fperms 0750 "${dest}"/logs
# replace the default pw with a random one, see #92281
local randpw=$(echo ${RANDOM}|md5sum|cut -c 1-15)